Bug 2434 - VLC is crashed while starting
: VLC is crashed while starting
Status: RESOLVED DUPLICATE of bug 2321
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: x86_64 Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-02 12:39 MSD by FirstLevel
Modified: 2013-08-05 10:50 MSD (History)
3 users (show)

See Also:
RPM Package: vlc-2.0.6-1plf-plf2012.1.x86_64
ISO-related:
Bad POT generating:
Upstream:


Attachments
diagnosctic information (3.97 KB, text/plain)
2013-08-02 12:39 MSD, FirstLevel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2013-08-02 12:39:11 MSD
Created attachment 1728 [details]
diagnosctic information

Description of problem:
I have installed ROSA 2012.1 Fresh x64 and tried to use VLC. But it is crashed while starting
[andrei@rosand ~]$ vlc
VLC media player 2.0.6 Twoflower (revision 2.0.6-0-gbe9623c)
Ошибка сегментирования (слепок снят)

The situation is repeated for new created user and after reinstall VLC.

I have attached diagnostic information

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 Denis Silakov 2013-08-02 12:53:58 MSD
Can you try the new vlc 2.0.8 from the bug #2414?
Comment 2 Eugene Shatokhin 2013-08-02 12:55:03 MSD
If it still crashes, please post the output of 'vlc -vvv' here too.
Comment 3 FirstLevel 2013-08-02 20:54:58 MSD
(In reply to comment #2)
> If it still crashes, please post the output of 'vlc -vvv' here too.
Case is not actual. After second reinstallation VLC installed with many dependencies and problem is solved.
I think it maybe mirror problem.
Comment 4 FirstLevel 2013-08-05 08:50:34 MSD
This is my fault. Problem is not solved, because user has installed 32bit version of VLC instead.
For 64bit VLC another user has same problem.
And You can see such output in debugger:
(gdb) run
Starting program: /usr/bin/vlc 
warning: no loadable sections found in added symbol-file system-supplied DSO at 0x7ffff7ffa000
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
VLC media player 2.0.6 Twoflower (revision 2.0.6-0-gbe9623c)

Program received signal SIGSEGV, Segmentation fault.
0x00007ffff7231798 in __strcmp_sse42 () from /lib64/libc.so.6
(gdb) backtrace
#0  0x00007ffff7231798 in __strcmp_sse42 () from /lib64/libc.so.6
#1  0x00007ffff35e6e19 in g_str_equal () from /lib64/libglib-2.0.so.0
#2  0x00007ffff35e654f in g_hash_table_lookup () from /lib64/libglib-2.0.so.0
#3  0x00007ffff3605a5f in g_quark_from_static_string () from /lib64/libglib-2.0.so.0
#4  0x00007fffec1c86d0 in ?? () from /lib64/libgobject-2.0.so.0
#5  0x00007ffff7debe66 in call_init.part.0 () from /lib64/ld-linux-x86-64.so.2
#6  0x00007ffff7debf20 in _dl_init_internal () from /lib64/ld-linux-x86-64.so.2
#7  0x00007ffff7df02ad in dl_open_worker () from /lib64/ld-linux-x86-64.so.2
#8  0x00007ffff7debcf6 in _dl_catch_error () from /lib64/ld-linux-x86-64.so.2
#9  0x00007ffff7defb3c in _dl_open () from /lib64/ld-linux-x86-64.so.2
#10 0x00007ffff74bb016 in ?? () from /lib64/libdl.so.2
#11 0x00007ffff7debcf6 in _dl_catch_error () from /lib64/ld-linux-x86-64.so.2
#12 0x00007ffff74bb62c in ?? () from /lib64/libdl.so.2
#13 0x00007ffff74bb0b1 in dlopen () from /lib64/libdl.so.2
#14 0x00007ffff797aa1d in module_Load (p_this=0x605108, psz_file=<optimized out>, p_handle=0x7fffffffd328, lazy=<optimized out>)
    at posix/plugin.c:62
#15 0x00007ffff7961be8 in module_InitDynamic (obj=0x605108, path=0x846e40 "/usr/lib64/vlc/plugins/gui/libqt4_plugin.so", fast=<optimized out>)
    at modules/bank.c:536
#16 0x00007ffff7961ebb in AllocatePluginFile (st=<optimized out>, relpath=<optimized out>, abspath=<optimized out>, bank=<optimized out>)
    at modules/bank.c:479
#17 AllocatePluginDir (bank=0x7fffffffd560, maxdepth=3961507632, absdir=0xffff <Address 0xffff out of bounds>, reldir=0x6dd3f0 "gui")
    at modules/bank.c:440
#18 0x00007ffff79620ad in AllocatePluginDir (bank=0x7fffffffd560, maxdepth=3961507632, absdir=0xffff <Address 0xffff out of bounds>, 
    reldir=0x0) at modules/bank.c:444
#19 0x00007ffff79621d0 in AllocatePluginPath (p_this=0x605108, path=0x619e60 "/usr/lib64/vlc/plugins", mode=CACHE_USE) at modules/bank.c:353
#20 0x00007ffff796285d in AllocateAllPlugins (p_this=0x605108) at modules/bank.c:282
#21 module_LoadPlugins (obj=0x605108) at modules/bank.c:189
#22 0x00007ffff78f78bb in libvlc_InternalInit (p_libvlc=0x605108, i_argc=3, ppsz_argv=0x7fffffffd8f0) at libvlc.c:247
#23 0x00007ffff7bc9fb5 in libvlc_new (argc=2, argv=<optimized out>) at core.c:59
Comment 5 Eugene Shatokhin 2013-08-05 10:50:41 MSD
Thanks for the info, esp. for the backtrace. Looks like a duplicate of http://bugs.rosalinux.ru/show_bug.cgi?id=2321.

*** This bug has been marked as a duplicate of bug 2321 ***