Bug 2430 - Canon Laser Shot LBP-1120 could not print
: Canon Laser Shot LBP-1120 could not print
Status: RESOLVED INVALID
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-01 15:14 MSD by FirstLevel
Modified: 2014-10-08 17:14 MSD (History)
3 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2013-08-01 15:14:51 MSD
Description of problem:
I have installed ROSA 2012.1 64bit Fresh and tried to use my printer Canon Laser Shot LBP-1120.
I have installed cndrvcups-lb-2.50-3-rosa2012.1.i586 package and setted up printer,
But if I send some file to printer it could not print.

Before sending job to printer:
[root@rosand andrei]# lpq
Canon-LASER-SHOT-LBP-1120 is ready
no entries

After sending job to printer:
[root@rosand andrei]# lpq
Canon-LASER-SHOT-LBP-1120 is ready and printing
Rank    Owner   Job     File(s)                         Total Size
active  root    15      Test Page                       1024 bytes

Lsusb output:

[root@rosand andrei]# lsusb
Bus 004 Device 002: ID 1bcf:053a Sunplus Innovation Technology Inc. Targa Silvercrest OMC807-C optische Funkmaus
Bus 004 Device 003: ID 04a9:262b Canon, Inc. LaserShot LBP-1120 Printer
Bus 007 Device 002: ID 04f2:b071 Chicony Electronics Co., Ltd 2.0M UVC Webcam / CNF7129
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 008 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Configuration file:

[root@rosand andrei]# cat /etc/cups/printers.conf
# Printer configuration file for CUPS v1.5.4
# Written by cupsd on 2013-08-01 13:57
# DO NOT EDIT THIS FILE WHEN CUPSD IS RUNNING
<DefaultPrinter Canon-LASER-SHOT-LBP-1120>
UUID urn:uuid:9c3547b4-e0c0-3cd9-78e3-edef2263b045
Info Canon LASER SHOT LBP-1120
Location rosand
MakeModel Canon LBP-1120 Foomatic/capt (recommended)
DeviceURI usb://Canon/LASER%20SHOT%20LBP-1120?serial=35D8GO
State Idle
StateTime 1375354666
Type 8392708
Accepting Yes
Shared Yes
JobSheets none none
QuotaPeriod 0
PageLimit 0
KLimit 0
OpPolicy default
ErrorPolicy stop-printer
</Printer>



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 Denis Silakov 2013-08-01 15:21:51 MSD
Please try the 'capt' driver (cups-drivers-capt package), not cndrvcups-lb.
Comment 2 FirstLevel 2013-08-01 16:53:02 MSD
(In reply to comment #1)
> Please try the 'capt' driver (cups-drivers-capt package), not cndrvcups-lb.

At the beginning of the case user has another configuration for his printer with same problem.

[root@rosand /]# cat /etc/cups/printers.conf
# Printer configuration file for CUPS v1.5.4
# Written by cupsd on 2013-07-30 11:49
# DO NOT EDIT THIS FILE WHEN CUPSD IS RUNNING
<DefaultPrinter Canon-LASER-SHOT-LBP-1120>
UUID urn:uuid:e98b7fda-b7ef-333c-46f7-28cd18e28bb3
Info Canon LASER SHOT LBP-1120
Location rosand
MakeModel Canon LBP-1120 Foomatic/capt (recommended)
DeviceURI usb://Canon/LASER%20SHOT%20LBP-1120?serial=35D8GO
State Idle
StateTime 1375174131
Type 8392708
Accepting Yes
Shared Yes
JobSheets none none
QuotaPeriod 0
PageLimit 0
KLimit 0
OpPolicy default
ErrorPolicy stop-printer
</Printer>
[root@rosand /]# lsusb
Bus 004 Device 002: ID 1bcf:053a Sunplus Innovation Technology Inc. Targa Silvercrest OMC807-C optische Funkmaus
Bus 004 Device 003: ID 04a9:262b Canon, Inc. LaserShot LBP-1120 Printer
Bus 007 Device 002: ID 04f2:b071 Chicony Electronics Co., Ltd 2.0M UVC Webcam / CNF7129
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 008 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
[root@rosand /]# systemctl status cups.service
cups.service - CUPS Printing Service
          Loaded: loaded (/lib/systemd/system/cups.service; enabled)
          Active: active (running) since Tue, 30 Jul 2013 10:56:42 +0300; 1h 16min ago
        Main PID: 2926 (cupsd)
          CGroup: name=systemd:/system/cups.service
                  └ 2926 /usr/sbin/cupsd -f

Jul 30 10:56:42 rosand systemd[1]: Starting CUPS Printing Service...
Jul 30 10:56:42 rosand systemd[1]: Started CUPS Printing Service.
Jul 30 11:45:48 rosand systemd[1]: Started CUPS Printing Service.
Jul 30 11:48:42 rosand systemd[1]: Started CUPS Printing Service.
Jul 30 11:54:10 rosand systemd[1]: Started CUPS Printing Service.
[root@rosand /]# lpq
Canon-LASER-SHOT-LBP-1120 is ready
no entries
[root@rosand /]# lpq
Canon-LASER-SHOT-LBP-1120 is ready and printing
Rank    Owner   Job     File(s)                         Total Size
active  root    4       Test Page                       1024 bytes
Comment 3 FirstLevel 2014-06-03 15:34:01 MSD
checking the relevance