Bug 2401 - [UPDATE REQUEST] x11-server 1.13.3 -> 1.13.4
: [UPDATE REQUEST] x11-server 1.13.3 -> 1.13.4
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-29 16:41 MSD by Andrey Bondrov
Modified: 2013-08-06 16:27 MSD (History)
3 users (show)

See Also:
RPM Package: x11-server
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Bondrov 2013-07-29 16:41:05 MSD
Let's have latest bugfix version from 1.13.x branch.
Comment 1 Andrey Bondrov 2013-07-29 16:43:18 MSD
Advisory: 
"Bugfix version 1.13.4. Notable changes since 1.13.3:
- fix crash on 24bpp host framebuffer
- fix flush input to work with Linux evdev devices
- only show the cursor if a window defines one"

https://abf.rosalinux.ru/build_lists/1197636
https://abf.rosalinux.ru/build_lists/1197637
Comment 2 Vladimir Potapov 2013-07-29 18:52:46 MSD
The package route to extended testing
Comment 3 Postnikov Dmitry 2013-08-01 00:19:39 MSD
****************************
Extended testing report
****************************
Tested on 4 computers. X11perf passed all gloss too, extremtuxracer, supertuxkart too, all gone. Vesa modes, fbdev and modesetting all work. Regressions not found. On the same computer passed all the tests gpu program from the site http://www.geeks3d.com/gputest/
Testing in Gnome64, Gnome32, KDE64
Comment 4 Vladimir Potapov 2013-08-01 05:37:25 MSD
x11-server-1.13.4-1-rosa2012.1
*********************** Advisory **********************
Bugfix version 1.13.4
********************** Changelog **********************
- fix crash on 24bpp host framebuffer
- fix flush input to work with Linux evdev devices
- only show the cursor if a window defines one
*******************************************************
QA Verified