Bug 240 - Don't work landscape print from LibreOffice Writer
: Don't work landscape print from LibreOffice Writer
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Normal enhancement
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-18 12:27 MSD by Denis
Modified: 2013-02-21 11:09 MSK (History)
5 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments
Report (11.05 KB, application/vnd.oasis.opendocument.text)
2013-02-19 14:24 MSK, Postnikov Dmitry
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Denis 2012-05-18 12:27:03 MSD
Description of problem:
Don't work landscape print from LibreOffice Writer

Version-Release number of selected component (if applicable):
LibreOffice 3.4.5 

How reproducible:
Always 

Steps to Reproduce:
1. Set page format to Landscape
2. Send page to printer

Error in mail queue:
"/usr/lib/cups/filter/hpcups failed"
from all another programs prints correctly
Comment 1 Denis Silakov 2013-02-07 17:07:34 MSK
The problem still exists and comes from ghostscript which fails during print attempt:

gs[5656]: segfault at 2ced000 ip 00000037a94803ba sp 00007fff6d2f77f8 error 6 in libc-2.13.so[37a9400000+182000]

Updating to ghostscript 9.05 from Desktop Fresh 2012 helps to avoid this issue.

So I think it makes sense to just backport newer ghostscript to Marathon (which currently has version 9.02).

Complete history of changes in ghostscript 9.xx series can be found here:

http://git.ghostscript.com/?p=ghostpdl.git;a=blob_plain;f=gs/doc/History9.htm;h=dd77327c116d589492003259a189611b69dcac59;hb=HEAD

The most interesting things for us are different fixes in page rotating and page size fitting. There are also several other bug fixes with respect to version 9.02 used in Marathon, as well as some gs interpreter optimizations.

Advisory:
Updated ghostscript to 9.05 to fix issues with page rotations, in particular Landscape printing from LibreOffice.

Build lists:
https://abf.rosalinux.ru/build_lists/942466
https://abf.rosalinux.ru/build_lists/942467
Comment 2 Vladimir Potapov 2013-02-08 13:37:10 MSK
Hm, I can't reproduce the error...
Set setting to landscape in LO or in printer driver parameters?
Comment 3 Denis Silakov 2013-02-08 13:49:35 MSK
I set 'Landscape' in LO (Format -> Page -> Orientation).

I experimented with 64bit system, there can be difference between 32bit and 64bit for such kind of errors.
Comment 4 Vladimir Potapov 2013-02-08 14:57:51 MSK
My hp1315 print all orientations of pages without update.
Bugsubmiter confirm a fix?
Comment 5 Vladimir Potapov 2013-02-14 09:57:11 MSK
This update route to extended testing
Comment 6 Postnikov Dmitry 2013-02-18 20:46:38 MSK
(In reply to comment #5)
> This update route to extended testing

*****************************
Extended testing report
****************************

Print landscape in Rosa Marathon 64bit without update, and with update.
Comment 7 Alexander Petryakov 2013-02-18 23:09:35 MSK
I can confirm that landscape print don't work.
After update printing work fine.
Comment 8 Vladimir Potapov 2013-02-19 07:09:29 MSK
(In reply to comment #6)
> (In reply to comment #5)
> > This update route to extended testing
> 
> *****************************
> Extended testing report
> ****************************
> 
> Print landscape in Rosa Marathon 64bit without update, and with update.

Where is the report?
Comment 9 Postnikov Dmitry 2013-02-19 14:24:23 MSK
Created attachment 1215 [details]
Report
Comment 10 Vladimir Potapov 2013-02-19 14:31:14 MSK
ghostscript-9.05-4-rosa.lts2012.0
******************** Advisory ********************
Updated ghostscript to 9.05 to fix issues with page rotations, in particular Landscape printing from LibreOffice on some configurations.
**************************************************
QA Verified