Bug 2396 - Dolphin crash play any video in details mode
: Dolphin crash play any video in details mode
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: x86_64 Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-28 17:48 MSD by Postnikov Dmitry
Modified: 2015-03-17 00:42 MSK (History)
3 users (show)

See Also:
RPM Package: dolphin-4.10.5-1-rosa2012.1.x86_64
ISO-related:
Bad POT generating:
Upstream:


Attachments
ff15.png (303.30 KB, image/png)
2013-07-28 17:48 MSD, Postnikov Dmitry
Details
strace-dolphin.txt (11.23 KB, text/plain)
2013-07-28 18:12 MSD, Postnikov Dmitry
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Postnikov Dmitry 2013-07-28 17:48:11 MSD
Created attachment 1705 [details]
ff15.png

Description of problem:
Dolphin crash play any video in details mode. Of video programs are installed in the system only ROMP and mlt. From audio-only programs Audacity, Audacious, Avidemux.


Steps to Reproduce:
1. Open folder with video file in Dolphin
2. In Dolphin press F11
3. And right panel press "Play".
4. Dolphin crash

In systemlog:
============
[root@mindlife log]# cat /var/log/messages | grep -i -E "dumped"
Jul 28 15:27:51 mindlife [10597]: Process 9040 (multiqueue1:src) dumped core.
Jul 28 15:29:15 mindlife [10689]: Process 10644 (multiqueue1:src) dumped core.
Jul 28 15:32:16 mindlife [10820]: Process 10771 (multiqueue1:src) dumped core.
Jul 28 15:44:06 mindlife [10926]: Process 10884 (multiqueue1:src) dumped core.
Jul 28 16:21:56 mindlife [17654]: Process 17615 (multiqueue1:src) dumped core.
[root@mindlife log]# 
============
Comment 1 Postnikov Dmitry 2013-07-28 18:12:27 MSD
Created attachment 1706 [details]
strace-dolphin.txt

strace Dolphin when it crashes
Comment 2 Eugene Shatokhin 2013-07-29 10:48:47 MSD
Can you try to launch Dolphin under GDB and obtain the backtrace of all threads at the time of crash?
Comment 3 Eugene Shatokhin 2013-07-29 10:51:22 MSD
Please also instal debug symbols for Dolphin, glib and gstreamer for GDB to resolve the source lines in the backtrace.
Comment 4 Postnikov Dmitry 2014-02-07 18:50:42 MSK
Actual in dolphin-4.11.4-1-rosa2012.1.x86_64

============
Feb  7 18:47:35 mindlife-K64R2 systemd-coredump[1840]: Process 30394 (multiqueue2:src) dumped core.
Feb  7 18:48:27 mindlife-K64R2 kernel: [31952.361768] multiqueue1:src[1896]: segfault at 7f88fdd202f0 ip 00007f894445a8db sp 00007f8911c228e8 error 6 in libc-2.15.so[7f8944314000+1ae000]
Feb  7 18:48:28 mindlife-K64R2 systemd-coredump[1906]: Process 1847 (multiqueue1:src) dumped core.
Feb  7 18:49:04 mindlife-K64R2 kernel: [31988.816231] multiqueue1:src[1954]: segfault at 7f8905c66290 ip 00007f894445a8db sp 00007f89124238e8 error 6 in libc-2.15.so[7f8944314000+1ae000]
Feb  7 18:49:04 mindlife-K64R2 systemd-coredump[1965]: Process 1909 (multiqueue1:src) dumped core.
===========
Comment 5 FirstLevel 2014-06-12 13:24:24 MSD
For dolphin-4.12.4-2-rosa2012.1.x86_64 and ATI videocard I have not found any problems with playing video in Dolphin.
Maybe it is solved?
Comment 6 FirstLevel 2014-10-08 21:55:43 MSD
Please could You check the problem for new release 2014.1
Comment 7 Denis Silakov 2015-03-17 00:42:40 MSK
Let's optimistically call this fixed, since we haven't met this problem for a long time.