Bug 2387 - Gimp tool "Operation GEGL" eats a lot of memory and swap
: Gimp tool "Operation GEGL" eats a lot of memory and swap
Status: RESOLVED WORKSFORME
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: x86_64 Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-27 01:25 MSD by Postnikov Dmitry
Modified: 2015-01-28 23:47 MSK (History)
3 users (show)

See Also:
RPM Package: gimp-2.8.6-1-rosa2012.1.x86_64
ISO-related:
Bad POT generating:
Upstream:


Attachments
ff5.png (624.50 KB, image/png)
2013-07-27 01:25 MSD, Postnikov Dmitry
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Postnikov Dmitry 2013-07-27 01:25:43 MSD
Created attachment 1699 [details]
ff5.png

Description of problem:
Gimp tool "Operation GEGL" eats a lot of memory and swap.
I have 8Gb RAM and 8Gb Swap. This operations eats 8Gb RAM and 3Gb swap. This is clearly something.

Version-Release number of selected component (if applicable):
gimp-2.8.6-1-rosa2012.1.x86_64

How reproducible:
Install Gimp

Steps to Reproduce:
1. Open any JPG photo
2. Open Tools->Operation GEGL-> Operation Gubic (or fractal or any ...)
3. And one kernel processors 100% and 8Gb RAM and 3Gb swap it USEs.
Comment 1 Postnikov Dmitry 2013-07-27 01:29:16 MSD
==========
[root@mindlife pastordi]# free -m
             total       used       free     shared    buffers     cached
Mem:          7938       7655        283          0          9        132
-/+ buffers/cache:       7512        425
Swap:         8000       2803       5197
[root@mindlife pastordi]# 
[root@mindlife pastordi]# df
Файловая система Размер Использовано  Дост Использовано% Cмонтировано в
rootfs              50G         8,2G   40G           18% /
devtmpfs           7,0G         4,0K  7,0G            1% /dev
tmpfs              7,0G          80K  7,0G            1% /dev/shm
tmpfs              7,0G         4,4M  7,0G            1% /run
/dev/sda2           50G         8,2G   40G           18% /
tmpfs              7,0G            0  7,0G            0% /sys/fs/cgroup
tmpfs              7,0G         108K  7,0G            1% /tmp
/dev/sda6          1,7T          73G  1,6T            5% /media/DISK2
[root@mindlife pastordi]#
===========
Comment 2 FirstLevel 2014-10-08 14:56:46 MSD
Please check the problem for new release
http://mirror.rosalab.ru/rosa/rosa2014.1/iso/ROSA.Fresh.R4/
Comment 3 Denis Silakov 2015-01-28 23:47:55 MSK
Can't reproduce this with current Gimp. Gegl operation consume resources, but not as much as described in this bug.