Bug 2385 - avahi-daemon chroot.c open failed
: avahi-daemon chroot.c open failed
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-26 22:31 MSD by Postnikov Dmitry
Modified: 2014-03-25 10:46 MSK (History)
4 users (show)

See Also:
RPM Package: avahi-0.6.31-7-rosa2012.1.x86_64
ISO-related:
Bad POT generating:
Upstream:


Attachments
messages.log.txt (1.46 MB, text/plain)
2013-07-26 22:31 MSD, Postnikov Dmitry
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Postnikov Dmitry 2013-07-26 22:31:06 MSD
Created attachment 1698 [details]
messages.log.txt

Description of problem:
avahi-daemon chroot.c open failed in system log.

============
Jul 26 22:11:27 localhost systemd[1]: Started Avahi mDNS/DNS-SD Stack.
Jul 26 22:11:27 localhost avahi-daemon[1668]: Successfully called chroot().
Jul 26 22:11:27 localhost avahi-daemon[1668]: Successfully dropped remaining capabilities.
Jul 26 22:11:27 localhost avahi-daemon[1675]: chroot.c: open() failed: No such file or directory
Jul 26 22:11:27 localhost avahi-daemon[1668]: Failed to open /etc/resolv.conf: Invalid argument
Jul 26 22:11:27 localhost avahi-daemon[1668]: Loading service file /services/openssh.service.
Jul 26 22:11:27 localhost avahi-daemon[1668]: Loading service file /services/sftp-ssh.service.
Jul 26 22:11:27 localhost avahi-daemon[1668]: Loading service file /services/udisks.service.
Jul 26 22:11:27 localhost avahi-daemon[1668]: System host name is set to 'localhost'. This is not a suitable mDNS host name, looking for alternatives.
Jul 26 22:11:27 localhost avahi-daemon[1668]: Network interface enumeration completed.
Jul 26 22:11:27 localhost avahi-daemon[1668]: Registering HINFO record with values 'X86_64'/'LINUX'.
Jul 26 22:11:27 localhost avahi-daemon[1668]: Server startup complete. Host name is linux.local. Local service cookie is 1985351668.
Jul 26 22:11:27 localhost avahi-daemon[1668]: Service "linux" (/services/udisks.service) successfully established.
Jul 26 22:11:27 localhost avahi-daemon[1668]: Service "linux" (/services/sftp-ssh.service) successfully established.
Jul 26 22:11:27 localhost avahi-daemon[1668]: Service "Remote Access on linux" (/services/openssh.service) successfully established.
Jul 26 22:11:27 localhost avahi-dnsconfd[1641]: Successfully connected to Avahi daemon.
Jul 26 22:11:32 localhost avahi-daemon[1668]: Joining mDNS multicast group on interface eth0.IPv4 with address 192.168.0.4.
Jul 26 22:11:32 localhost avahi-daemon[1668]: New relevant interface eth0.IPv4 for mDNS.
Jul 26 22:11:32 localhost avahi-daemon[1668]: Registering new address record for 192.168.0.4 on eth0.IPv4.
Jul 26 22:11:32 localhost avahi-daemon[1668]: Registering new address record for fe80::d63d:7eff:fe94:3a78 on eth0.*.
==================
Comment 1 Aleksandr Kazantcev 2013-07-26 22:51:04 MSD
Is avahi-daemon not work? This is only say, than nothing to open...

I not confirm this error, especially if you used localhost as computer name. Some network service failed with it. Set another hostname and try. If error appear again confirm it.
Comment 2 Postnikov Dmitry 2013-07-26 23:31:23 MSD
After you change the computer name, avahi no errors in the logs. If return the computer name on localhost.localdomain then the error appears. But all work under any name of your computer.
Comment 3 Aleksandr Kazantcev 2013-07-26 23:34:01 MSD
This is not error - network service strongly need real hostname - not localhost.localdomane. If you want work with some network service, like avahi, samba, nfs etc you need set computer host name.
Comment 4 Postnikov Dmitry 2013-07-26 23:36:59 MSD
Can make the auto generated computer name distinctive from localhost.localdomane , when installing the system?
Comment 5 Eugene Shatokhin 2013-07-29 10:22:14 MSD
(In reply to comment #4)
> Can make the auto generated computer name distinctive from
> localhost.localdomane , when installing the system?

IIRC, we have something like that already. At least, the default host name is set to "<username>-computer" rather than "localhost.localdomain" in the build 1311 of ROSA Fresh R1 with KDE.
Comment 6 Aleksandr Kazantcev 2013-07-29 10:25:46 MSD
This commits not applied in repos - only as experimental. We need push befor geo-ip packages, then apply this commits to main repo.
Comment 7 Postnikov Dmitry 2013-11-12 17:37:29 MSK
The problem is urgent.
Comment 8 Alexander Burmashev 2013-11-12 17:43:05 MSK
Problem is adressed in latest drakxtools/draklive-install.
Comment 9 Denis Silakov 2013-12-25 15:36:22 MSK
So is the issue really fixed with R2 images?
Comment 10 Denis Silakov 2014-03-25 10:46:20 MSK
Ok, seems to be fixed repos and images.