Bug 237 - Kde control settings language does not set language for non KDE applications
: Kde control settings language does not set language for non KDE applications
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Normal enhancement
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-17 17:28 MSD by Sergey Borovkov
Modified: 2012-08-14 10:15 MSD (History)
4 users (show)

See Also:
RPM Package: kdebase4-runtime
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sergey Borovkov 2012-05-17 17:28:58 MSD
Description of problem:
Kde control settings language does not set language for non KDE applications

How reproducible:
Reproducible.

Steps to Reproduce:
1. Change locale in KDE control center.
2. Firefox and other non KDE applications do not change language.
Comment 1 Sergey Borovkov 2012-05-17 17:38:05 MSD
Fixed in:
x64: https://abf.rosalinux.ru/build_lists/548935

Advisory:
Language changes in all programs upon locale change in KDE language settings.
Comment 2 Sergey Borovkov 2012-05-17 17:57:01 MSD
Detailed description:
KDE localization does not pay any attention to host system locale settings (so KDE apps running under Gnome, Windows, Mac or Meego while defaulting to the host Country/Language don't use the actual host Locale settings, and Gnome and Qt apps running under KDE Workspace don't use KDE Locale settings).
We added patch that makes KDE Control Center store not only KDE specific settings but also language settings for non KDE applications (in ~/.i18n file).
Comment 3 Vladimir Potapov 2012-05-21 17:06:29 MSD
Please, 
1) Add the test packages for all supported platforms (x64 and i586)
2) https://abf.rosalinux.ru/build_lists/548935  - Access violation
Comment 4 Vladimir Potapov 2012-05-23 15:46:53 MSD
Any news?
Comment 5 Alexander Burmashev 2012-05-24 15:25:09 MSD
This package was built for private repo, it should be rebuilt to the official one.
Comment 6 Evgeniy Auzhin 2012-05-30 16:48:42 MSD
I built this package in Tigro personal repo

Buildlist:
i586:   https://abf.rosalinux.ru/build_lists/613156
x86_64: https://abf.rosalinux.ru/build_lists/613157
Comment 7 Denis Silakov 2012-07-16 11:35:17 MSD
It seems that this update has been published quite long ago?
Comment 8 Vladimir Potapov 2012-07-16 13:55:57 MSD
This occurred only if the patch was included in the next update.
QA has not tested the update and did not allow him to publish as it has not been collected in the correct repository.
http://wiki.rosalab.ru/en/index.php/Requesting_an_Update#What_should_a_maintainer_do
Comment 9 Sergey Borovkov 2012-07-16 14:33:33 MSD
Advisory:
KDE localization does not pay any attention to host system locale settings (so KDE apps running under Gnome, Windows, Mac or Meego while defaulting to the host Country/Language don't use the actual host Locale settings, and Gnome and Qt apps running under KDE Workspace don't use KDE Locale settings).
We added patch that makes KDE Control Center store not only KDE specific settings but also language settings for non KDE applications (in ~/.i18n file).

Buildlists:
https://abf.rosalinux.ru/build_lists/623147
https://abf.rosalinux.ru/build_lists/623148
Comment 10 Vladimir Potapov 2012-07-17 10:12:24 MSD
Package kdebase4-runtime-4.8.3-2-rosa.lts2012.0.x86_64 is already installed
Please, up the number!
Comment 11 Sergey Borovkov 2012-07-17 11:17:54 MSD
Hm, this bug should be closed. I checked it and this patch is already in main/updates. I was confused by recent comments here and rebuilt it.
Comment 12 Vladimir Potapov 2012-07-17 14:05:55 MSD
"if the patch was included in the next update"
Comment 13 Sergey Borovkov 2012-07-17 14:29:35 MSD
(In reply to comment #12)
> "if the patch was included in the next update"

I don't understand what you mean. Can you be more specific please?
Comment 14 Vladimir Potapov 2012-07-17 14:37:23 MSD
Я писал, что отдельно этот патч не проверял и не пропускал. Но он мог быть опубликован т.к. где-то в этом районе обновлялся весь KDE.

This occurred only if the patch was included in the next update.
Это произошло только в том случае, если патч был включен в следующее обновление.
Comment 15 Denis Silakov 2012-07-18 16:16:50 MSD
(In reply to comment #14)
> 
> This occurred only if the patch was included in the next update.

This seems to be the case. If you install a clear ROSA 2012 image (without any updates) and change preferred language in KDE Control Center, this will not affect non-KDE applications (e.g., urpmi). If you update KDE to the one from updates, the behavior will change.
Comment 16 Denis Silakov 2012-07-25 15:22:06 MSD
As far as I can say, the issue is fixed, but I am not QA.

Vladimir - would you like to test the patch is really in place (like I described in comment #15 - you should compare behavior of 'pure' ROSA 2012 LTS with the updated one) or we can just mark this as published?
Comment 17 Vladimir Potapov 2012-07-27 16:25:57 MSD
kdebase4-runtime-4.8.3-2-rosa.lts2012.0
************* Advisory *****************
Fix bug with KDE locale setting not affect for non-KDE applications
****************************************
QA Verified
Comment 18 Alexander Burmashev 2012-07-31 23:16:25 MSD
Actually i still do not get it - should i publish it or not ?
Comment 19 Denis Silakov 2012-08-13 12:10:45 MSD
(In reply to comment #18)
> Actually i still do not get it - should i publish it or not ?

I guess there is nothing to publish here (everything has been published for a long time), just set the published flag:)