Bug 2369 - Vim works incorrectly from usual user
: Vim works incorrectly from usual user
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-23 10:26 MSD by FirstLevel
Modified: 2014-06-04 07:01 MSD (History)
2 users (show)

See Also:
RPM Package: vim-minimal-7.3.646-2-rosa2012.1.x86_64
ISO-related:
Bad POT generating:
Upstream:


Attachments
greetings screen (88.58 KB, image/jpeg)
2013-07-23 10:26 MSD, FirstLevel
Details
after enter "i" from root (48.90 KB, image/jpeg)
2013-07-23 10:26 MSD, FirstLevel
Details
after enter "i" from user (44.61 KB, image/jpeg)
2013-07-23 10:26 MSD, FirstLevel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2013-07-23 10:26:05 MSD
Created attachment 1690 [details]
greetings screen

Description of problem:
I have installed ROSA 2012.1 Fresh and discovered strange situation with vim.
If I launch vim from root it works well:
- after launching I see screen with greetings 
- if I press "i" I see "insert" in the bottom of the screen and vi entered to edit mode

If I launch vim from usuall user it works incorrectly:
- after launching I see screen with greetings 
- if I press "i" I don't see "insert" in the bottom of the screen and vi is not entered to edit mode



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 FirstLevel 2013-07-23 10:26:39 MSD
Created attachment 1691 [details]
after enter "i" from root
Comment 2 FirstLevel 2013-07-23 10:26:50 MSD
Created attachment 1692 [details]
after enter "i" from user
Comment 3 Denis Silakov 2013-07-23 10:32:24 MSD
Indeed, I also see this problem with vim-minimal. Note, however, that it actually enters the "INSERT" mode and you can type text; just the indicator is missing.

Another possible workaround is to install vim-enhanced, it is free of this problem.
Comment 4 Denis Silakov 2013-07-23 14:34:04 MSD
Ok, the reason is that root has .vimrc file by default where vi-compatibility mode is disabled (by "set nocp" command).

If you launch vim-minimal as ordinary user, there is no .vimrc file and it launches in vi-compatible mode; in this mode, it doesn't show status at the bottom line.

You can type ":set nocp" to disable this mode - after this, you should be able to see 'insert' at the bottom if you press 'i'. Or just copy /root/.vimrc to user's home (and not forget to change permissions).

So this issue is a question of default configuration mismatch for root and users.
Comment 5 FirstLevel 2014-06-03 15:34:37 MSD
checking the relevance
Comment 6 FirstLevel 2014-06-04 07:01:14 MSD
Case is not actual