Bug 2351 - Use '--auto' in rpmdrake by default
: Use '--auto' in rpmdrake by default
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-17 11:38 MSD by Denis Silakov
Modified: 2013-07-22 10:44 MSD (History)
2 users (show)

See Also:
RPM Package: rpmdrake
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Denis Silakov 2013-07-17 11:38:34 MSD
Currently we have quite a few situations when several packages exists that satisfy some package dependency. By default, urpmi and rpmdrake in such ask user which package to install. However, most users (especially non-developers) are not familiar with different packages and just make random choices.

To avoid such questions, rpmdrake has "Select dependencies without asking" option. This option is disabled by default. We believe that it is time to turn it on in the default configuration. During the last months, we have made some improvements in automated package selection, so in many cases such auto selection works better than random choices.
Comment 1 Denis Silakov 2013-07-17 11:39:41 MSD
Advisory:
Turn on "Select dependencies without asking" option in rpmdrake by default.

Build lists:
https://abf.rosalinux.ru/build_lists/1181306
https://abf.rosalinux.ru/build_lists/1181305

After updating to these versions, the option in question should become enabled.
Comment 2 Vladimir Potapov 2013-07-19 13:08:32 MSD
Hmmm... I Can't reproduce "select dependences" case for current urpmi
without urpmi update:
1) Delete all java
2) urpmi icedtea-web  -  java-1.6.0-openjdk automatically added
   GUI select libreoffice-java - java-1.7.0-openjdk automatically added...
Comment 3 Denis Silakov 2013-07-19 13:57:31 MSD
You mean that urpmi and rpmdrake makes different choices with '--auto'?

This is expected, since we've slightly changed algoright of 'urpmi --auto', but this change is not ported to rpmdrake yet. I will do this next week, and I think this is a separate issue.
Comment 4 Vladimir Potapov 2013-07-19 16:54:08 MSD
How to check this update?
Comment 5 Denis Silakov 2013-07-21 23:31:26 MSD
Disable "Select dependencies without asking" option in rpmdrake (if you have manually enabled it). Install new rpmdrake - this oiption should be enabled now.

If you have already enabled this option before updating, then nothing should change.
Comment 6 Vladimir Potapov 2013-07-22 04:51:40 MSD
rpmdrake-5.26.12-28-rosa2012.1
********************** Advisory *********************
Turn on "Select dependencies without asking" option in rpmdrake by default.
*****************************************************
QA Verified