Bug 2350 - nut-cgi config is not compatible with Apache 2.4
: nut-cgi config is not compatible with Apache 2.4
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-17 11:01 MSD by Denis Silakov
Modified: 2013-07-22 14:14 MSD (History)
3 users (show)

See Also:
RPM Package: nut-cgi
ISO-related:
Bad POT generating:
Upstream:
alexander.petryakov: qa_verified+
dmitry.romashkin: secteam_verified+
alex.burmashev: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Denis Silakov 2013-07-17 11:01:59 MSD
nut-cgi package contains a config file for Apache which is not compatible with Apache 2.4 used in Desktop Fresh R1. As a result, if you install nut-cgi, you will fail t restart apache (systemctl restart httpd will fail).
Comment 1 Denis Silakov 2013-07-17 11:04:39 MSD
Advisory:
Fix apache config in nut-cgi to be compatible with Apache 2.4.

Now apache will restart normally after nut-cgi installation. Moreover, if you use default network settings, after installation of nut-cgi you can go to localhost/cgi-bin/upsset.cgi and check your ups statistics.

Build lists:
https://abf.rosalinux.ru/build_lists/1181472
https://abf.rosalinux.ru/build_lists/1181473
Comment 2 Alexander Petryakov 2013-07-22 02:05:47 MSD
nut-2.6.4-6
************** Advisory **************
Fix apache config in nut-cgi to be compatible with Apache 2.4.

Now apache will restart normally after nut-cgi installation. Moreover, if you use default network settings, after installation of nut-cgi you can go to localhost/cgi-bin/upsset.cgi and check your ups statistics.
**************************************
QA Verified

p.s. Some note
I think not good idea use predefined hostname localhost.localdomain.
Can you use command `hostname` to get real hostname, in next versions?