Bug 2330 - pdflatex fails to process documents containing Russian text
: pdflatex fails to process documents containing Russian text
Status: RESOLVED INVALID
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-11 13:36 MSD by Eugene Shatokhin
Modified: 2013-07-18 12:09 MSD (History)
2 users (show)

See Also:
RPM Package: texlive-latex.bin-20120810-3-rosa2012.1.x86_64
ISO-related:
Bad POT generating:
Upstream:


Attachments
Test TeX file. (165 bytes, application/x-tex)
2013-07-11 13:36 MSD, Eugene Shatokhin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eugene Shatokhin 2013-07-11 13:36:51 MSD
Created attachment 1660 [details]
Test TeX file.

Description of problem:
When processing TeX files containing the text in Russian (e.g., the file test_rus.tex attached here), pdflatex fails with the following error:

-----------------------------
!pdfTeX error: pdflatex (file cm-super-t2a.enc): cannot open encoding file for 
reading
 ==> Fatal error occurred, no output PDF file produced!
-----------------------------

However, cm-super-t2a.enc is present in the system (texlive-cm-super package it belongs to is installed, the file /usr/share/texmf-dist/fonts/enc/dvips/cm-super/cm-super-t2a.enc is in place).

On the other hand, 'latex' produces a correct .dvi file for the same input TeX file.

A strange thing is, the problem seems to be gone after I have installed xdvi. pdflatex probably does not use it at all but issues no errors since then even if I remove xdvi package.

How reproducible: always

Steps to Reproduce:
1. On a newly installed ROSA Desktop Fresh, install the following packages:
 - texlive-collection-latex
 - texlive-collection-langcyrillic 
 - texlive-hyphen-russian
 - texlive-cm-super

2. Run pdflatex on the attached file:
   pdflatex test_rus.tex
Comment 1 Denis Silakov 2013-07-17 18:28:38 MSD
Does it help to install not xdvi, but texlive-cyrillic?
Comment 2 Eugene Shatokhin 2013-07-18 12:09:33 MSD
(In reply to comment #1)
> Does it help to install not xdvi, but texlive-cyrillic?

texlive-cyrillic was installed already when the bug triggered.

Looks like the problem was not in our packages. .aux file for that .tex file was created before I have installed texlive-cm-super. So, it seems, pdflatex used that .aux file and did not see cm-super-t2a.enc as a result.

If I remove the old .aux file and run pdflatex again, no errors occur.
Not a bug, closing.