Bug 2328 - Installation of texlive-collection-latex fails occasionally with errors reported by fmtutil
: Installation of texlive-collection-latex fails occasionally with errors repor...
Status: RESOLVED WORKSFORME
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-11 12:55 MSD by Eugene Shatokhin
Modified: 2014-10-08 15:50 MSD (History)
3 users (show)

See Also:
RPM Package: texlive-collection-latex-20125708-2-rosa2012.1.noarch
ISO-related:
Bad POT generating:
Upstream:


Attachments
fmtutil log (35.73 KB, application/octet-stream)
2013-07-11 12:55 MSD, Eugene Shatokhin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eugene Shatokhin 2013-07-11 12:55:31 MSD
Created attachment 1658 [details]
fmtutil log

Description of problem:
On a newly installed and updated ROSA Desktop Fresh R1, installation of texlive-collection-latex fails from time to time when 'fmtutil' runs (I suspect it happens when a dependent package, texlive-latex.bin is being installed).

After that event, the most simple TeX documents (see the example: http://bugs.rosalinux.ru/show_bug.cgi?id=2168) cannot be processed due to missing latex.fmt.

The output of fmtutil is attached. One of the notable errors:
--------------------------
(/usr/share/texmf/tex/generic/hyphen/hyphen.tex)
! I can't find file `dehypht-x-2012-05-30.tex'.
\addlanguage ...me =#5 \uselanguage {#1}\input #2
                                                  \if *#3*\else \input #3 \f...
l.32 ...2-05-30}{dehypht-x-2012-05-30.tex}{}{2}{2}

(Press Enter to retry, or Control-D to exit)
Please type another input file name:
! Emergency stop.
\addlanguage ...me =#5 \uselanguage {#1}\input #2
                                                  \if *#3*\else \input #3 \f...
l.32 ...2-05-30}{dehypht-x-2012-05-30.tex}{}{2}{2}

!  ==> Fatal error occurred, no output PDF file produced!
Transcript written on pdfetex.log.
Error: `pdftex -ini  -jobname=pdfetex -progname=pdfetex -translate-file=cp227.tcx *pdfetex.ini' failed
--------------------------

How reproducible: occasionally. When I remove all texlive packages and then install them again, the errors occur much more rarely.
Comment 1 Denis Silakov 2013-07-22 09:02:30 MSD
Could you point me to a log where such an error with dehypht-x-2012-05-30.tex occurs? Can't find such a log at fba by myself, but maybe I am looking at the wrong place...
Comment 2 Eugene Shatokhin 2013-08-05 18:32:16 MSD
The logs for the new test runs should appear on FBA soon.

When I run latex on the same file manually on ROSA Fresh x64, I see a different error now:

--------------------------
$ latex test.tex 
This is pdfTeX, Version 3.1415926-2.4-1.40.13 (TeX Live 2012/Mandriva)
 restricted \write18 enabled.

kpathsea: Running mktexfmt latex.fmt
tcfmgr: config file `tcfmgr.map' (usually in $TEXMFMAIN/texconfig) not found (ls-R missing?).
fmtutil: config file `fmtutil.cnf' not found.
I can't find the format file `latex.fmt'!
--------------------------

However, fmtutil.cnf and tcfmgr.map are present and readable:
/usr/share/texmf/web2c/fmtutil.cnf
/usr/share/texmf/texconfig/tcfmgr.map

If I run 'fmtutil --all' as root now, the error again is as follows:
--------------
tcfmgr: config file `tcfmgr.map' (usually in $TEXMFMAIN/texconfig) not found (ls-R missing?).
fmtutil: config file `fmtutil.cnf' not found.
--------------
Comment 3 FirstLevel 2014-10-08 14:57:34 MSD
Please check the problem for new release
http://mirror.rosalab.ru/rosa/rosa2014.1/iso/ROSA.Fresh.R4/
Comment 4 Eugene Shatokhin 2014-10-08 15:50:56 MSD
The problem does not show up anymore.