Bug 231 - Dolphin moves files on removable storages to .Trash-500 folder instead of removing them immediately on "Del" command
: Dolphin moves files on removable storages to .Trash-500 folder instead of rem...
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Normal enhancement
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-16 12:52 MSD by Alexander Skakov
Modified: 2012-07-26 11:09 MSD (History)
7 users (show)

See Also:
RPM Package: kdebase4-4.8.2
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
dmitry.romashkin: secteam_verified+
alex.burmashev: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Skakov 2012-05-16 12:52:20 MSD
Description of problem:
Dolphin moves files on removable storages to .Trash-500 folder instead of removing them immediately on "Del" command. This is not an anticipated behavior for regular user and should be fixed.

Version-Release number of selected component (if applicable):
4.8.2

How reproducible:
1. Open any removable device folder in Dolphin
2. Select any file
3. Hit "Del" or choose "Move to trash" from context menu
Comment 2 Alexander Skakov 2012-05-16 13:36:20 MSD
Fixed in:
x86: https://abf.rosalinux.ru/build_lists/548935
x64: https://abf.rosalinux.ru/build_lists/548936

Advisory:
Dolphin now removes files from removable drives immediately instead of moving them to trash.
Comment 3 Pavel Shved 2012-05-16 13:45:26 MSD
Will it also make such files be removed completely, for instance on a 1.5-Tb USB hard drive?
Comment 4 Alexander Skakov 2012-05-16 13:46:54 MSD
(In reply to comment #3)
> Will it also make such files be removed completely, for instance on a 1.5-Tb
> USB hard drive?

Yes, that's the behavior we agreed on
Comment 5 Denis Koryavov 2012-05-16 13:51:18 MSD
Here is the GLPI ticket for this bug: http://helpdesk.rosalab.ru/front/ticket.form.php?id=1172#
Comment 6 Pavel Shved 2012-05-16 14:07:40 MSD
(In reply to comment #5)
> Here is the GLPI ticket for this bug:
> http://helpdesk.rosalab.ru/front/ticket.form.php?id=1172#

Here's another link you don't have access to:
https://abf.rosalinux.ru/shvedsky/cvc3

I can give you more links that give "Access denied".  In the meantime, has there been any discussion in rosa-devel or something where everybody could participate?
Comment 7 Denis Koryavov 2012-05-16 14:24:07 MSD
Do you registered on helpdesk.rosalab.ru?
Comment 8 Vladimir Potapov 2012-05-22 16:59:55 MSD
(In reply to comment #2)
> Fixed in:
> x86: https://abf.rosalinux.ru/build_lists/548935
> x64: https://abf.rosalinux.ru/build_lists/548936
> 
> Advisory:
> Dolphin now removes files from removable drives immediately instead of
> moving them to trash.

"Access violation to this page!"

Vladimir Potapov
QA Team
Comment 9 Alexander Burmashev 2012-05-23 15:00:50 MSD
Now i see why it is so - the package is built to the private repo. It should be rebuilt in order to match updated policy.
Comment 10 Vladimir Potapov 2012-05-24 14:56:40 MSD
Please, rebuild your package to the official public repository instead of your private one, as specified in the "Make a proper build"
Comment 11 Alexander Skakov 2012-05-31 13:18:44 MSD
Packages rebuilt to official public repo:
x86: https://abf.rosalinux.ru/build_lists/613211
x64: https://abf.rosalinux.ru/build_lists/613212
Comment 12 Ural Mullabaev 2012-06-09 11:17:43 MSD
Is there any news?
Comment 13 Pavel Shved 2012-06-09 12:02:18 MSD
(In reply to comment #12)
> Is there any news?

Sorry, due to a bug in a workflow, bugzilla showed that there's an update request pending, while it was not the case.  This will be fixed today.

I cleared status for this bug; could you, please, repeat your update request?
Comment 14 Alexander Skakov 2012-06-09 16:03:23 MSD
Packages rebuilt to official public repo:
x86: https://abf.rosalinux.ru/build_lists/613211
x64: https://abf.rosalinux.ru/build_lists/613212

Advisory:
Dolphin now removes files from removable drives immediately instead of moving them to trash.
Comment 15 Vladimir Potapov 2012-06-12 17:20:23 MSD
In testing...
Comment 16 Vladimir Potapov 2012-06-14 03:09:41 MSD
dolphin-4.8.3-3
*********Advisory************
Dolphin now removes files from removable drives immediately instead of moving them to trash.
****************************
QA verified
Comment 17 Alexander Burmashev 2012-07-24 11:06:47 MSD
Seems that containers are lost or outdates, rebuild please ?
Comment 18 Alexander Skakov 2012-07-24 13:16:02 MSD
Rebuild:
x64: https://abf.rosalinux.ru/build_lists/637156
x86: https://abf.rosalinux.ru/build_lists/637155
Comment 19 Alexander Burmashev 2012-07-24 13:17:27 MSD
It really will be better to REcheck the package quickly, since it took so long time to get to it.
Comment 20 Vladimir Potapov 2012-07-24 16:46:14 MSD
Please, rebuild your package to the official public repository instead of your private one, as specified in the "Make a proper build"
Comment 21 Alexander Skakov 2012-07-25 10:57:39 MSD
Build lists rebuilt in Rosa2012LTS:
x64: https://abf.rosalinux.ru/build_lists/637309
i586: https://abf.rosalinux.ru/build_lists/637308
Comment 22 Vladimir Potapov 2012-07-25 17:08:27 MSD
dolphin-4.8.3-4
*********Advisory************
Dolphin now removes files from removable drives immediately instead of moving them to trash.
****************************
QA verified