Bug 2304 - backlight fn+f11 and fn+f12 keys doesn't work since kernel 3.8 update
: backlight fn+f11 and fn+f12 keys doesn't work since kernel 3.8 update
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-07 23:49 MSD by altadeos
Modified: 2013-10-22 10:08 MSD (History)
2 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments
xorg.conf (1.31 KB, text/plain)
2013-10-21 23:16 MSD, altadeos
Details

Note You need to log in before you can comment on or make changes to this bug.
Description altadeos 2013-07-07 23:49:54 MSD
Description of problem:

To have functionnal FN+F11 (backlight decrease) and FN+F12 (backlight increase) combinaison keys on my laptop it was necessary to put acpi_osi=Linux on the grub boot line before 3.8.x kernel update.
It was working very good but after kernel 3.8.x update i was unable to control backlight of my computer with fn keys and with kde powerdevil.
The problem with kde powerdevil is now solved since i have update kernel to 3.9.x but fn keys doesn't work anymore even if i put acpi_osi=linux on grub boot line.

see bug 2265 http://bugs.rosalinux.ru/show_bug.cgi?id=2265

i have tried with xev and showkey for FN + F11 (backlight decrease) and FN + F12 (backlight increase) but they don't return anything. No keycodes. 

So, i tried with fedora 19 live usb and if i press Fn + F11 or Fn + F12 it show me that it is recognized but the function to increase/decrease doesn't look implemented.

showkey on fedora return me a keycode.

Can you tell me what results do you need?

Could you please help me?
Best regards.
Comment 1 bober 2013-07-08 08:43:44 MSD
If kernel is the only change you made, then do a git bisection.
Some tutorials:
https://www.kernel.org/pub/software/scm/git/docs/git-bisect.html
https://www.kernel.org/pub/software/scm/git/docs/git-bisect-lk2009.html

Report first bad commit

And attach dmesg after pressing not working keys
Comment 2 altadeos 2013-10-21 23:16:02 MSD
Hello, 

I think this bug can be close.
I don't know since when it work but now with my Rosa 2012.1 up to date all is working including fn keys.

I don't know what update restore the function but really thank you to have solved this.

i will add my xorg.conf for people who have the same laptop like me.

Best regards.
Comment 3 altadeos 2013-10-21 23:16:43 MSD
Created attachment 2091 [details]
xorg.conf