Bug 2302 - [UPDATE REQUEST] KDE 4.10.4 -> 4.10.5
: [UPDATE REQUEST] KDE 4.10.4 -> 4.10.5
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-05 18:33 MSD by Andrey Bondrov
Modified: 2013-07-11 06:25 MSD (History)
3 users (show)

See Also:
RPM Package: various
ISO-related:
Bad POT generating:
Upstream:


Attachments
kk32-3.png (222.38 KB, image/png)
2013-07-07 00:36 MSD, Postnikov Dmitry
Details
klook segfault in KDE 4.10.4 (2.88 MB, video/webm)
2013-07-08 03:50 MSD, Andrey Bondrov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Bondrov 2013-07-05 18:33:21 MSD
KDE 4.10.4 -> 4.10.5 update is ready for testing.

Please add this repository and update your system: 

http://abf-downloads.rosalinux.ru/kde4_backports_personal/repository/rosa2012.1/

If everything is fine, KDE 4.10.5 packages will be pushed to Main Updates.
Comment 1 Postnikov Dmitry 2013-07-07 00:31:06 MSD
All updated without problems and mistakes on all 4 computers. And everything works fine, except Klook. With him all the problems. Especially with sound.

1. When playing exactly this mp3 file Klook falls with the error:
========
localhost	kernel	[  346.033110] klook[6626]: segfault at 0 ip 00007fcb0e516af1 sp 00007ffff366bd50 error 4 in libQtCore.so.4.8.4[7fcb0e36f000+2c3000]
localhost	[6639]	Process 6626 (klook) dumped core.
========
This error on both architectures.
The file for example:
http://cdn.2safe.com/696564033558/05 - Lumen — Кофе.mp3

2. Black screen in Klook when playing a video, although ROMP loses excellent. This error on both architectures.
The file for example:
http://cdn.2safe.com/778415033045/7Б - Молодые ветра.avi

3. Has no sound in some avi files, for example,
http://cdn.2safe.com/897062033560/Basta.-.Lyubov_.avi

All this a regression, after update.
Everything else is normal.
Comment 2 Postnikov Dmitry 2013-07-07 00:36:07 MSD
Created attachment 1634 [details]
kk32-3.png

Pardon! Forgot...
In both architecture, again in NM began to appear in two network cards Wlan0 & Eth0. And i not found wifi card in system block.
This also regression.
Comment 3 Andrey Bondrov 2013-07-07 08:59:05 MSD
(In reply to comment #2)
> Created attachment 1634 [details]
> kk32-3.png
> 
> Pardon! Forgot...
> In both architecture, again in NM began to appear in two network cards Wlan0
> & Eth0. And i not found wifi card in system block.
> This also regression.

This one is really unlikely related to KDE update.

For the rest, I could reproduce segfault with 05 - Lumen - Кофе.mp3. But other mp3s seem to work fine. I also found that:

1. With phonon-vlc klook opens 05 - Lumen - Кофе.mp3 with no issues while with phonon-gstreamer klook segfaults.
2. Editing and saving id3 tags fixed 05 - Lumen - Кофе.mp3 playback with klook & phonon-gstreamer. 

So there must be a bug in phonon-gstreamer or gstreamer codecs.

There's a big chance that you got some buggy updates from Main/Updates along with KDE 4.10.5 packages.

Can you please try to install R1 in virtual machine, update it only from official repositories and try to reproduce reported bugs with KDE 4.10.4?
Comment 4 Andrey Bondrov 2013-07-07 10:22:24 MSD
So far I found that klook segfaults in this function:

================
QString Audio::guessEncoding(const QByteArray &data)
{
    KEncodingProber prober(KEncodingProber::Universal);
    prober.feed(data);
    QString str = prober.confidence() > 0.7
            ? QTextCodec::codecForName(prober.encoding())->toUnicode(data)
            : QString::fromUtf8(data);

    return str;
}
================

But KEncodingProber code wasn't changed for 2 years already. Is there a chance that you have Qt 4.8.5 installed?
Comment 5 Postnikov Dmitry 2013-07-07 21:18:56 MSD
We tested these music files in 4.10.4 and problems with Klook was not. And in 4.10.5 appeared.

I default to the system is worth the package:
[root@localhost pastordi]# rpm -qa | grep qt4
qt4-common-4.8.4-1-rosa2012.1.i586
qt4-qtdbus-4.8.4-1-rosa2012.1.i586

(We are not tested in VirtualBox, we tested in real hardware)
Comment 6 Andrey Bondrov 2013-07-08 03:50:50 MSD
Created attachment 1638 [details]
klook segfault in KDE 4.10.4

I see. So I have to do some testing myself. And of course I can reproduce klook segfault with your mp3 in KDE 4.10.4 & Qt 4.8.4. Because there are no code changes in KDE 4.10.5 related to encoding detection. While it's surely a bug in klook that must be fixed, it's not a regression in KDE 4.10.5.

See attached video.
Comment 7 Postnikov Dmitry 2013-07-08 10:47:29 MSD
Now, i checked. Yes in the old version of KDE the same thing. Then there remains only the question to Klook with the other two .avi files, and again double vision network interfaces.
Comment 8 Maksim Tomilov 2013-07-09 00:55:14 MSD
Bugs with encoding cp-1251 is fixed, mp3-files has opened normaly. But there is another problem

__________________________

ROSA FRESH R1 i586
klook-2.0-12-rosa2012.1.i586

1. Open, example, mp3-file (1.mp3) in the Klook. At the top of the window of klook there is a button "Open in Rosa Media Player"

2. Switch the display klook of the tiles

3. In this mode, try to move the cursor to other files, the button will not change its name. The button will be called "Open", but no "Open in Rosa Media Player", as will be. Only when the cursor on the file 1.mp3 button changes

Screencast here...
http://cdn.2safe.com/705233033558/screencast.mov
Comment 9 Andrey Bondrov 2013-07-09 04:55:58 MSD
(In reply to comment #8)
> Bugs with encoding cp-1251 is fixed, mp3-files has opened normaly. But there
> is another problem

Yes, I confirm this issue. But as it's not a regression, it's better to file a bug for it and assign to UX Team. For me it looks like an incomplete feature, just a prototype. Because it's really hard to click "Open in..." button no matter what label it has. Perhaps this button should be removed in "tiles" mode. Let UX Team decide.
Comment 10 Postnikov Dmitry 2013-07-09 10:08:02 MSD
I add bugs 2320 for klook issues.
Comment 11 Vladimir Potapov 2013-07-10 15:13:43 MSD
I can't found regressions in this update.
Comment 12 Andrey Bondrov 2013-07-10 16:25:33 MSD
The update in being published to Main Updates.