Bug 228 - A separate section for English-speaking users on forum
: A separate section for English-speaking users on forum
Status: RESOLVED FIXED
Product: Websites
Classification: ROSA Infrastructure
Component: Forum
: unspecified
: All Linux
: Normal enhancement
: ---
Assigned To: JDronova
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-15 19:25 MSD by Pavel Shved
Modified: 2013-01-25 22:32 MSK (History)
5 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pavel Shved 2012-05-15 19:25:54 MSD
Now the language has been set, so English speakers should have a separate section on the forum, I guess.

From bug #154, comment 23:

Also, whoever manages the forum, you should make the "English-speaking forum" a category with sub-forums dedicated to various topics (installation, hardware support, Desktop, Server etc etc etc), otherwise you will end up with a big mess of topics in 1 place.
Comment 1 JDronova 2012-05-15 22:34:02 MSD
Well, I'd suggest something like this, to start with:
*Installation
*Hardware support
*Desktop
*Off the wall

server matters still are somewhat obscure, since we had no releases yet, and MCS we do not support.
Comment 2 JDronova 2012-05-15 22:40:56 MSD
I forgot: should we create them in the main tree, since now we have global language switch?
Comment 3 rugyada 2012-05-21 18:22:52 MSD
Please, make "English-speaking forum" a category with own sub-forums.
English (international forum ) flag could point to this category then.
Comment 4 Pavel Shved 2012-05-21 18:28:02 MSD
+1

It could be very confusing to have "Forum for English speakers" at the end of a long list of Cyrillic forums.  A separate section would work then.

Julia, do you need any help at coding/server administration side, or you could sort it out from the web interface?
Comment 5 JDronova 2012-05-21 19:02:25 MSD
Yes I think it can be done from my admin interface.
Will create the subforums with same names and move existing topics accordingly, then delete separate English forums.
Comment 6 JDronova 2012-05-21 19:09:27 MSD
Done already.
Just created parent forum and moved the rest of English-speaking stuff there :)
Comment 7 rugyada 2012-05-21 19:58:43 MSD
Better than before, thank you, but what about to create two main *categories* (ru forum & en forum) ?
It would be more clean, imho, and anyway you could need to add any new forum in the future. "Subforums: xxx, yyy, zzz, ..." row would become very long.
Comment 8 JDronova 2012-05-21 20:41:14 MSD
(In reply to comment #7)
> Better than before, thank you, but what about to create two main
> *categories* (ru forum & en forum) ?
> It would be more clean, imho, and anyway you could need to add any new forum
> in the future. "Subforums: xxx, yyy, zzz, ..." row would become very long.

Don't know, the current structure may be a long-time 'temporarily workaround' (if you know what I mean) due to catastrophic lack of time of our server-admins. Ask Pavel :(
The problem is that we were planning on announcing our English forums, may be tomorrow or day aft.tomorrow, and now I don't know should we wait or what..? quantity of non-Russian speaking users is growing fast and I am interested in concentrating them on our forums rather then on MIB forums etc, naturally.
Comment 9 JDronova 2012-05-21 20:50:32 MSD
rugyada
You mean something like this:
http://forum.exler.ru/ (it's in Russian but it doesn't matter in our case)
?
Comment 10 rugyada 2012-05-21 21:14:50 MSD
(In reply to comment #8)
> quantity of non-Russian speaking users is growing fast and I am
> interested in concentrating them on our forums rather then on MIB forums
> etc, naturally.
That's why they should find clean and organized forum ;)

(In reply to comment #9)
> rugyada
> You mean something like this:
> http://forum.exler.ru/ (it's in Russian but it doesn't matter in our case)
> ?
Well, it's not phpBB, for what I can see, but could be something like that.
You can give a look at mib.pianetalinux.org/forum
maybe better example. (Sorry for spam :D )

Aside, I'm familiar with phpBB forum, I'm admin in ours. Feel free to tell me if I can be of some help.
Comment 11 JDronova 2012-05-22 07:22:57 MSD
(In reply to comment #10)
> (In reply to comment #8)
> You can give a look at mib.pianetalinux.org/forum
> maybe better example. (Sorry for spam :D )
Hmm, now I want a nice skin, too ^__^

> Aside, I'm familiar with phpBB forum, I'm admin in ours. Feel free to tell
> me if I can be of some help.
Sure, thank you! :)
Will see today, what can we do.
Comment 12 Denis Silakov 2013-01-25 22:32:09 MSK
I guess there is no reason to keep this bug opened.