Bug 2272 - Gnome R1 doesn't work on laptop with ssd
: Gnome R1 doesn't work on laptop with ssd
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: GNOME edition
: Fresh
: x86_64 Linux
: Normal normal
: ---
Assigned To: Arkady L. Shane
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-02 12:56 MSD by Yura Yurochko
Modified: 2013-07-07 22:53 MSD (History)
2 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments
lspci (5.10 KB, text/plain)
2013-07-02 13:48 MSD, Yura Yurochko
Details
photo.jpg (2.83 MB, image/jpeg)
2013-07-03 17:55 MSD, Yura Yurochko
Details
dmesg (60.14 KB, text/plain)
2013-07-03 18:13 MSD, Yura Yurochko
Details
xorg (28.23 KB, text/plain)
2013-07-03 18:14 MSD, Yura Yurochko
Details
photo_1 (2.35 MB, image/jpeg)
2013-07-03 18:36 MSD, Yura Yurochko
Details
photo_2 (1.77 MB, image/jpeg)
2013-07-03 18:43 MSD, Yura Yurochko
Details
archive (6.47 KB, application/x-gzip)
2013-07-03 18:55 MSD, Yura Yurochko
Details
journal.txt (163.64 KB, text/plain)
2013-07-04 12:44 MSD, Yura Yurochko
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yura Yurochko 2013-07-02 12:56:15 MSD
Description of problem:
After installing Gnome R1 and first rebooting system doesn't start: process of loading is waiting on plymouth. I can't go to virtual console, keyboard doesn't work too.


Version-Release number of selected component (if applicable):
Rosa Fresh Gnome R1


How reproducible:


Steps to Reproduce:
1. Install Gnome R1 on your laptop with ssd
2. Restart system
3. See
Comment 1 Eugene Shatokhin 2013-07-02 13:41:32 MSD
1. Does it stop with "dracut: Starting plymouth daemon" as the last line of the system log at the screen?

I observed a probably similar problem in ROSA Fresh R1 (with KDE rather than GNOME though) in our automatic tests from time to time. Without additional info, however, it is hard to say if they are related.

2. Does a second reboot help?

3. Please post the hardware configuration here, at least you can boot the system in Live mode and get the output of 'lspci -vnn'.
Comment 2 Alexander Burmashev 2013-07-02 13:43:20 MSD
DO you have similar problems with latest KDE images ?
Comment 3 Yura Yurochko 2013-07-02 13:48:05 MSD
Created attachment 1596 [details]
lspci
Comment 4 Yura Yurochko 2013-07-02 13:48:27 MSD
Now, i use Rosa R1 KDE and all right. But with Gnome on this laptop i have problem. Second and other reboot doesn't help.

I attach file with "lspci -vnn".
Comment 5 Yura Yurochko 2013-07-02 13:49:40 MSD
I have still one laptop with ssd, but Gnome R1 works good on this laptop.
Comment 6 Yura Yurochko 2013-07-02 13:51:04 MSD
Also i installed Fedora 18 with Gnome on problem laptop, and it works good.
Comment 7 Alexander Burmashev 2013-07-02 14:17:30 MSD
Fedora does not really interest me, but thx for the info :)
Do you have Gnome system in dualboot with KDE or any other ?
Comment 8 Yura Yurochko 2013-07-02 14:20:45 MSD
No, now on this laptop installed KDE R1 and Fedora.
But i can install Gnome beside KDE, if need.
Comment 10 Yura Yurochko 2013-07-03 17:00:50 MSD
Ok, i will test it after downloading.
Comment 11 Yura Yurochko 2013-07-03 17:55:47 MSD
Created attachment 1619 [details]
photo.jpg

i tested this iso, but i got similar results. I attached photo with logs without splash option. See it.
Comment 12 Alexander Burmashev 2013-07-03 18:01:46 MSD
According to the screenshot you have a problem with X or KDM.
Can you please provide Xorg.0.log, dmesg, kdm.log
Comment 13 Alexander Burmashev 2013-07-03 18:09:31 MSD
Also try booting with 
xdriver=vesa nomodeset vga=788 
boot options
Comment 14 Yura Yurochko 2013-07-03 18:13:05 MSD
Created attachment 1620 [details]
dmesg
Comment 15 Yura Yurochko 2013-07-03 18:14:55 MSD
Created attachment 1621 [details]
xorg

I started system with option "single" and copied two files: xorg.old, dmesg.old. But in log-folder a don't find file kdm.log.
Comment 16 Alexander Burmashev 2013-07-03 18:19:47 MSD
Haha, sorry )
I need logs from /var/log/gdm folder )
Comment 17 Yura Yurochko 2013-07-03 18:36:16 MSD
Created attachment 1622 [details]
photo_1

In /var/log/gdm/ there are files, but i can't copy them on usb, see photo.
Comment 18 Alexander Burmashev 2013-07-03 18:38:54 MSD
cp * /mnt/
Comment 19 Yura Yurochko 2013-07-03 18:43:48 MSD
Created attachment 1623 [details]
photo_2

i tried it too, but it didn't help. see photo_2.
Comment 20 Alexander Burmashev 2013-07-03 18:47:36 MSD
tar -zcvf gdm.tar.gz /var/log/gdm/
then copy /var/log/gdm.tar.gz to the flash drive
Comment 21 Yura Yurochko 2013-07-03 18:55:30 MSD
Created attachment 1624 [details]
archive

attached archive.
Comment 22 Alexander Burmashev 2013-07-03 19:00:08 MSD
Ok,now booting with 
xdriver=vesa nomodeset vga=788 
boot options
Comment 23 Yura Yurochko 2013-07-03 19:07:36 MSD
Yes, it works, but colors and resolution is very bad.
But system is working
Comment 24 Alexander Burmashev 2013-07-03 19:10:47 MSD
i see, thx, much clearer.
The problem exists, but it is not ssd related and not the one we faced on Eugene Shatokhin test machines.
Comment 25 Alexander Burmashev 2013-07-03 19:20:28 MSD
Try please changing splash=silent to splash=text in grub boot menu
Comment 26 Yura Yurochko 2013-07-03 19:25:40 MSD
All as at "photo", a didn't see any difference.
Comment 27 Alexander Burmashev 2013-07-03 19:35:04 MSD
Can you switch to other virtual consoles when system fails to start ?
Comment 28 Yura Yurochko 2013-07-04 11:13:57 MSD
No, i can't to switch to virtual console.

Also i tried xdriver=intel, but it doesn't help too.
Comment 29 Yura Yurochko 2013-07-04 12:44:09 MSD
Created attachment 1631 [details]
journal.txt

I tried i915.modeset=0 at grub boot menu and it works, system works, but resolution is bad. Also, at journalctl there are many messages with "failed". I attached file, see it please.
Comment 30 Alexander Burmashev 2013-07-04 13:15:24 MSD
This is no surprising, i915.modeset=0 does not load the required driver :)
and BTW better provide journalctl -a for a full output.
Comment 31 Alexander Burmashev 2013-07-04 13:19:27 MSD
Try please 
acpi=off
at boot options
Comment 32 Yura Yurochko 2013-07-04 13:56:16 MSD
I tried, system started, but resolution also is bad and system works very slowly.
Comment 33 Alexander Burmashev 2013-07-04 15:10:32 MSD
Try please booting to runlevel 3, add
3
to boot string in grub
then login with some user and try startx.
Comment 34 Yura Yurochko 2013-07-04 16:01:39 MSD
Results: after logining i typed startx and see mouse-pointer, but after it i see black screen only. And i can't to switch to virtual console.
Comment 35 Arkady L. Shane 2013-07-05 00:08:00 MSD
Ok. Last mesa builds

https://abf.rosalinux.ru/build_lists/1176886
https://abf.rosalinux.ru/build_lists/1176887

fix this issue.
Comment 36 Yura Yurochko 2013-07-07 22:53:18 MSD
In new Gnome R1 this problem solved.