Bug 2254 - Memtest86+ reports false positives
: Memtest86+ reports false positives
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-27 11:56 MSD by Eugene Shatokhin
Modified: 2013-07-02 16:19 MSD (History)
2 users (show)

See Also:
RPM Package: memtest86+-4.20-2-rosa2012.1
ISO-related:
Bad POT generating:
Upstream:


Attachments
Screenshot with the errors reported by Memtest86+ (14.17 KB, image/png)
2013-06-27 11:56 MSD, Eugene Shatokhin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eugene Shatokhin 2013-06-27 11:56:08 MSD
Created attachment 1578 [details]
Screenshot with the errors reported by Memtest86+

Description of problem:

When I boot from the install DVD or USB stick with ROSA Desktop Fresh R1, select "Troubleshooting" at boot launch Memtest86+, Memtest soon starts reporting errors even if memory is OK (see the attached screenshot). 

This happens both on real hardware and under QEMU and VirtualBox. 

On the systems with 2Gb of RAM it takes no more than 20 minutes (usually - less than 3-4 minutes) for the problem to show up.

When I launch Memtest from the install DVD with Fedora 18 (same version of Memtest, 4.20) on these systems, it shows no errors.


Version-Release number of selected component (if applicable):
4.20-2


How reproducible:
Always


Steps to Reproduce:
1. Boot from ROSA Desktop Fresh R1 install media.
2. Select "Troubleshooting" in the boot menu than choose "Run a memory test".
3. Wait several minutes (perhaps, the more RAM a machine has, the longer one should wait).
Comment 1 Postnikov Dmitry 2013-06-27 13:09:33 MSD
Everything is alright with me.
Comment 2 Eugene Shatokhin 2013-06-27 13:26:06 MSD
(In reply to comment #1)
> Everything is alright with me.

What kind of system have you tried it on? How long did Memtest run?
Comment 3 Postnikov Dmitry 2013-06-27 13:28:30 MSD
(In reply to comment #2)
> (In reply to comment #1)
> > Everything is alright with me.
> 
> What kind of system have you tried it on? How long did Memtest run?

I tried KDE, Gnome from usb. And one time Gnome in QEMU.
Comment 4 Alexander Burmashev 2013-06-27 13:31:54 MSD
Ok, i can confirm this issue, patched package is on the way.
Comment 5 Postnikov Dmitry 2013-06-27 13:33:31 MSD
Hm...and why all works for me? I 20-25% chased test.
Comment 6 Alexander Burmashev 2013-06-27 14:10:46 MSD
http://bugs.rosalinux.ru/show_bug.cgi?id=2255
Comment 7 Alexander Burmashev 2013-06-27 20:54:11 MSD
I prepared a test image with new memtest
http://file-store.rosalinux.ru/api/v1/file_stores/7bf0ddca1dccc5f6910db5493bea1ecd03af61a9
My tests show that test7 no longer shows a lot of errors.
Comment 8 Eugene Shatokhin 2013-06-28 10:48:20 MSD
(In reply to comment #7)
> My tests show that test7 no longer shows a lot of errors.

I can confirm that. Memtest from that image did not issue false positives.
Comment 9 Eugene Shatokhin 2013-07-02 16:19:40 MSD
The problem has been fixed. 
In addition, we now have an automatic regression test for it.