Bug 223 - Ktorrent not run
: Ktorrent not run
Status: RESOLVED WORKSFORME
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Normal enhancement
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-15 11:19 MSD by Aleksandr Kazantcev
Modified: 2012-05-28 17:40 MSD (History)
4 users (show)

See Also:
RPM Package: ktorrent-4.1.1-3
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aleksandr Kazantcev 2012-05-15 11:19:07 MSD
Run Ktorrent. It's failed with error

Сергей Голубев QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
KGlobal::locale::Warning your global KLocale is being recreated with a valid main component instead of a fake component, this usually means you tried to call i18n related functions before your main component was created. You should not do that since it most likely will not work 
Warning: QWidget::insertAction: Attempt to insert null action
Warning: QWidget::insertAction: Attempt to insert null action
Warning: QWidget::insertAction: Attempt to insert null action
unnamed app(29623): Communication problem with "ktorrent" , it probably crashed. 
Error message was: "org.freedesktop.DBus.Error.NoReply" : " "Message did not receive a reply (timeout by message bus)" "

In NVIDIA and AMD card there working workaround:

 LD_PRELOAD=/usr/lib/libGL.so.1 ktorrent

But in Intel not work:

ERROR: ld.so: object '/usr/lib/libGL.so.1' from LD_PRELOAD cannot be preloaded: ignored.
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
KGlobal::locale::Warning your global KLocale is being recreated with a valid main component instead of a fake component, this usually means you tried to call i18n related functions before your main component was created. You should not do that since it most likely will not work 
Warning: QWidget::insertAction: Attempt to insert null action
Warning: QWidget::insertAction: Attempt to insert null action
Warning: QWidget::insertAction: Attempt to insert null action
unnamed app(14752): Communication problem with "ktorrent" , it probably crashed. 
Error message was: "org.freedesktop.DBus.Error.NoReply" : " "Message did not receive a reply (timeout by message bus)
Comment 1 Postnikov Dmitry 2012-05-15 13:13:21 MSD
I have AMD and ATI video, all working.
Second computer AMD and NVideo also all working.
(R2012LTS i586)
Comment 2 Alexander Burmashev 2012-05-15 13:20:06 MSD
I thought i had some special case, but on my pc it works too.
If started from konsole it shows me some warning to the konsole output, but it starts and works ok.
Comment 3 Denis Koryavov 2012-05-15 13:29:08 MSD
It works on my PC too. I think it is a local problem of user.
Comment 4 Dmitry Mikhirev 2012-05-28 17:40:26 MSD
I could not reproduce this too, so closing as "worksforme".