Bug 2198 - System update "rpmdrake"
: System update "rpmdrake"
Status: RESOLVED WORKSFORME
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: x86_64 Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-13 16:42 MSD by korolniknik
Modified: 2013-09-05 17:39 MSD (History)
1 user (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description korolniknik 2013-06-13 16:42:17 MSD
Description of problem:
Программа "MandrivaUpdate" аварийно завершила свою работу со следующей ошибкой:

  Can't call method "fullname" on an undefined value at /usr/lib/perl5/vendor_perl/5.12.3/Rpmdrake/pkg.pm line 553.
  standalone::bug_handler() called from /usr/lib/perl5/vendor_perl/5.12.3/Rpmdrake/pkg.pm:559
  Rpmdrake::pkg::get_pkgs() called from /usr/lib/perl5/vendor_perl/5.12.3/Rpmdrake/gui.pm:631
  Rpmdrake::gui::pkgs_provider() called from /usr/sbin/MandrivaUpdate:257
  main::run_treeview_dialog() called from /usr/sbin/MandrivaUpdate:284

user@MagOS ~ $ lspcidrake -v
r8169           : Realtek Semiconductor Co., Ltd.|RTL8111/8168B PCI Express Gigabit Ethernet controller [NETWORK_ETHERNET] (vendor:10ec device:8168 subv:1849 subd:8168) (rev: 06)
Card:ATI Radeon HD 2000 to HD 6300 (radeon/fglrx): ATI Technologies Inc|RS780L [Radeon HD 3000] [DISPLAY_VGA] (vendor:1002 device:9616 subv:1849 subd:9616)
unknown         : Advanced Micro Devices [AMD]|Family 10h Processor Link Control [BRIDGE_HOST] (vendor:1022 device:1204)
k10temp         : Advanced Micro Devices [AMD]|Family 10h Processor Miscellaneous Control [BRIDGE_HOST] (vendor:1022 device:1203)
unknown         : Advanced Micro Devices [AMD]|Family 10h Processor DRAM Controller [BRIDGE_HOST] (vendor:1022 device:1202)
unknown         : Advanced Micro Devices [AMD]|Family 10h Processor Address Map [BRIDGE_HOST] (vendor:1022 device:1201)
unknown         : Advanced Micro Devices [AMD]|Family 10h Processor HyperTransport Configuration [BRIDGE_HOST] (vendor:1022 device:1200)
ohci_hcd        : ATI Technologies Inc|SB7x0/SB8x0/SB9x0 USB OHCI2 Controller [SERIAL_USB] (vendor:1002 device:4399 subv:1849 subd:4399)
unknown         : ATI Technologies Inc|SBx00 PCI to PCI Bridge [BRIDGE_PCI] (vendor:1002 device:4384)
unknown         : ATI Technologies Inc|SB7x0/SB8x0/SB9x0 LPC host controller [BRIDGE_ISA] (vendor:1002 device:439d subv:1849 subd:439d)
snd_hda_intel   : ATI Technologies Inc|SBx00 Azalia (Intel HDA) [MULTIMEDIA_AUDIO_DEV] (vendor:1002 device:4383 subv:1849 subd:3662)
pata_atiixp     : ATI Technologies Inc|SB7x0/SB8x0/SB9x0 IDE Controller [STORAGE_IDE] (vendor:1002 device:439c subv:1849 subd:439c)
sp5100_tco      : ATI Technologies Inc|SBx00 SMBus Controller [SERIAL_SMBUS] (vendor:1002 device:4385 subv:1849 subd:4385) (rev: 3c)
ehci_hcd        : ATI Technologies Inc|SB7x0/SB8x0/SB9x0 USB EHCI Controller [SERIAL_USB] (vendor:1002 device:4396 subv:1849 subd:4396)
ohci_hcd        : ATI Technologies Inc|SB7x0 USB OHCI1 Controller [SERIAL_USB] (vendor:1002 device:4398 subv:1849 subd:4398)
ohci_hcd        : ATI Technologies Inc|SB7x0/SB8x0/SB9x0 USB OHCI0 Controller [SERIAL_USB] (vendor:1002 device:4397 subv:1849 subd:4397)
ehci_hcd        : ATI Technologies Inc|SB7x0/SB8x0/SB9x0 USB EHCI Controller [SERIAL_USB] (vendor:1002 device:4396 subv:1849 subd:4396)
ohci_hcd        : ATI Technologies Inc|SB7x0 USB OHCI1 Controller [SERIAL_USB] (vendor:1002 device:4398 subv:1849 subd:4398)
ohci_hcd        : ATI Technologies Inc|SB7x0/SB8x0/SB9x0 USB OHCI0 Controller [SERIAL_USB] (vendor:1002 device:4397 subv:1849 subd:4397)
ahci            : ATI Technologies Inc|SB7x0/SB8x0/SB9x0 SATA Controller [IDE mode] [STORAGE_SATA] (vendor:1002 device:4390 subv:1849 subd:4390)
shpchp          : Advanced Micro Devices [AMD]|RS780/RS880 PCI to PCI bridge (PCIE port 1) [BRIDGE_PCI] (vendor:1022 device:9605)
shpchp          : ASRock Incorporation|Device 9602 [BRIDGE_PCI] (vendor:1849 device:9602)
unknown         : Advanced Micro Devices [AMD]|RS780 Host Bridge [BRIDGE_HOST] (vendor:1022 device:9600 subv:1849 subd:9600)
hid_generic     : PIXART USB OPTICAL MOUSE
user@MagOS ~ $ 

System update "rpmdrake" unenable and crash.
Comment 1 Denis Silakov 2013-06-14 16:18:12 MSD
I would suggest to run 'urpmi --auto-update --auto" from console and see if the error disappears after this.
Comment 2 Denis Silakov 2013-09-05 17:39:09 MSD
We've had a lot of updates since the time the bug was reported for rpm-related stuff and had no reports about MandrivaUpdate failures after that. Closing as "worksforme", feel free to reopen if you are able to reproduce the failure on a Fresh R1 with all updates.