Bug 217 - ROSA Marathon 2012 does not works with the broadcom (wl, b43) drivers with PAE kernels
: ROSA Marathon 2012 does not works with the broadcom (wl, b43) drivers with PA...
Status: RESOLVED WORKSFORME
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: High major
: 2012 Marathon RP1
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-12 17:12 MSD by Denis Koryavov
Modified: 2013-03-01 17:35 MSK (History)
5 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments
lspcidrake (1.82 KB, text/plain)
2012-05-12 17:12 MSD, Denis Koryavov
Details
lsmod (3.22 KB, text/plain)
2012-05-12 17:13 MSD, Denis Koryavov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Denis Koryavov 2012-05-12 17:12:42 MSD
Created attachment 142 [details]
lspcidrake

Description of problem:

I tried to install RM2012 (32 and 64 bit) to the Lenovo G570 notebook. And I can't to work with WiFi on this notebook on all kernels with the PAE support (not 32 nor 64bit). I tried to use broadcom-dkms-wl driver and b43 driver as it described on our wiki, but both of drivers do not work with PAE kernels. 

With wl driver I see WiFi networks, but can't connect to them, with b43 driver I can connect to the WiFi networks, but can not use internet - the system loose connection after few seconds (but WiFi connection is active!).  

The output of commands of lspcidrake and lsudb is attached. 

How reproducible:
Always (as far as I can see)

Steps to Reproduce:
1. Install RM2012 on any system with BCM4313 WiFi chip.
2. Try to use it with WiFi (especially when Ad-Hoc mode enabled).
Comment 1 Denis Koryavov 2012-05-12 17:13:44 MSD
Created attachment 143 [details]
lsmod
Comment 2 Postnikov Dmitry 2012-05-12 17:31:53 MSD
At the manufacturer's website wrote that the drivers for these chips do not work in Ad-Hoc mode.(I do not remember the link :) )
Comment 3 Postnikov Dmitry 2012-05-12 17:50:30 MSD
Found http://linuxwireless.org/en/users/Drivers/b43. Refer to the table, there is fixed a. It is necessary to check the firmware version.
I quote:
-----------
However, broadcom-wl does not support some things that b43/b43legacy does. broadcom-wl can only offer connection to AP or Ad-Hoc networks, it does not offer AP modes and Monitor modes. Furthermore, the driver does not cooperate well with iw tools because it has its own ieee80211 stack. This stack is both outdated and does not work with the mac80211 stack which b43/b43legacy is based on. 
-----------
We must use this driver.

On oficial website wrote (see IBSS): http://www.broadcom.com/docs/linux_sta/README.txt
Comment 4 Dmitry Mikhirev 2012-05-17 12:50:55 MSD
(In reply to comment #0)
> I tried to install RM2012 (32 and 64 bit) to the Lenovo G570 notebook. And I
> can't to work with WiFi on this notebook on all kernels with the PAE support
> (not 32 nor 64bit).

64 bit PAE? Oo
Comment 5 Alexander Burmashev 2012-08-03 17:01:13 MSD
Did you test this version ?

https://abf.rosalinux.ru/build_lists/643908
https://abf.rosalinux.ru/build_lists/643907

As far as i can see from external reports this should be working
Comment 6 Denis Koryavov 2012-12-25 21:48:50 MSK
No, unfortunately the user, who installed ROSA and faced up with this problem, removed ROSA from its notebook because didn't get any solution for a long time. I have no any devices with this problem anymore, thus, this bug can be closed I suppose.