Bug 2168 - Latex not working. latex.fmt and class descriptions missing
: Latex not working. latex.fmt and class descriptions missing
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-10 01:23 MSD by Stanislav Fomin
Modified: 2013-06-27 14:01 MSD (History)
2 users (show)

See Also:
RPM Package: texlive-latex
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stanislav Fomin 2013-06-10 01:23:17 MSD
Description of problem:
* Texlive Latex not working
* latex.fmt and class descriptions missing

How reproducible:
Always

Steps to Reproduce:

* Install lyx or TexMaker or Kyle - that most of TeX/LaTex packages
* make a sample document  

test.tex

---------------------------

\documentstyle{article}
\begin{document}
111111
\end{document}
---------------------------

Try to "latex" it.

latex test
Comment 1 Denis Silakov 2013-06-27 14:01:06 MSD
It seems that the proper metapackage that will install all components necessary to work with latex is texlive-collection-latex.

I've added such dependency to kile, texmaker and lyx (and updated kile and lyx to later versions, as well). Updated packages will be available in repos soon.

Note that we have ~1500 texlive packages. texlive-collection-latex install only part of them; this seems to be enough, but if you think that we should add dependencies on other texlive packages, feel free to reopen the bug.