Bug 2159 - nvidia173 package was updated not to provide *.so files [UPDATE REQUEST]
: nvidia173 package was updated not to provide *.so files [UPDATE REQUEST]
Status: RESOLVED INVALID
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-07 02:47 MSD by Alexander Burmashev
Modified: 2013-07-19 10:32 MSD (History)
3 users (show)

See Also:
RPM Package: nvidia173
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments
skype.log (156.84 KB, text/x-log)
2013-06-07 11:51 MSD, Vladimir Potapov
Details
173.14.37 (235.97 KB, image/png)
2013-06-07 12:51 MSD, Postnikov Dmitry
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Burmashev 2013-06-07 02:47:33 MSD
nvidia173 package was updated not to provide *.so.1 files
Comment 1 Alexander Burmashev 2013-06-07 02:50:01 MSD
Advisory:
Previously x11-driver-video-nvidia173 was providing various *.so files, including
libGL.so.1, which was causing some problems. For example while installing skype libva package could require nvidia package, instead of libgl1. So nvidia173 package was updated not to provide *.so files


Buidllists:
https://abf.rosalinux.ru/build_lists/1120356
https://abf.rosalinux.ru/build_lists/1120355

How to check:
Check old package provides and compare them to the new provides.
Comment 2 Vladimir Potapov 2013-06-07 10:25:53 MSD
#urpmi skype

*****

Некоторые запрошенные пакеты не могут быть установлены:
nvidia173-doc-html-173.14.37-2-rosa2012.1.x86_64 (из-за неудовлетворённости x11-driver-video-nvidia173[== 173.14.37-2])
x11-driver-video-nvidia173-173.14.37-2-rosa2012.1.x86_64 (из-за конфликтов с x11-driver-video-nvidia173-173.14.37-1-rosa2012.1.x86_64)
Продолжить установку? (Y/n)
Comment 3 Alexander Burmashev 2013-06-07 11:44:49 MSD
This error is irrelevant because 173.14.37-2 will be placed instead of 173.14.37-1 and there will be no 173.14.37-1 in repo.
Comment 4 Vladimir Potapov 2013-06-07 11:51:32 MSD
Created attachment 1509 [details]
skype.log
Comment 5 Vladimir Potapov 2013-06-07 12:35:43 MSD
Для удовлетворения зависимости «libGL.so.1» нужен один из следующих пакетов:
 1- libgl1-9.0.1-2-rosa2012.1.i586: Files for Mesa (GL and GLX libs) (для установки)
 2- x11-driver-video-nvidia173-173.14.37-1-rosa2012.1.i586: NVIDIA proprietary X.org driver and libraries for GeForce FX based cards (для установки)
Ваш выбор? (1-2)
Comment 6 Alexander Burmashev 2013-06-07 12:42:25 MSD
As far as i can see there is no x11-driver-video-nvidia173-173.14.37-1 in the repo, refresh your local metadata please.
Comment 7 Postnikov Dmitry 2013-06-07 12:51:01 MSD
Created attachment 1510 [details]
173.14.37

(In reply to comment #6)
> As far as i can see there is no x11-driver-video-nvidia173-173.14.37-1 in
> the repo, refresh your local metadata please.

Hm... But I also have in the repositories is he.
Comment 8 Vladimir Potapov 2013-06-07 13:13:07 MSD
x11-driver-video-nvidia173-173.14.37-2-rosa2012.1
**************************** Advisory ***********************
Previously x11-driver-video-nvidia173 was providing various *.so files, including
libGL.so.1, which was causing some problems. For example while installing skype libva package could require nvidia package, instead of libgl1. So nvidia173 package was updated not to provide *.so files
*************************************************************
QA Verified
Comment 9 Postnikov Dmitry 2013-06-09 12:10:49 MSD
Hm... My video card ATI and 64 bit system. After update, when you install Skype, according get packages dkms-nvidia-173.... & x11-driver-video-nvidia173.... 
This is no good.