Bug 2154 - Strange dependencies for lyx package
: Strange dependencies for lyx package
Status: RESOLVED INVALID
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-06 12:46 MSD by FirstLevel
Modified: 2013-06-06 16:03 MSD (History)
3 users (show)

See Also:
RPM Package: lyx-2.0.4-2-rosa2012.1.i586.rpm
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2013-06-06 12:46:09 MSD
Description of problem:
I have installed ROSA 2012.1 Fresh  and tried to install lyx package.
But the output of urmi command has shown that I need to download and install 1.6GB and 1538 packages...

1.6GB of additional disk space will be used.
1.6GB of packages will be retrieved.
Proceed with the installation of the 1538 packages? (Y/n) n

Is it normal?

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 Alexander Burmashev 2013-06-06 12:47:06 MSD
Did you install x86_64 2012.1 Fresh or i586 ?
Comment 2 FirstLevel 2013-06-06 12:47:49 MSD
i586
Comment 3 Alexander Burmashev 2013-06-06 12:51:05 MSD
Well, i see the reason. Lyx requires the whole texlive stack which really weighs 1.6 gb. We will need to check if requires can be lowered.
Comment 4 Denis Silakov 2013-06-06 12:57:08 MSD
Well, lyx is based on tex, so I think it's ok for it to require all texlive packages.

Previously (a couple of years ago) we had two huge packages - texlive-texmf (with stuff necessary to compile tex documents) and texlive-doc (with a huge set of documentation).

Then we have split these two packages on the large set of small ones, since in many cases you require only part of the whole texlive power. But I think that for Lyx it does make sense to require the whole texlive.
Comment 5 FirstLevel 2013-06-06 16:01:06 MSD
"It is normal for this package." 
Could I give this answer to user?
Comment 6 Denis Silakov 2013-06-06 16:03:17 MSD
Yes, I'd say so.

This is TeX:) And a ton of its documentation and auxiliary packages.