Bug 215 - Can not boot old kernel after the new was installed
: Can not boot old kernel after the new was installed
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: High major
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-12 16:38 MSD by Denis Koryavov
Modified: 2012-08-03 17:20 MSD (History)
5 users (show)

See Also:
RPM Package: bootloader-utils
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments
Possible patch for bootloader.pm (496 bytes, patch)
2012-06-29 15:11 MSD, Denis Silakov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Denis Koryavov 2012-05-12 16:38:38 MSD
Description of problem:

I've installed ROSA Marathon 2012 32 Bit to the Lenovo G570 notebook with 4 GB RAM. After that, I tried to install new kernel with PAE support. After I installed it, I could not load system with the support of nonpae kernel. 


How reproducible:
Always

Steps to Reproduce:
1. Install RM2012 32Bit.
2. Install PAE kernel (for example kernel-nrj-desktop686-pae).
3. Reboot and try to boot with the support of old kernel.
Comment 1 alexander barakin 2012-05-25 14:57:28 MSD
at least missing directory /lib/modules/<old-linux-modules>

i'll try to solve this problem·
Comment 2 alexander barakin 2012-05-25 15:14:21 MSD
(In reply to comment #1)
> at least missing directory /lib/modules/<old-linux-modules>

no, its content of wrong initrd

to be continued…
Comment 3 Aleksandr Kazantcev 2012-05-25 15:19:16 MSD
It problem for overwriting initramfs in initrd.img instead symlinked it.

New kernel erase old intird, becouse we using dracut -f command :(
Comment 4 Alexander Burmashev 2012-05-25 15:25:10 MSD
I am not sure that it deletes old initramfs, as far as i know it is not deleted, just symlink is replaced.
Comment 5 alexander barakin 2012-05-25 18:29:08 MSD
(In reply to comment #3)
> It problem for overwriting initramfs in initrd.img instead symlinked it.
> 
> New kernel erase old intird, becouse we using dracut -f command :(

as i see, after installing/removing package with linux, there is _bardak_ in /boot and /boot/grub/menu.lst
Comment 6 Denis Silakov 2012-06-29 15:11:28 MSD
Created attachment 319 [details]
Possible patch for bootloader.pm

The reason of the original failure is that bootloader-config leaves '/boot/initrd.img' in menu.lst as initrd for old kernel, while '/boot/initrd.img' is a symlink pointing to the newly installed kernel.

The attached is a possible patch for /usr/lib/libDrakX/bootloader.pm (this file is from drakxtools). It makes installation/removal of kernel much more predictable for me, but it would be nice if someone else perform a thorough testing.

I am also not sure if this can affect creation of iso image...
Comment 7 alexander barakin 2012-07-16 17:38:42 MSD
1. initial setup creates /boot/initrd.img as file, not symlink
2. this causes problems in the infrastructure responsible for the linux installation/removal
3. i wrote a patch, which convert /boot/initrd.img to symlink: https://abf.rosalinux.ru/sash_kan/bootloader-utils/commit/1568c50d76147cf5eeafb5a637f6b851d859a44c
4. this patch will be required until iso-image creation will be fixed
Comment 8 alexander barakin 2012-07-16 19:26:47 MSD
Advisory:
this patch prevents the inability to load the old linux after installing the new one
https://abf.rosalinux.ru/build_lists/623276
https://abf.rosalinux.ru/build_lists/623277
Comment 9 Vladimir Potapov 2012-07-18 16:53:21 MSD
bootloader-utils-1.15-9-rosa.lts2012.0
************** Advisory ***************
This patch prevents the inability to load the old linux after installing the new one
***************************************
QA Verified
Comment 10 Alexander Burmashev 2012-08-03 17:20:14 MSD
*** Bug 75 has been marked as a duplicate of this bug. ***