Bug 2090 - [UPDATE REQUEST] rosa-imagewriter 2.2
: [UPDATE REQUEST] rosa-imagewriter 2.2
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
https://abf.rosalinux.ru/import/rosa-...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-02 16:45 MSD by Konstantin Vlasov
Modified: 2013-06-04 20:56 MSD (History)
4 users (show)

See Also:
RPM Package: rosa-imagewriter
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments
A localization issue in dialog (221.01 KB, image/png)
2013-06-02 17:02 MSD, Vladimir Potapov
Details
no debug (141.68 KB, image/png)
2013-06-03 04:52 MSD, Vladimir Potapov
Details
no GUI filter (123.61 KB, image/png)
2013-06-03 04:53 MSD, Vladimir Potapov
Details
GTK-style open dialog (150.71 KB, image/png)
2013-06-03 05:21 MSD, Vladimir Potapov
Details
very sloooooow (more then 1 min) start in GNOME (x64) (782.23 KB, image/png)
2013-06-03 05:41 MSD, Vladimir Potapov
Details
differences (357.82 KB, image/png)
2013-06-03 16:08 MSD, Vladimir Potapov
Details
sudo firefox (240.74 KB, image/png)
2013-06-03 16:47 MSD, Vladimir Potapov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Konstantin Vlasov 2013-06-02 16:45:55 MSD
rosa-imagewriter was updated to version 2.2.
Comment 1 Konstantin Vlasov 2013-06-02 16:47:23 MSD
https://abf.rosalinux.ru/build_lists/1118143
https://abf.rosalinux.ru/build_lists/1118144

Advisory: The tool was rewritten from scratch, introducing new user interface and various improvements.
Comment 2 Vladimir Potapov 2013-06-02 17:02:21 MSD
Created attachment 1436 [details]
A localization issue in dialog
Comment 3 Konstantin Vlasov 2013-06-02 21:29:30 MSD
Fixed, version 2.3.

https://abf.rosalinux.ru/build_lists/1118225
https://abf.rosalinux.ru/build_lists/1118226

Advisory: The tool was rewritten from scratch, introducing new user interface and various improvements.
Comment 4 Vladimir Potapov 2013-06-03 04:52:33 MSD
Created attachment 1437 [details]
no debug
Comment 5 Vladimir Potapov 2013-06-03 04:53:08 MSD
Created attachment 1438 [details]
no GUI filter
Comment 6 Vladimir Potapov 2013-06-03 05:21:52 MSD
Created attachment 1440 [details]
GTK-style open dialog

GTK-style open dialog in KDE (but qt5 libraries in requirements)
Comment 7 Vladimir Potapov 2013-06-03 05:41:04 MSD
Created attachment 1441 [details]
very sloooooow (more then 1 min) start in GNOME (x64)
Comment 8 Konstantin Vlasov 2013-06-03 14:15:09 MSD
> no debug
Fixed:
https://abf.rosalinux.ru/build_lists/1118322
https://abf.rosalinux.ru/build_lists/1118323

> no GUI filter
This is a problem in rpmdrake. Patch has been pushed, and update is waiting for approval (bug #2094).

> GTK-style open dialog
This is a global problem of ROSA distribution itself: root user seems to have different KDE or Qt theme, therefore all applications started as root will look as on the screenshot.

> very sloooooow (more then 1 min) start in GNOME (x64)
Is it critical? I'll try to find out what the problem is, but our main platform is KDE for the moment. Should we delay publishing of the application because of this particular problem?
Comment 9 Alexander Burmashev 2013-06-03 14:45:31 MSD
Small comment - personally i do not see any other GUI tool to write rosa images from rosa system, so i do not see a bit reason to delay publishing. Imho it is always better to have a tool that is working, but have some problems.
Comment 10 Vladimir Potapov 2013-06-03 15:42:50 MSD
If errors were critical, I would have declined the update. But I would like to fix all that we can fix.
Comment 11 Vladimir Potapov 2013-06-03 15:53:15 MSD
 
> > GTK-style open dialog
> This is a global problem of ROSA distribution itself: root user seems to
> have different KDE or Qt theme, therefore all applications started as root
> will look as on the screenshot.
The problem is not in the visual style, but a dialogue. In gnome disks are mounted automatically, and therefore in the open dialog is no mechanism to mount disks. And not mounted disks are not visible. In my case the iso image was lying on a different partition and I had to run a Dolphin to access it.
Comment 12 Postnikov Dmitry 2013-06-03 15:54:29 MSD
(In reply to comment #11)
>  
> > > GTK-style open dialog
> > This is a global problem of ROSA distribution itself: root user seems to
> > have different KDE or Qt theme, therefore all applications started as root
> > will look as on the screenshot.
> The problem is not in the visual style, but a dialogue. In gnome disks are
> mounted automatically, and therefore in the open dialog is no mechanism to
> mount disks. And not mounted disks are not visible. In my case the iso image
> was lying on a different partition and I had to run a Dolphin to access it.

+100
Comment 13 Vladimir Potapov 2013-06-03 15:59:14 MSD
P.S. See firefox. In gnome  - open-file-dialog GNOME. In KDE -open-file-dialog KDE.
Comment 14 Konstantin Vlasov 2013-06-03 16:05:54 MSD
(In reply to comment #11)
> The problem is not in the visual style, but a dialogue. In gnome disks are
> mounted automatically, and therefore in the open dialog is no mechanism to
> mount disks. And not mounted disks are not visible. In my case the iso image
> was lying on a different partition and I had to run a Dolphin to access it.

(In reply to comment #13)
> P.S. See firefox. In gnome  - open-file-dialog GNOME. In KDE
> -open-file-dialog KDE.

Try to launch Firefox as root: you will see the same GTK dialog in it. It's not ROSA ImageWriter, it's the root account itself responsible for this difference.
Comment 15 Vladimir Potapov 2013-06-03 16:08:59 MSD
Created attachment 1443 [details]
differences
Comment 16 Konstantin Vlasov 2013-06-03 16:31:49 MSD
(In reply to comment #15)
> Created attachment 1443 [details]
> differences

On your screenshot console displays the Bash prompt. I means that firefox you tried to launch is not running at the moment. Probably, you already had a normal-user firefox instance running - in this case the root-user firefox did not launch, but simply sent the command of opening a new window into the existing firefix instance and terminated itself, so only the normal-user instance continues to be running. If you start
# ps auxww | grep firefox
you will see the real user account the firefox process belongs to.

Please, close all Firefox instances and try launching from root account again.
Comment 17 Vladimir Potapov 2013-06-03 16:47:27 MSD
Created attachment 1444 [details]
sudo firefox
Comment 18 Vladimir Potapov 2013-06-03 16:54:58 MSD
It may be worthwhile to remake launch on SUDO? Perhaps the problem with GNOME will go away.
Comment 19 Vladimir Potapov 2013-06-04 06:56:25 MSD
rosa-imagewriter-2.3-2-rosa2012.1
******************** Advisory **********************
The tool was rewritten from scratch, introducing new user interface and various improvements.
****************************************************
QA Verified
Comment 20 Postnikov Dmitry 2013-06-04 14:54:57 MSD
http://cdn.2safe.com/583035033557/screen4.mov
Всплывающие менюшки с предпросмотром консоли (ближе к концу ролика) всплывают на секунду и все. Только при запущенном rosa-image-writer такое.
Comment 21 Konstantin Vlasov 2013-06-04 20:56:23 MSD
(In reply to comment #20)
> http://cdn.2safe.com/583035033557/screen4.mov
> Всплывающие менюшки с предпросмотром консоли (ближе к концу ролика)
> всплывают на секунду и все. Только при запущенном rosa-image-writer такое.

It seems that disappearing preview tooltips are caused by Qt5 in general. On my machine this problem is also reproduced when I have any Qt5 application running (e.g. Qt Creator). I'll try to contact Qt developers on this problem.