Bug 2088 - Update Request fet-5.18.2 to fet-5.19.1
: Update Request fet-5.18.2 to fet-5.19.1
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Contributed Packages
: Fresh
: All Linux
: Highest normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
http://lalescu.ro/liviu/fet/
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-01 12:15 MSD by symbianflo
Modified: 2013-06-03 14:48 MSD (History)
1 user (show)

See Also:
RPM Package: Update request fet from 5.18.2 to 5.19.1
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description symbianflo 2013-06-01 12:15:21 MSD
Description of problem:
Package update request ( two versions skipped already)

Version-Release number of selected component (if applicable):


How reproducible:
fet-5.18.2 please update to fet-5.19.1

Steps to Reproduce:
The source code is here: 
http://lalescu.ro/liviu/fet/download/fet-5.19.1.tar.bz2

Can you please complete the porting with Moroccan and Algerian schools for, also (included or as a separate package):
http://lalescu.ro/liviu/fet/custom.html

#########
Flagged as "Highest priority " , here is why ,the improvements since 5.18.2:

- Version 5.19.0
	- Updated the sources to Qt 5.0.0 (but the precompiled Windows version still uses Qt 4.8.4, because of various problems).
	- Made a separate command-line interface without using the X-screen (suggested by Danny Zitzman, Zsolt Udvari and maybe other users).
	- Made generation identical on all computers, by modifying QSet handling in the parts where the generation depends on the order of
	elements in a QSet (the elements are sorted and randomized, then). A minor bug was corrected with this occasion.
	- Now you can split a year into 4 categories (suggested by Bobby Wise).
	- When starting FET, the first shortcuts tab section (File) is selected (suggested by a user).
	- Added three new sample files, by waleed and Bobby Wise.
- Version 5.19.1
	- Updated the sources to Qt 5.0.2 (but the precompiled Windows version still uses Qt 4.8.4, because of various problems).
	- Corrected some minor string problems.
	- Updated the Romanian translation (by Liviu Lalescu). Now it uses diacritics.
	- Updated the Ukrainian translation (by Andriy Melnyk).
	- Added a new sample file, by geaplanet.
########

Thank you
Comment 1 Denis Silakov 2013-06-03 14:20:04 MSD
fet has been updated.

As for Moroccan/Algerian editions, they should be implemented as separate packages. I'm afraid we don't have resources at ROSA atm to make this, but volunteers are welcome, as usual. Fet is in contrib, so there is no need in strong QA procedures there.
Comment 2 symbianflo 2013-06-03 14:41:39 MSD
(In reply to comment #1)
> fet has been updated.
> 
> As for Moroccan/Algerian editions, they should be implemented as separate
> packages. I'm afraid we don't have resources at ROSA atm to make this, but
> volunteers are welcome, as usual. Fet is in contrib, so there is no need in
> strong QA procedures there.

Yeah about that :
http://www.mandrivalinux.ro/content/solicitare-free-timetabling-software-solvedupdated
13. July 2010 - 23:57 
my first porting in mandriva , 
but when I've tried to maintain it in rosa 
you colleague wrote to me " WTF respect other packagers work" ( after I've asked in the ML if I can take FET...)
I'll never touch fet again ... if rosa don't need it I'll maintain it of course on MRB,  the developer is romanian .
Comment 3 Denis Silakov 2013-06-03 14:42:52 MSD
(In reply to comment #2)

> I'll never touch fet again ... if rosa don't need it I'll maintain it of
> course on MRB,  the developer is romanian .

Surely. It seems that previous maintainer lost interest to this package.
Comment 4 symbianflo 2013-06-03 14:48:32 MSD
(In reply to comment #3)
> (In reply to comment #2)
> 
> > I'll never touch fet again ... if rosa don't need it I'll maintain it of
> > course on MRB,  the developer is romanian .
> 
> Surely. It seems that previous maintainer lost interest to this package.

ahahahahaha niceeeee, so this is how it works? 
I'll push you out , because is my porting, and after a while I call my self out too and the packages are orphans....
No comment!!!!


Great , thx for the update .
I'll maintain it on MRB then...