Bug 2084 - ACPI Error
: ACPI Error
Status: RESOLVED WORKSFORME
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-31 15:20 MSD by Postnikov Dmitry
Modified: 2015-03-29 16:14 MSD (History)
4 users (show)

See Also:
RPM Package: kernel-nrj-desktop-3.8.12-2rosa-1-1-rosa2012.1.x86_64
ISO-related:
Bad POT generating:
Upstream:


Attachments
ACPI error.png (164.39 KB, image/png)
2013-05-31 15:20 MSD, Postnikov Dmitry
Details
dmesg.txt (56.55 KB, text/plain)
2013-05-31 15:20 MSD, Postnikov Dmitry
Details
lspci.txt (1.57 KB, text/plain)
2013-05-31 15:21 MSD, Postnikov Dmitry
Details
BIOS.png (361.75 KB, image/png)
2013-06-02 02:02 MSD, Postnikov Dmitry
Details
acpi-list.txt (242.91 KB, text/plain)
2013-06-08 21:46 MSD, Postnikov Dmitry
Details
DSDT.aml (40.32 KB, application/octet-stream)
2013-06-08 21:48 MSD, Postnikov Dmitry
Details
first version of ssdt2 (852 bytes, application/octet-stream)
2013-06-09 08:24 MSD, bober
Details
second version of ssdt2 (852 bytes, application/octet-stream)
2013-06-09 08:29 MSD, bober
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Postnikov Dmitry 2013-05-31 15:20:08 MSD
Created attachment 1430 [details]
ACPI error.png

Description of problem:
When i set SATA hdd in "IDE native" mode in BIOS - this error not found.
When i set SATA hdd in "AHCI" mode in BIOS - i see this error.
This is manifested on 3 computers testers.

Version-Release number of selected component (if applicable):

See att.
==========
[root@localhost pastordi]# cat /var/log/dmesg | grep -i -E "error|faile|segfau"
[    1.781371] ACPI Error: [DSSP] Namespace lookup failure, AE_NOT_FOUND (20121018/psargs-359)
[    1.792151] ACPI Error: Method parse/execution failed [\_SB_.PCI0.SAT0.SPT2._GTF] (Node ffff880215071910), AE_NOT_FOUND (20121018/psparse-537)
[    1.825599] ACPI Error: [DSSP] Namespace lookup failure, AE_NOT_FOUND (20121018/psargs-359)
[    1.837240] ACPI Error: Method parse/execution failed [\_SB_.PCI0.SAT0.SPT0._GTF] (Node ffff880215071820), AE_NOT_FOUND (20121018/psparse-537)
[    1.887014] ACPI Error: [DSSP] Namespace lookup failure, AE_NOT_FOUND (20121018/psargs-359)
[    1.899948] ACPI Error: Method parse/execution failed [\_SB_.PCI0.SAT0.SPT2._GTF] (Node ffff880215071910), AE_NOT_FOUND (20121018/psparse-537)
[    1.940660] ACPI Error: [DSSP] Namespace lookup failure, AE_NOT_FOUND (20121018/psargs-359)
[    1.954229] ACPI Error: Method parse/execution failed [\_SB_.PCI0.SAT0.SPT0._GTF] (Node ffff880215071820), AE_NOT_FOUND (20121018/psparse-537)
[root@localhost pastordi]#
===========
Comment 1 Postnikov Dmitry 2013-05-31 15:20:46 MSD
Created attachment 1431 [details]
dmesg.txt
Comment 2 Postnikov Dmitry 2013-05-31 15:21:17 MSD
Created attachment 1432 [details]
lspci.txt
Comment 3 Postnikov Dmitry 2013-06-01 14:11:42 MSD
Found on the kernel.org identical bug. On the motherboard with my chip Z77 and IvyBrige.
https://bugzilla.kernel.org/show_bug.cgi?id=43229
Comment 4 Alexander Burmashev 2013-06-01 14:50:04 MSD
Yes, i also have seen it, but it does not really seem very valuable to us since it is closed wontfix....
Comment 5 Postnikov Dmitry 2013-06-02 02:02:18 MSD
Created attachment 1435 [details]
BIOS.png

I tried a BIOS option "SATAxx Hot Plug" in [Enable] - but nothing to help. Mistakes are all the same.
Comment 6 bober 2013-06-08 19:30:19 MSD
attach your acpidump

you can suppress warning messages via libata.noacpi=1 kernel parameter.
Comment 7 Postnikov Dmitry 2013-06-08 21:46:41 MSD
Created attachment 1517 [details]
acpi-list.txt
Comment 8 Postnikov Dmitry 2013-06-08 21:48:07 MSD
Created attachment 1518 [details]
DSDT.aml
Comment 9 bober 2013-06-09 08:24:12 MSD
Created attachment 1519 [details]
first version of ssdt2
Comment 10 bober 2013-06-09 08:29:15 MSD
Created attachment 1520 [details]
second version of ssdt2

(second version)
Comment 11 bober 2013-06-09 08:55:49 MSD
Try out this two tables. One of them(or both) may work. Your messages from ACPI interpreter will not appear, but maybe some libata's messages occur. It is good idea to recompile kernel with CONFIG_ATA_VERBOSE_ERROR option on to get informative description of a problem. Short tutorial how to override tables can be found here 
http://lxr.linux.no/linux+v3.9.5/Documentation/acpi/initrd_table_override.txt
increase debug log level and boot with overriden table and post your dmesg if any errors occur. They may look like 
ata##: "rejected by device (Stat=0x%02x Err=0x%02x)"
"failed (Emask=0x%x Stat=0x%02x Err=0x%02x)"
"ACPI cmd %02x/%02x:%02x:%02x:%02x:%02x:%02x (%s) %s\n"

Debbuger able to execute _GTF method, but for some reason it returns 15-byte length buffer. Ata's taskfile is 7-byte length, so return value should be multiple of 7, this fact may also prevent to use acpi on your ata host


Make sure you are using >3.8 kernel and able to revert changes in your initcpio in case of error
Comment 12 bober 2013-06-09 09:00:58 MSD
>> I tried a BIOS option "SATAxx Hot Plug" in [Enable] - but nothing to help.

From acpi spec:
  9.8.1.1 _GTF (Get Task File)
  This optional object returns a buffer containing the ATA commands used to restore the drive to boot
up defaults (that is, the state of the drive after POST). The returned buffer is an array with each
element in the array consisting of seven 8-bit register values (56 bits) corresponding to ATA task
registers 1F1 thru 1F7. Each entry in the array defines a command to the drive.

It is used on resuming from s2ram, I am not shure how disabling ata hotplugging can help
Comment 13 Postnikov Dmitry 2013-11-11 22:18:02 MSK
In kernel-3.10.9-17 problem remains.
Comment 14 FirstLevel 2014-10-08 15:11:09 MSD
Please check the problem for new release
http://mirror.rosalab.ru/rosa/rosa2014.1/iso/ROSA.Fresh.R4/
Comment 15 Denis Silakov 2015-03-29 16:14:31 MSD
Let's mark as "worksforme" since we haven't see a way to reproduce this bug for a long time and initially we though that this is not a real problem that could lead to system misfunction. Feel free to reopen if your have problems with installing modern ROSA Desktop Fresh R5.