Bug 2073 - no localization grub-customizer
: no localization grub-customizer
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Localization
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: Andrey Bondrov
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-30 16:35 MSD by Vladimir Potapov
Modified: 2014-11-05 12:33 MSK (History)
5 users (show)

See Also:
RPM Package: grub-customizer
ISO-related:
Bad POT generating:
Upstream:
firstlevel: qa_verified+
andrey.bondrov: published+


Attachments
list don't localized (57.76 KB, image/png)
2013-05-30 16:35 MSD, Vladimir Potapov
Details
отсутствующие строки (41.89 KB, image/png)
2014-10-17 13:48 MSD, JDronova
Details
.po и .mo для версии 4.0 (18.71 KB, application/x-7z-compressed)
2014-10-17 18:26 MSD, JDronova
Details
error while starting after upgrade (80.88 KB, image/jpeg)
2014-10-30 14:24 MSK, FirstLevel
Details
grub-customizer-window.jpg (132.45 KB, image/jpeg)
2014-11-05 11:09 MSK, FirstLevel
Details
mainmenu.jpg (61.67 KB, image/jpeg)
2014-11-05 11:09 MSK, FirstLevel
Details
submenu.jpg (65.40 KB, image/jpeg)
2014-11-05 11:09 MSK, FirstLevel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Potapov 2013-05-30 16:35:23 MSD
Created attachment 1426 [details]
list don't localized

see screenshot
Comment 1 JDronova 2013-05-30 21:46:39 MSD
А что это за пакет?
Comment 2 Postnikov Dmitry 2013-05-30 21:50:13 MSD
(In reply to comment #1)
> А что это за пакет?

[root@localhost pastordi]# urpmq -i grub-customizer
    http://abf-downloads.rosalinux.ru/rosa2012.1/repository/x86_64/media/main/release/media_info/info.xml.lzma
Name        : grub-customizer                                                                                                                    
Version     : 2.5.6
Release     : 1
Group       : System/Configuration/Boot and Init
Size        : 1110274                      Architecture: x86_64
Source RPM  : grub-customizer-2.5.6-1.src.rpm
URL         : https://launchpad.net/grub-customizer
Summary     : Graphical interface to configure the grub2/burg settings
Description :
Grub Customizer is a graphical interface to configure the grub2/burg settings
with focus on the individual list order - without losing the dynamical
behavior of grub.
Comment 3 JDronova 2013-05-30 21:50:58 MSD
Вас понял, буду разбираться.
Comment 4 Vladimir Potapov 2013-05-31 04:06:07 MSD
Юль, хромает локализация не версии 2.5, а версии 3 которую я только что пропустил через QA потому что предыдущая совсем нерабочая.
Comment 5 Stanislav Fomin 2013-06-04 01:09:04 MSD
Move these bugs from Stanislav to Julia.
Comment 6 FirstLevel 2014-10-08 14:49:54 MSD
Please check the problem for new release
http://mirror.rosalab.ru/rosa/rosa2014.1/iso/ROSA.Fresh.R4/
Comment 7 Denis Silakov 2014-10-16 12:00:09 MSD
The issue is valid.
Comment 8 JDronova 2014-10-17 13:48:57 MSD
Created attachment 3350 [details]
отсутствующие строки

Доделала и причесала существующий перевод, но при проверке проявились строки, отсутствующие в пошке. Попробую перегенерить шаблон для начала.
Comment 9 JDronova 2014-10-17 16:52:24 MSD
Может, его и обновить до кучи? Там на оф сайте уже 4.0, и много вкусностей, судя по мессаджам. А я как раЗ переводик подгоню.
Comment 10 Andrey Bondrov 2014-10-17 17:25:50 MSD
(In reply to comment #9)
> Может, его и обновить до кучи? Там на оф сайте уже 4.0, и много вкусностей,
> судя по мессаджам. А я как раЗ переводик подгоню.

Advisory: "New version 4.0.6"

https://abf.rosalinux.ru/build_lists/2311291
https://abf.rosalinux.ru/build_lists/2311292
Comment 11 JDronova 2014-10-17 17:50:22 MSD
Меня подождите только, а то там ланчпадовские перлы щас вычищаю, нервным не смотреть.
Comment 12 JDronova 2014-10-17 18:26:48 MSD
Created attachment 3352 [details]
.po и .mo для версии 4.0
Comment 13 JDronova 2014-10-30 02:48:59 MSK
Давно можно собирать ^___^
Comment 14 Andrey Bondrov 2014-10-30 11:17:18 MSK
(In reply to comment #13)
> Давно можно собирать ^___^

Что-то не пришло сообщение с багзиллы, так что если что-то ещё так же зависло, лучше напомнить.

Advisory: "New version 4.0.6 with complete Russian translation"
https://abf.rosalinux.ru/build_lists/2325840
https://abf.rosalinux.ru/build_lists/2325841
Comment 15 FirstLevel 2014-10-30 14:24:23 MSK
Created attachment 3399 [details]
error while starting after upgrade
Comment 16 FirstLevel 2014-10-30 14:25:21 MSK
(In reply to comment #14)
> (In reply to comment #13)
> > Давно можно собирать ^___^
> 
> Что-то не пришло сообщение с багзиллы, так что если что-то ещё так же
> зависло, лучше напомнить.
> 
> Advisory: "New version 4.0.6 with complete Russian translation"
> https://abf.rosalinux.ru/build_lists/2325840
> https://abf.rosalinux.ru/build_lists/2325841

For 32bit and 64bit systems after upgrade grub-customizer I have an error while launching this utility.
See may attach in previous comment
Comment 17 FirstLevel 2014-10-31 10:22:33 MSK
************************ Advisory **********************
For 32bit and 64bit systems after upgrade grub-customizer I have an error while launching this utility.
See may attach in previous comment
********************************************************
QA Denied
Comment 18 FirstLevel 2014-10-31 15:12:33 MSK
Уточняю.
Старая версия grub-customizer запускалась и из-под root, и из-под обычного пользователя (выдавался запрос на пароль пользователя root).

Новая версия grub-customizer запускается от root, а вот от обычного пользователя вместо запроса пароля root выдается ошибка, которая на скриншоте.

Для нового пакета в зависимостях идет пакет libgtkmm3.0_1, который не требуется для старого. Видимо в нем и проблема?


Вот вывод консоли при запуске от root:
[root@r4 ~]# grub-customizer 

** (grub-customizer:8648): WARNING **: Can't load fallback CSS resource: Failed to import: Ресурс из «/org/gnome/adwaita/gtk-fallback.css» не существует

** (grub-customizer:8648): WARNING **: Can't load fallback CSS resource: Failed to import: Ресурс из «/org/gnome/adwaita/gtk-fallback.css» не существует
 *** initializing (w/o specified bootloader type)…
   * reading partition info…
   * Loading Framebuffer resolutions (background process)
   * Finding out if this is a live CD
 *** initializing (w/ specified bootloader type)…
   * Checking if the config directory is clean
 *** loading configuration
 *** loading - preserveConfig: no
   * unsetting saved config
 *** loading settings
 *** loading grub list
   * loading scripts…
   * loading proxies…
   * cleaning up proxy configuration…
   * creating proxifiedScript links & chmodding other files…
   * running grub2-mkconfig
     theme rosa not found!
   * restoring grub configuration
   * removing invalid proxies from list
   * loading completed
 *** grub list completely loaded
 *** loading saved grub list
GLib-GIO-Message: Using the 'memory' GSettings backend.  Your settings will not be saved or shared with other applications.
[root@r4 ~]#
Comment 19 Andrey Bondrov 2014-11-02 16:56:10 MSK
Should be fixed now.

Advisory: "New version 4.0.6 with complete Russian translation"
https://abf.rosalinux.ru/build_lists/2328054
https://abf.rosalinux.ru/build_lists/2328055
Comment 20 FirstLevel 2014-11-05 11:09:04 MSK
(In reply to comment #19)
> Should be fixed now.
> 
> Advisory: "New version 4.0.6 with complete Russian translation"
> https://abf.rosalinux.ru/build_lists/2328054
> https://abf.rosalinux.ru/build_lists/2328055

I don't fully understand some things.
I see that grub menu contains 
- mainmenu.jpg
- submenu.jpg

If I launch grub-customizer I see such window: grub-customizer-window.jpg

Why I could not see Repair Tools in grub menu?

Russian localization works is full.
Comment 21 FirstLevel 2014-11-05 11:09:25 MSK
Created attachment 3402 [details]
grub-customizer-window.jpg
Comment 22 FirstLevel 2014-11-05 11:09:42 MSK
Created attachment 3403 [details]
mainmenu.jpg
Comment 23 FirstLevel 2014-11-05 11:09:59 MSK
Created attachment 3404 [details]
submenu.jpg
Comment 24 FirstLevel 2014-11-05 12:08:41 MSK
grub-customizer-4.0.6-4
http://abf-downloads.rosalinux.ru/rosa2014.1/container/2328054/i586/main/release/
http://abf-downloads.rosalinux.ru/rosa2014.1/container/2328055/x86_64/main/release/
************************ Advisory **********************
"New version 4.0.6 with complete Russian translation"
********************************************************
QA Verified