Bug 2060 - Need to reconfigure HP LJ P1102 every time after reboot
: Need to reconfigure HP LJ P1102 every time after reboot
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-28 11:06 MSD by FirstLevel
Modified: 2013-09-10 11:21 MSD (History)
5 users (show)

See Also:
RPM Package: hplip-3.12.10-2-rosa2012.1.x86_64
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments
diag.txt (3.90 KB, text/plain)
2013-05-28 11:06 MSD, FirstLevel
Details
printers.conf.good.txt (538 bytes, text/plain)
2013-05-28 11:06 MSD, FirstLevel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2013-05-28 11:06:16 MSD
Created attachment 1422 [details]
diag.txt

Description of problem:
I have installed ROSA 2012.1 Fresh and plugged printer Hewlett-Packard LaserJet P1102.
I have set up printer. See  attach printers.conf.good.txt
If I restart system I could not print because system does not see printer and I need to reconfigure printer again.
Another problem if I set up printer and do not reboot but printer is slept I could not print again because printing process is hanging with message "Printer is not plugged". Some diagnostic information for second problem are described in attachment. 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 FirstLevel 2013-05-28 11:06:33 MSD
Created attachment 1423 [details]
printers.conf.good.txt
Comment 2 FirstLevel 2013-05-28 11:07:27 MSD
some additional information.
After reboot the information about early installed printer is absent in printers.conf
Comment 3 Sergey Zhemoitel 2013-05-29 14:09:55 MSD
На сайте разработчика hplip версии 3.13.5, в репозитории 3.12.10... М.б. проблема решится обновлением?
Comment 5 Sergey Zhemoitel 2013-05-31 11:03:26 MSD
На сегодня с пакетами из предложенного источника проблем не обнаружено.
Comment 6 Sergey Zhemoitel 2013-08-15 13:07:01 MSD
Может имеет смысл пересобрать пакеты hplip с 3.13.8?

Так как с 3.13.5 описанных проблем в обозначенном баге не обнаружено.
Comment 7 Sergey Zhemoitel 2013-08-15 13:09:25 MSD
протестировать и отправить в ROSA Fresh 2012.1?
Comment 8 Denis Silakov 2013-08-23 14:39:31 MSD
*** Bug 1611 has been marked as a duplicate of this bug. ***
Comment 9 Denis Silakov 2013-08-26 10:53:27 MSD
Could you try these packages:

https://abf.rosalinux.ru/build_lists/1220389
https://abf.rosalinux.ru/build_lists/1220390

This is 3.13.8 backported from cooker.
Comment 10 Sergey Zhemoitel 2013-08-28 14:48:25 MSD
Прогонка на 2-х машинах не показала проблем с драйвером и принтером. 
Если есть возможность, то можно ли добавить пакет в обновления основного дистрибутива?
Comment 11 Denis Silakov 2013-08-28 14:59:48 MSD
Advisory:

hplip has been updated to version 3.13.8. As usual, the new version adds support for many new printers and contains several bug fixes (including fixes for hplip upgrade tool crashes and problems after shutting down/rebooting the computer).

Detailed changelog is available here:
http://sourceforge.net/p/hplip/news/

Build lists:
https://abf.rosalinux.ru/build_lists/1220389
https://abf.rosalinux.ru/build_lists/1220390
Comment 12 Vladimir Potapov 2013-08-29 18:00:09 MSD
Wow! My Hp1606dn now work!
Comment 13 Vladimir Potapov 2013-08-29 19:53:55 MSD
Two regressions:
1) on i586 my hp1606 don't detect after update (x64 - now excellent work!)
2) hp-setup start fail after update (before update check password automatically, this tool start from gui too)
****************
QA Denied
Comment 14 Denis Silakov 2013-08-30 16:51:41 MSD
Can you try these builds for hp-setup issue:

https://abf.rosalinux.ru/build_lists/1223701
https://abf.rosalinux.ru/build_lists/1223702

As for hp1606 - did it work with previous hplip on i586?
Comment 15 Vladimir Potapov 2013-08-30 16:53:45 MSD
(In reply to comment #14)

> As for hp1606 - did it work with previous hplip on i586?

with previous hplip the printer detect and work with standard hp5pcl driver.
Comment 16 Vladimir Potapov 2013-08-31 11:06:13 MSD
Problem description:
http://hplipopensource.com/node/367

hp-doctor script run command ' su -c "/usr/bin/gpg --no-permission-warning --keyserver pgp.mit.edu --recv-keys 0xA59047B9" '
and don't query password.
Comment 17 Vladimir Potapov 2013-08-31 11:38:12 MSD
run http://hplipopensource.com/hplip-web/smartinstall/SmartInstallDisable-Tool.run solve problem with the printer.

Maybe, add the tool to the package and write package external info?
"For HP LaserJet 1100 series,HP LaserJet p1560 series,HP LaserJet p1600 series, HP LaserJet CP1020 series, HP LaserJet M1130 MFP series, HP LaserJet M1210 MFP series we recommend to run SmartInstallDisable-Tool.run after printer connection"
Comment 18 Denis Silakov 2013-09-06 11:55:03 MSD
Advisory:

hplip has been updated to version 3.13.8. As usual, the new version adds support for many new printers and contains several bug fixes (including fixes for hplip upgrade tool crashes and problems after shutting down/rebooting the computer).

Detailed changelog is available here:
http://sourceforge.net/p/hplip/news/

Build lists:
https://abf.rosalinux.ru/build_lists/1245225
https://abf.rosalinux.ru/build_lists/1245226

SmartInstallDisable-Tool.run is included in these packages. I have also added README.urpmi file with infromation about this tool which will bedisplayed by urpmi and rpmdrake.
Comment 19 Vladimir Potapov 2013-09-07 19:09:11 MSD
hplip-3.13.8-4-rosa2012.1
***************** Advisory ************************
hplip has been updated to version 3.13.8. As usual, the new version adds support for many new printers and contains several bug fixes (including fixes for hplip upgrade tool crashes and problems after shutting down/rebooting the computer).
SmartInstallDisable-Tool.run is included in these packages. I have also added README.urpmi file with infromation about this tool which will bedisplayed by urpmi and rpmdrake.
***************************************************
QA Verified