Bug 2058 - In some cases KCM KDM prefers English locale over system locale
: In some cases KCM KDM prefers English locale over system locale
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-27 20:04 MSD by Andrey Bondrov
Modified: 2013-05-28 11:03 MSD (History)
2 users (show)

See Also:
RPM Package: kdm
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Bondrov 2013-05-27 20:04:25 MSD
In some cases KCM KDM prefers English locale over system locale. 

How to reproduce. Edit 

/var/lib/mandriva/kde4-profiles/Default/share/config/kdm/kdmrc

and change Language to ru_RU.UTF-8 (Language=ru_RU.UTF-8). After that you'll see that KDM is properly localized for Russian language. But when you open KCM KDM, you'll see that language setting is reset to English. And when you apply changes made in KCM KDM, you may lose your KDM localization. This happens because while KDM perfectly understands ru_RU.UTF-8, KCM KDM doesn't (it understands only plain ru).

Other than that, it's better to set default language in KCM KDM according to system locale when reading the value from KDM config fails for some reasons.
Comment 1 Andrey Bondrov 2013-05-27 20:05:54 MSD
Advisory: "Prefer system locale for KDM when reading language settings from KDM config fails"

https://abf.rosalinux.ru/build_lists/1116741
https://abf.rosalinux.ru/build_lists/1116742
Comment 2 JDronova 2013-05-27 20:58:18 MSD
*** Bug 2054 has been marked as a duplicate of this bug. ***
Comment 3 Vladimir Potapov 2013-05-28 05:11:37 MSD
kdm-4.10.3-10-rosa2012.1
********************* Advisory **************************
Prefer system locale for KDM when reading language settings from KDM config fails
*********************************************************
QA Verified