Bug 2053 - Invalid LO icons
: Invalid LO icons
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Design
: Fresh
: All Linux
: Low minor
: ---
Assigned To: Design Team Group
: Group of QA Team
:
Depends on:
Blocks: 5062
  Show dependency treegraph
 
Reported: 2013-05-27 12:25 MSD by Vladimir Potapov
Modified: 2015-02-17 19:29 MSK (History)
7 users (show)

See Also:
RPM Package: libre-office
ISO-related:
Bad POT generating:
Upstream:


Attachments
invalid icon (32.46 KB, image/png)
2013-05-27 12:25 MSD, Vladimir Potapov
Details
ss (27.43 KB, image/png)
2015-01-17 20:38 MSK, Vladimir Potapov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Potapov 2013-05-27 12:25:29 MSD
Created attachment 1416 [details]
invalid icon

See screenshot
Comment 1 Denis Silakov 2013-06-03 20:32:36 MSD
"Invalid" means "too small"?
Comment 2 Vladimir Potapov 2013-06-04 05:30:59 MSD
(In reply to comment #1)
> "Invalid" means "too small"?

Too small and invalid white background.
Comment 3 Vladimir Potapov 2013-06-04 05:31:34 MSD
*** Bug 2107 has been marked as a duplicate of this bug. ***
Comment 4 Denis Silakov 2013-10-30 18:15:52 MSK
*** Bug 3025 has been marked as a duplicate of this bug. ***
Comment 5 Denis Silakov 2013-10-30 22:53:41 MSK
Maybe out UXteam can help with this? We have a lot of other examples of small icons, but the LibreOffice ones seem to be the most annoying/ugly.
Comment 6 Dmitry 2013-11-01 11:23:23 MSK
Each icon is taken from X-Window system (special property of window). If application attaches only small icon to its window then KDE will show only small icon.
Comment 7 Vladimir Potapov 2013-11-01 14:01:07 MSK
(In reply to comment #6)
> Each icon is taken from X-Window system (special property of window). If
> application attaches only small icon to its window then KDE will show only
> small icon.

The bug fixed for marathon's office but it showed again.
Comment 8 Dmitry 2013-11-01 14:10:10 MSK
How it is fixed for marathon?
Comment 9 Stanislav Fomin 2013-11-25 13:02:20 MSK
Переношу в выделенный продукт.
Comment 10 Denis Silakov 2013-12-19 15:24:50 MSK
*** Bug 3220 has been marked as a duplicate of this bug. ***
Comment 11 Vladimir Potapov 2015-01-17 20:37:28 MSK
Я нашел вполне приемлемый обход этой старой некрасивости.
https://bugs.kde.org/show_bug.cgi?id=294163
По-умолчанию там требуются иконки в 128 и не все их дают (офис, скайп, драк-утилиты меньше других и получается некрасиво).
Но можно просто изменить требуемый размер до 64 и все станет чуть меньше, зато ровнее.
Для этого нужно просто в  /usr/share/apps/kwin/tabbox/big_icons/contents/ui/main.qml 
изменить IconSize: 128 на IconSize: 64
Comment 12 Vladimir Potapov 2015-01-17 20:38:03 MSK
Created attachment 3643 [details]
ss
Comment 13 Andrey Bondrov 2015-01-19 13:40:10 MSK
Should be fixed in next kdebase4-workspace, I'll let you know when it's ready for testing.
Comment 14 Vladimir Potapov 2015-02-17 19:29:33 MSK
Fixed