Bug 2050 - KCM KDM resets fonts, style and color to system defaults (KDE bug 254430)
: KCM KDM resets fonts, style and color to system defaults (KDE bug 254430)
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-24 11:09 MSD by Andrey Bondrov
Modified: 2013-05-24 16:57 MSD (History)
2 users (show)

See Also:
RPM Package: kdm
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Bondrov 2013-05-24 11:09:04 MSD
KCM KDM resets fonts, style and color to system defaults when you open it ("Настрока рабочего стола" -> "Вход в систему").

See KDE bug: https://bugs.kde.org/show_bug.cgi?id=254430

How to reproduce:
1) Change application style to anything different from system defaults (for example, to Cleanlooks). Save settings.
2) Open KCM KDM. There's no need to change anything there, it's enough to just run this KCM.
3) Check application style. It's reset to system defaults.

The same applies to color scheme and fonts.

Another way to reproduce
1) Change application style to anything different from system defaults. Save settings.
2) Save $HOME/.kde4/share/config/kdeglobals file somewhere
3) Open KCM KDM.
4) Compare $HOME/.kde4/share/config/kdeglobals file with the one you saved in #2. You'll see your config messed up.
Comment 1 Andrey Bondrov 2013-05-24 11:09:47 MSD
Advisory: "Fix bug with KCM KDM resetting fonts, style and color to system defaults (KDE bug 254430)"

https://abf.rosalinux.ru/build_lists/1108717
https://abf.rosalinux.ru/build_lists/1108718
Comment 2 Vladimir Potapov 2013-05-24 16:54:55 MSD
kdebase4-workspace-4.10.3-9-rosa2012.1
*********************** Advisory **************************
Fix bug with KCM KDM resetting fonts, style and color to system defaults (KDE bug 254430)
***********************************************************
QA Verified