Bug 2048 - GDB return error: rpmdb: Program version 5.1 doesn't match environment version 5.2
: GDB return error: rpmdb: Program version 5.1 doesn't match environment versio...
Status: RESOLVED WORKSFORME
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-23 22:59 MSD by Alexander Petryakov
Modified: 2013-08-19 16:29 MSD (History)
1 user (show)

See Also:
RPM Package: gdb-7.1-5.src.rpm
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Petryakov 2013-05-23 22:59:42 MSD
Description of problem:

# gdb ls (can be any application)
GNU gdb (GDB) 7.1-5 (ROSA Linux release 2012.0)
Copyright (C) 2010 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i586-mandriva-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...

Reading symbols from /bin/ls...rpmdb: Program version 5.1 doesn't match environment version 5.2

rpmdb: Unacceptable log file /var/lib/rpm/./log/log.0000000023: unsupported log version 18
rpmdb: Invalid log file: log.0000000023: Недопустимый аргумент
rpmdb: PANIC: Недопустимый аргумент
==> rpmdbe_event_notify(0x92ac680, PANIC(0), 0xbfc0c804) app_private (nil)
rpmdb: unable to join the environment
error: db_init:db3.c:1009: dbenv->open(-30973): DB_RUNRECOVERY: Fatal error, run database recovery
error: db3open:db3.c:2334: dbenv->open(-30973): DB_RUNRECOVERY: Fatal error, run database recovery
error: cannot open Packages(0) index: (-30973)
        DB: Berkeley DB 5.1.25: (January 28, 2011)
error: не могу открыть базу данных Packages в 
rpmdb: Unacceptable log file /var/lib/rpm/./log/log.0000000023: unsupported log version 18
rpmdb: Invalid log file: log.0000000023: Недопустимый аргумент
rpmdb: PANIC: Недопустимый аргумент
==> rpmdbe_event_notify(0x92b6ca0, PANIC(0), 0xbfc0e814) app_private (nil)
rpmdb: unable to join the environment
error: db_init:db3.c:1009: dbenv->open(-30973): DB_RUNRECOVERY: Fatal error, run database recovery
Re-opening dbenv with DB_RECOVER ...
rpmdb: Unacceptable log file /var/lib/rpm/./log/log.0000000023: unsupported log version 18
rpmdb: Invalid log file: log.0000000023: Недопустимый аргумент
rpmdb: PANIC: Недопустимый аргумент
==> rpmdbe_event_notify(0x92b6ca0, PANIC(0), 0xbfc0e814) app_private (nil)
rpmdb: unable to join the environment
error: db_init:db3.c:1009: dbenv->open(-30973): DB_RUNRECOVERY: Fatal error, run database recovery

recovery failed. Exiting ...
[root@Mar-x86 sasha]# rpm -q gdb
gdb-7.1-5-rosa.lts2012.0.i586
[root@Mar-x86 sasha]# rpm -qi gdb
Name        : gdb                          Relocations: (not relocatable)
Version     : 7.1                               Vendor: ROSA
Release     : 5                             Build Date: Вск 06 Май 2012 00:11:11
Install Date: Втр 21 Май 2013 18:16   Build Host: rosa-build-i586-1r.rosalinux.ru
Group       : Development/Other             Source RPM: gdb-7.1-5.src.rpm
Size        : 9214422                          License: GPLv3+
Signature   : RSA/SHA1, Птн 11 Май 2012 13:43:29, Key ID f53e9db116a853e7
URL         : http://www.gnu.org/software/gdb/
Summary     : A GNU source-level debugger for C, C++ and Fortran
Architecture: i586
Description :
Gdb is a full featured, command driven debugger. Gdb allows you to
trace the execution of programs and examine their internal state at
any time.  Gdb works for C and C++ compiled with the GNU C compiler
gcc.

If you are going to develop C and/or C++ programs and use the GNU gcc
compiler, you may want to install gdb to help you debug your programs.
Comment 1 Denis Silakov 2013-05-24 11:44:39 MSD
Maybe this is cause by the fact that debug-package was built using old rpm?

What happens if you remove coreutils-debug?
Comment 2 Denis Silakov 2013-08-19 16:29:36 MSD
Well, closing as 'worksforme', likely the issue arose due to the fact that some debug packages were built before switching Marathon to newer rpm. Feel free to reopen the bug if you are able to reproduce the issue,