Bug 2006 - [UPDATE REQUEST] systemd-194-17.src.rpm
: [UPDATE REQUEST] systemd-194-17.src.rpm
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Highest critical
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-14 21:04 MSD by Aleksandr Kazantcev
Modified: 2013-05-20 14:41 MSD (History)
3 users (show)

See Also:
RPM Package: systemd-194-17.src.rpm
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments
smd1 (366.64 KB, image/png)
2013-05-17 14:45 MSD, Postnikov Dmitry
Details
smd1double (638.90 KB, image/png)
2013-05-17 23:45 MSD, Postnikov Dmitry
Details
Postnikov-all(updKDE4.10.3-systemd194-17-2).odt (13.32 KB, application/vnd.oasis.opendocument.text)
2013-05-18 23:17 MSD, Postnikov Dmitry
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aleksandr Kazantcev 2013-05-14 21:04:32 MSD
New versuion with presets and logind patch
Comment 1 Aleksandr Kazantcev 2013-05-14 21:08:04 MSD
https://abf.rosalinux.ru/build_lists/1088959
https://abf.rosalinux.ru/build_lists/1088958

Advisory: This update consists three important fix for current and feature updates:

- add presets for accountservice, than thay not be deleted after upgrade
- add presets for kdm, gdm, xdm, lightdm, slim
- add logind patch to check users only in tty and x11 session, that prevent disabling poweroff/shutdowns with ftp, ssh and other sessions


How test - please install and see if all corrects and test all with newest DM update.
Comment 2 Vladimir Potapov 2013-05-15 18:47:07 MSD
The package route to extended testing
Comment 3 Postnikov Dmitry 2013-05-17 01:45:18 MSD
(In reply to comment #2)
> The package route to extended testing

Adopted in work with KDE 4.10.3
Comment 4 Postnikov Dmitry 2013-05-17 14:45:25 MSD
Created attachment 1375 [details]
smd1

This after half day work. (kde4.10.3)

journalctl -p -err
===================
May 17 12:24:20 localhost.localdomain systemd-udevd[362]: specified group 'scanner' unknown
May 17 12:24:21 localhost.localdomain kernel: sp5100_tco: mmio address 0xfec000f0 already in use
May 17 12:24:24 localhost.localdomain systemd-tmpfiles[1231]: [/usr/lib/tmpfiles.d/legacy.conf:22] Unknown group 'lock'.
May 17 12:24:24 localhost.localdomain systemd[1]: Failed to start Recreate Volatile Files and Directories.
May 17 12:24:26 localhost.localdomain systemd[1]: Failed to start Configure CPU power related settings.
May 17 12:24:30 localhost.localdomain kdm[1437]: Cannot lock pid file /var/run/kdm.pid, another xdm is running (pid 1462)
May 17 12:24:30 localhost.localdomain NetworkManager[1553]: read_mac_address: assertion `*error == NULL' failed
May 17 12:24:30 localhost.localdomain NetworkManager[1553]: nm_connection_verify: assertion `*error == NULL' failed
May 17 12:24:36 localhost.localdomain systemd[1]: Failed to start LSB: Winbind naming service (winbindd).
May 17 12:25:13 localhost.localdomain pulseaudio[3313]: [pulseaudio] pid.c: Daemon already running.
May 17 12:25:13 localhost.localdomain pulseaudio[3316]: [pulseaudio] pid.c: Daemon already running.
May 17 12:25:13 localhost.localdomain pulseaudio[3318]: [pulseaudio] pid.c: Daemon already running.
May 17 12:25:26 localhost.localdomain kdm[1444]: Cannot execute 'grub-set-default': not in $PATH.
May 17 12:25:26 localhost.localdomain kdm[1444]: Cannot execute 'grub': not in $PATH.
May 17 12:25:33 localhost.localdomain kdm[1444]: Cannot execute 'grub-set-default': not in $PATH.
May 17 12:25:33 localhost.localdomain kdm[1444]: Cannot execute 'grub': not in $PATH.
May 17 12:25:41 localhost.localdomain kdm[1444]: Cannot execute 'grub-set-default': not in $PATH.
May 17 12:25:41 localhost.localdomain kdm[1444]: Cannot execute 'grub': not in $PATH.
May 17 12:29:50 localhost.localdomain kdm[1444]: Cannot execute 'grub-set-default': not in $PATH.
May 17 12:29:50 localhost.localdomain kdm[1444]: Cannot execute 'grub': not in $PATH.
May 17 12:39:13 localhost.localdomain systemd-tmpfiles[11959]: [/usr/lib/tmpfiles.d/legacy.conf:22] Unknown group 'lock'.
May 17 12:39:13 localhost.localdomain systemd-tmpfiles[11959]: stat(/run/user/500/gvfs) failed: Permission denied
May 17 12:39:13 localhost.localdomain systemd[1]: Failed to start Cleanup of Temporary Directories.
May 17 13:02:15 localhost.localdomain su[22548]: pam_systemd(su:session): Failed to create session: Invalid argument
May 17 13:02:15 localhost.localdomain su[22553]: pam_systemd(su:session): Failed to create session: Invalid argument
May 17 13:03:30 localhost.localdomain su[23111]: pam_systemd(su:session): Failed to create session: Invalid argument
May 17 13:03:30 localhost.localdomain su[23116]: pam_systemd(su:session): Failed to create session: Invalid argument
May 17 13:04:36 localhost.localdomain su[23559]: pam_systemd(su:session): Failed to create session: Invalid argument
May 17 13:04:36 localhost.localdomain su[23564]: pam_systemd(su:session): Failed to create session: Invalid argument
May 17 13:04:49 localhost.localdomain su[23718]: pam_systemd(su:session): Failed to create session: Invalid argument
May 17 13:04:50 localhost.localdomain su[23723]: pam_systemd(su:session): Failed to create session: Invalid argument
May 17 13:05:06 localhost.localdomain su[23889]: pam_systemd(su:session): Failed to create session: Invalid argument
May 17 13:05:06 localhost.localdomain su[23894]: pam_systemd(su:session): Failed to create session: Invalid argument
May 17 14:38:46 localhost.localdomain su[4400]: pam_systemd(su:session): Failed to create session: Invalid argument
===================
Comment 5 Postnikov Dmitry 2013-05-17 14:46:44 MSD
kde4.10.3

systemctl status kdm
====================
[root@localhost pastordi]# systemctl status kdm
kdm.service - K Display Manager
          Loaded: loaded (/lib/systemd/system/kdm.service; enabled)
          Active: active (running) since Fri, 17 May 2013 12:24:26 +0400; 2h 21min ago
        Main PID: 1444 (kdm)
          CGroup: name=systemd:/system/kdm.service
                  ├ 1444 /usr/bin/kdm -nodaemon
                  └ 1624 /etc/X11/X :0 vt7 -nolisten tcp -auth /var/run/xauth/A:0-GKjn2b

May 17 12:24:54 localhost.localdomain kdm[2198]: :0[2198]: pam_tcb(kde:auth): Authentication passed for pastordi from (uid=0)
May 17 12:24:54 localhost.localdomain kdm[2198]: :0[2198]: pam_tcb(kde:session): Session opened for pastordi by (uid=0)
May 17 12:25:26 localhost.localdomain kdm[1444]: Cannot execute 'grub-set-default': not in $PATH.
May 17 12:25:26 localhost.localdomain kdm[1444]: Cannot execute 'grub': not in $PATH.
May 17 12:25:33 localhost.localdomain kdm[1444]: Cannot execute 'grub-set-default': not in $PATH.
May 17 12:25:33 localhost.localdomain kdm[1444]: Cannot execute 'grub': not in $PATH.
May 17 12:25:41 localhost.localdomain kdm[1444]: Cannot execute 'grub-set-default': not in $PATH.
May 17 12:25:41 localhost.localdomain kdm[1444]: Cannot execute 'grub': not in $PATH.
May 17 12:29:50 localhost.localdomain kdm[1444]: Cannot execute 'grub-set-default': not in $PATH.
May 17 12:29:50 localhost.localdomain kdm[1444]: Cannot execute 'grub': not in $PATH.
[root@localhost pastordi]#
==============
Comment 6 Vladimir Potapov 2013-05-17 14:48:27 MSD
It's regression?
Comment 7 Postnikov Dmitry 2013-05-17 14:50:25 MSD
(In reply to comment #6)
> It's regression?

This NO end testing!
But ... regression i see.
Comment 8 Vladimir Potapov 2013-05-17 14:55:56 MSD
Is error present with NEW KDE and OLD systemd?
Comment 9 Alexander Burmashev 2013-05-17 14:56:18 MSD
Unknown group 'lock'. - reinstalling lockdev  from scratch should help. To be sure 
rpm -e lockdev --nodeps
urpmi lockdev
Comment 10 Aleksandr Kazantcev 2013-05-17 14:57:28 MSD
Logind patch related to greeter options (not use in KDM) and tty/x11 session (not in standalone machines).

Please test all in old systemd and new KDE.
Comment 11 Postnikov Dmitry 2013-05-17 23:17:13 MSD
(In reply to comment #8)
> Is error present with NEW KDE and OLD systemd?

No. This NEW KDE 4.10.3 and systemd-194-17.
Comment 12 Aleksandr Kazantcev 2013-05-17 23:21:54 MSD
http://lists.rosalab.ru/pipermail/rosa-devel/2013-February/004287.html - pam_systemd(su:session): Failed to create session: Invalid argument error present in old systemd too and fix only in systemd > 195 (see this bug - https://bugs.freedesktop.org/show_bug.cgi?id=55656)
Comment 13 Aleksandr Kazantcev 2013-05-17 23:26:32 MSD
This error: (kdm[1444]: Cannot execute 'grub-set-default': not in $PATH.) - when we moved to systemd we was able see this errors.

This error (with gvfs error in ALL distro) also present in old systemd-194

May 17 12:39:13 localhost.localdomain systemd-tmpfiles[11959]: [/usr/lib/tmpfiles.d/legacy.conf:22] Unknown group 'lock'.
May 17 12:39:13 localhost.localdomain systemd-tmpfiles[11959]: stat(/run/user/500/gvfs) failed: Permission denied
Comment 14 Postnikov Dmitry 2013-05-17 23:45:44 MSD
Created attachment 1379 [details]
smd1double

(In reply to comment #12)
> http://lists.rosalab.ru/pipermail/rosa-devel/2013-February/004287.html -
> pam_systemd(su:session): Failed to create session: Invalid argument error
> present in old systemd too and fix only in systemd > 195 (see this bug -
> https://bugs.freedesktop.org/show_bug.cgi?id=55656)

OK :)
this screenshot is suitable for a comparison?
Comment 15 Postnikov Dmitry 2013-05-17 23:53:53 MSD
19(In reply to comment #13)
> This error: (kdm[1444]: Cannot execute 'grub-set-default': not in $PATH.) -
> when we moved to systemd we was able see this errors.
> 
> This error (with gvfs error in ALL distro) also present in old systemd-194
> 
> May 17 12:39:13 localhost.localdomain systemd-tmpfiles[11959]:
> [/usr/lib/tmpfiles.d/legacy.conf:22] Unknown group 'lock'.
> May 17 12:39:13 localhost.localdomain systemd-tmpfiles[11959]:
> stat(/run/user/500/gvfs) failed: Permission denied

 	
The above conclusion was with systemd-194-17, following the conclusion with systemd-194-17

I think the difference is in the negative side is visible?

===========
[root@localhost pastordi]# systemctl status kdm
kdm.service - K Display Manager
          Loaded: loaded (/lib/systemd/system/kdm.service; enabled)
          Active: active (running) since Fri, 17 May 2013 23:49:12 +0400; 1min 6s ago
        Main PID: 1433 (kdm)
          CGroup: name=systemd:/system/kdm.service
                  ├ 1433 /usr/bin/kdm -nodaemon
                  └ 1485 /etc/X11/X :0 vt7 -nolisten tcp -auth /var/run/xauth/A:0-WuGiyb

May 17 23:49:12 localhost.localdomain systemd[1]: Starting K Display Manager...
May 17 23:49:12 localhost.localdomain systemd[1]: Started K Display Manager.
May 17 23:49:41 localhost.localdomain kdm[1825]: :0[1825]: pam_tcb(kde:auth): Authentication passed for pastordi from (uid=0)
May 17 23:49:41 localhost.localdomain kdm[1825]: :0[1825]: pam_tcb(kde:session): Session opened for pastordi by (uid=0)
[root@localhost pastordi]# 
===========
Comment 16 Aleksandr Kazantcev 2013-05-18 00:09:26 MSD
I will try rebuild systemd only with one patch - add new greeter options. If error atill appears i think we has some strange regress in build...
Comment 17 Postnikov Dmitry 2013-05-18 00:18:15 MSD
*******************
Extended testing report
*******************
http://cdn.2safe.com/528366033558/Postnikov-all(updKDE4.10.3-systemd194-17).odt
Comment 18 Aleksandr Kazantcev 2013-05-18 00:20:10 MSD
Try this packages

https://abf.rosalinux.ru/build_lists/1098008
https://abf.rosalinux.ru/build_lists/1098009
Comment 19 Postnikov Dmitry 2013-05-18 00:55:44 MSD
(In reply to comment #18)
> Try this packages
> 
> https://abf.rosalinux.ru/build_lists/1098008
> https://abf.rosalinux.ru/build_lists/1098009

ОК.
Sent the job to test these packages. Tomorrow after 21h (MSK) will be results.
Comment 20 Alexander Burmashev 2013-05-18 01:14:53 MSD
I am a bit lost in the report, can we sum them

1) kdm + grub
not a systemd error at all. Even if it is seen with new systemd, it is not a systemd bug. KDM probes some binary files of grub and can't find them, and it is seen in the log. I am not even sure it can be treated like a bug.


2) lock group - already answered.


What else ? Let's split the problems into small one and discuss/fix them one by one.
Comment 21 Postnikov Dmitry 2013-05-18 01:27:43 MSD
(In reply to comment #20)
> I am a bit lost in the report, can we sum them
> 
> 1) kdm + grub
> not a systemd error at all. Even if it is seen with new systemd, it is not a
> systemd bug. KDM probes some binary files of grub and can't find them, and
> it is seen in the log. I am not even sure it can be treated like a bug.
> 
> 
> 2) lock group - already answered.
> 
> 
> What else ? Let's split the problems into small one and discuss/fix them one
> by one.

Yes to these two problems is clear. 

I gave the task for testers is:
=================================
.....
a) Install the package "urpm-tools"
b) Delete the repository with systemd-194-17 (which was added yesterday)
c) Repository KDE 4,10,3 should stay on.
d) Run the command "urpm-reposync" and agree to sync.
e) After the synchronization check what is a package of systemd-194-14 and kde 4.10.3
f) Reboot.
You already know the weaknesses of systend 17, on this can these weak
place on systemd the 14th check. Type screens remove, etc.

3. Connect the NEW repository systemd-194-17
32bit
https://abf.rosalinux.ru/build_lists/1098008
64 bit
https://abf.rosalinux.ru/build_lists/1098009

4. Update the system, and it will be updated systemd.
....
=================================

I think that after the tests of the new systemd will see what and how. I am not here to write, to not clutter up the Bugzilla. After the reports, then on the items can be anything out.
Comment 22 Postnikov Dmitry 2013-05-18 23:17:53 MSD
Created attachment 1383 [details]
Postnikov-all(updKDE4.10.3-systemd194-17-2).odt

*******************************
Extended testing report- 2
******************************
Comment 23 Aleksandr Kazantcev 2013-05-18 23:37:53 MSD
I disabled one patch may doing regress (see https://abf.rosalinux.ru/import/systemd/diff/112649e62c646b26149fe02b646fae48acb18109...90aeb9f9f51cfbc17c54f748bbae4ff5341d5b75). We strongly need only greeter patcha end presets for DM.

Similar version built for import and may be use for QA approving

https://abf.rosalinux.ru/build_lists/1098152
https://abf.rosalinux.ru/build_lists/1098153
Comment 24 Postnikov Dmitry 2013-05-19 00:08:14 MSD
Once again test necessary?
Comment 25 Aleksandr Kazantcev 2013-05-19 00:20:07 MSD
I think no - this is similar package, but built in inmport, not private repo.
Comment 26 Postnikov Dmitry 2013-05-19 00:29:04 MSD
(In reply to comment #25)
> I think no - this is similar package, but built in inmport, not private repo.

You removed the patch about the display-manager? Can still check? Until weekend, and everyone is asleep in the fazenda, can test. :)
Comment 27 Aleksandr Kazantcev 2013-05-19 00:32:15 MSD
Latest packages are equal packages in comment 19.
Comment 28 Aleksandr Kazantcev 2013-05-19 10:54:08 MSD
I remove logind patch (0167) and clean all future-plane patches for it

https://abf.rosalinux.ru/import/systemd/commit/691973f48372c814e31d5f3b6fadc694a3a16e57
Comment 29 Postnikov Dmitry 2013-05-19 11:24:41 MSD
Go back to ConsoleKit instead Logind? I loginctl works fine. Relogin users goes well. Any devices are normally connected. 
Then we again check systemd need? Postpone tests video drivers?
Comment 30 Aleksandr Kazantcev 2013-05-19 11:36:37 MSD
No... We will use Logind - consolekit will be drop after unfreezy ABF repo and will be next step (on QA to, but some later).

I drop only backported from systemd > 194 patches. We need test it more carefully and not now.

If you test drivers from Comment 18 and they work OK, you don't need test drivers from Comment 23 - they identical.

Video drivers not related to systemd to.
Comment 31 Postnikov Dmitry 2013-05-19 11:40:14 MSD
OK i understood.
Comment 32 Vladimir Potapov 2013-05-19 14:35:45 MSD
https://abf.rosalinux.ru/build_lists/1098152
https://abf.rosalinux.ru/build_lists/1098153
***************** Advisory ***********************
New bugfix version released
******************** Changelog *******************
- add presets for accountservice, than thay not be deleted after upgrade
- add presets for kdm, gdm, xdm, lightdm, slim
- add logind patch to check users only in tty and x11 session, that prevent disabling poweroff/shutdowns with ftp, ssh and other sessions
**************************************************
QA Verified