Bug 2002 - [UPDATE REQUEST] KDE 4.9.5 -> 4.10.3
: [UPDATE REQUEST] KDE 4.9.5 -> 4.10.3
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-13 12:08 MSD by Andrey Bondrov
Modified: 2013-05-27 07:16 MSD (History)
7 users (show)

See Also:
RPM Package: various
ISO-related:
Bad POT generating:
Upstream:


Attachments
Lock (405.11 KB, image/jpeg)
2013-05-16 05:07 MSD, Vladimir Potapov
Details
create menu (99.69 KB, image/png)
2013-05-16 13:08 MSD, Vladimir Potapov
Details
"Create" menu in KDE 4.9.5 (1.21 MB, image/png)
2013-05-16 20:07 MSD, Andrey Bondrov
Details
incorrect border (76.30 KB, image/png)
2013-05-17 05:45 MSD, Vladimir Potapov
Details
Open device dialog with Arezzo theme (187.38 KB, image/png)
2013-05-17 16:14 MSD, Andrey Bondrov
Details
The icons place near border (42.67 KB, image/png)
2013-05-17 16:38 MSD, Vladimir Potapov
Details
Patched Device Notifier (634.25 KB, image/png)
2013-05-17 17:34 MSD, Andrey Bondrov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Bondrov 2013-05-13 12:08:21 MSD
Please test KDE 4.9.5 -> 4.10.3 update for regressions. Add this repository:
http://abf-downloads.rosalinux.ru/kde4_backports_personal/repository/rosa2012.1/

And update your system from it.

Note that only regressions are important. Common bugs that already were in 4.9.5 are not worth of mentioning. So you need to have both 4.9.5 and 4.10.3 installed to compare them.

Please write all found regressions in comments. One regression = one comment.

In fact, the update was already well-tested by many users. But extra testing won't hurt. We have about one week until we push KDE 4.10.3 to Main Updates.

ISOs with KDE 4.10.3 will be ready soon as well. So please test both update and clean install.
Comment 1 Vladimir Potapov 2013-05-15 12:07:52 MSD
Следующий пакет будет удалён для обновления остальных:
kphotoalbum-4.4-1-rosa2012.1.i586
 (из-за отсутствия libkipi.so.9)
Comment 2 Andrey Bondrov 2013-05-15 12:36:29 MSD
(In reply to comment #1)
> Следующий пакет будет удалён для обновления остальных:
> kphotoalbum-4.4-1-rosa2012.1.i586
>  (из-за отсутствия libkipi.so.9)

Thanx for reminding :-) kamoso and kphotoalbum will be rebuilt against new libkipi right after we push KDE 4.10 to updates.
Comment 3 Vladimir Potapov 2013-05-15 14:15:03 MSD
X64:
systemctl | grep failed

proc-fs-nfsd.mount        loaded failed failed 
kdm.service               loaded failed failed
Comment 4 Alexander Burmashev 2013-05-15 14:17:02 MSD
provide please systemctl status kdm.service, it should give more info.
Comment 5 Aleksandr Kazantcev 2013-05-15 14:21:54 MSD
kdm service failed because you did not use latest update from systemd (new update from ABF). This need for future migrations. If kdm run properly you not reason worry about.

nfs failed, because you did not setup nfs. For systemd service failed == broken.
Comment 6 Vladimir Potapov 2013-05-15 14:26:46 MSD
(In reply to comment #5)
> kdm service failed because you did not use latest update from systemd (new
> update from ABF). This need for future migrations. If kdm run properly you
> not reason worry about.
Hmm. 
urpmi systemd
systemd-194-17-rosa2012.1.x86_64 уже установлен

(In reply to comment #4)
> provide please systemctl status kdm.service, it should give more info.
kdm.service - K Display Manager
          Loaded: loaded (/lib/systemd/system/kdm.service; enabled)
          Active: failed (Result: start-limit) since Wed, 15 May 2013 19:04:06 +0900; 21min ago
         Process: 3289 ExecStart=/usr/bin/kdm -nodaemon (code=exited, status=1/FAILURE)
          CGroup: name=systemd:/system/kdm.service

May 15 19:04:06 Fresh64.rosa systemd[1]: Stopping K Display Manager...
May 15 19:04:06 Fresh64.rosa systemd[1]: Starting K Display Manager...
May 15 19:04:06 Fresh64.rosa systemd[1]: Failed to start K Display Manager.
Comment 7 Alexander Burmashev 2013-05-15 14:29:10 MSD
attach please /var/log/kdm.log
Comment 8 Aleksandr Kazantcev 2013-05-15 14:36:42 MSD
You has ALL update from ABF repo? Not systemd only - in systemd update only for logind and new pamd options.
Comment 9 Aleksandr Kazantcev 2013-05-15 14:37:59 MSD
If you has old sysvinit part in system, kdm.service failed, because kdm run via init script before service and this behavior is normal.
Comment 10 Vladimir Potapov 2013-05-15 17:05:24 MSD
Wow! After reboot the bug disappeared.
On i586 test platform it don't appear.
OK.
Comment 11 Vladimir Potapov 2013-05-15 18:47:37 MSD
The package route to extended testing
Comment 12 Postnikov Dmitry 2013-05-15 19:54:01 MSD
(In reply to comment #11)
> The package route to extended testing

Adopted in work
Comment 13 Postnikov Dmitry 2013-05-16 00:08:22 MSD
I install new system from ISO without update. I add repo urpmi -update kde10 http://abf-downloads.rosalinux.ru/kde4_backports_personal/repository/rosa2012.1/x86_64/main/release/
After urpmi --auto-update and see messages:

==========
[root@localhost pastordi]# urpmi --auto-update
источник «kde10» уже обновлён
Некоторые запрошенные пакеты не могут быть установлены:
amarok-2.7.0-3-rosa2012.1.x86_64 (из-за неудовлетворённости liblastfm.so.1()(64bit))
kdebase4-runtime-4.10.3-1-rosa2012.1.x86_64 (из-за неудовлетворённости libntrack-qt4.so.1()(64bit))
kdebase4-workspace-4.10.3-2-rosa2012.1.x86_64 (из-за неудовлетворённости libxcb-damage.so.0()(64bit))
lib64amaroklib1-2.7.0-3-rosa2012.1.x86_64 (из-за неудовлетворённости liblastfm.so.1()(64bit))
lib64gwenviewlib4-4.10.3-3-rosa2012.1.x86_64 (из-за неудовлетворённости lib64lcms2_2)
Продолжить установку? (Y/n)
==========

Is this a normal?

===========
[root@localhost pastordi]# rpm -qa | grep kde4
mandriva-kde4-config-common-2012-22-rosa2012.1.noarch
Default-kde4-config-2012-22-rosa2012.1.noarch
lib64akonadi-kde4-4.9.4-1-rosa2012.1.x86_64
python-kde4-4.9.4-1-rosa2012.1.x86_64
drakconf-kde4-2012.1-3-rosa2012.1.x86_64
lib64kde4-style-qtcurve-1.8.14-1-rosa2012.1.x86_64
kde4-windeco-dekorator-0.5.1-11-rosa2012.1.x86_64
kde4-audiocd-4.9.4-1-rosa2012.1.x86_64
kde4-nsplugins-4.9.4-1-rosa2012.1.x86_64
task-kde4-4.9.4-1-rosa2012.1.noarch
task-kde4-minimal-4.9.4-1-rosa2012.1.noarch
libreoffice-kde4-3.6.2-2-rosa2012.1.x86_64
kde4-filesharing-4.9.4-1-rosa2012.1.x86_64
kde4-style-qtcurve-1.8.14-1-rosa2012.1.x86_64
[root@localhost pastordi]#
============
Comment 14 Andrey Bondrov 2013-05-16 02:08:48 MSD
(In reply to comment #13)
> I install new system from ISO without update. I add repo urpmi -update kde10
> http://abf-downloads.rosalinux.ru/kde4_backports_personal/repository/
> rosa2012.1/x86_64/main/release/
> After urpmi --auto-update and see messages:
> 
> ==========
> [root@localhost pastordi]# urpmi --auto-update
> источник «kde10» уже обновлён
> Некоторые запрошенные пакеты не могут быть установлены:
> amarok-2.7.0-3-rosa2012.1.x86_64 (из-за неудовлетворённости
> liblastfm.so.1()(64bit))
> kdebase4-runtime-4.10.3-1-rosa2012.1.x86_64 (из-за неудовлетворённости
> libntrack-qt4.so.1()(64bit))
> kdebase4-workspace-4.10.3-2-rosa2012.1.x86_64 (из-за неудовлетворённости
> libxcb-damage.so.0()(64bit))
> lib64amaroklib1-2.7.0-3-rosa2012.1.x86_64 (из-за неудовлетворённости
> liblastfm.so.1()(64bit))
> lib64gwenviewlib4-4.10.3-3-rosa2012.1.x86_64 (из-за неудовлетворённости
> lib64lcms2_2)
> Продолжить установку? (Y/n)
> ==========
> 
> Is this a normal?

You really must have Main Updates repository enabled because KDE 4.10 will be there and it depends on some packages from Main Updates. It makes no sense to test update with Main and Main Updates repositories disabled.
Comment 15 Vladimir Potapov 2013-05-16 05:07:52 MSD
Created attachment 1359 [details]
Lock

The lock screen: there is no localization, strange design
Comment 16 Aleksandr Kazantcev 2013-05-16 06:04:45 MSD
Lockscreen is normal. Translate part related to Localize team, but i think we will not have man power for properly translate in needing time.
Comment 17 Vladimir Potapov 2013-05-16 08:12:12 MSD
(In reply to comment #16)
> Lockscreen is normal. Translate part related to Localize team, but i think
> we will not have man power for properly translate in needing time.

This is not a localized dialog users will see every morning. This is very bad.
Distributions Rosa has always been the most beautiful and well localized. It is important to keep this brand.
Comment 18 Andrey Bondrov 2013-05-16 10:40:02 MSD
(In reply to comment #17)
> (In reply to comment #16)
> > Lockscreen is normal. Translate part related to Localize team, but i think
> > we will not have man power for properly translate in needing time.
> 
> This is not a localized dialog users will see every morning. This is very
> bad.

I agree. I'll take a look today to fix this ASAP.
Comment 19 JDronova 2013-05-16 11:45:24 MSD
Plese file a bug in lokalization regarding this problem.
Comment 20 Vladimir Potapov 2013-05-16 12:01:38 MSD
(In reply to comment #19)
> Plese file a bug in lokalization regarding this problem.

http://bugs.rosalinux.ru/show_bug.cgi?id=2015
Comment 21 Vladimir Potapov 2013-05-16 13:08:04 MSD
Created attachment 1363 [details]
create menu

Create menu is old-style now?
Comment 22 Andrey Bondrov 2013-05-16 17:28:16 MSD
(In reply to comment #21)
> Created attachment 1363 [details]
> create menu
> 
> Create menu is old-style now?

Yes, it was requested by many users and some of them already wrote how happy they were with more entries added to "Create menu" in this update. And nobody was unhappy. So it's better to have it this way, I guess.
Comment 23 JDronova 2013-05-16 17:53:50 MSD
(In reply to comment #15)
> Created attachment 1359 [details]
> Lock
> 
> The lock screen: there is no localization, strange design

The lokalization issue seems to be fixed, see bug 2015.
Comment 24 Andrey Bondrov 2013-05-16 18:44:05 MSD
BTW, meanwhile Amarok is updated to 2.7.1 and Digikam to 3.2.0. Both in this KDE 4.10 testing repository.
Comment 25 JDronova 2013-05-16 18:50:29 MSD
Some .po files from the list at https://abf.rosalinux.ru/import/kde-l10n/tree/rosa2012.1  are not fully translated. These are:
kde-workspace/powerdevil.po (trunk)
kde-workspace/plasma_package_org.kde.desktop.activitymanager.po (stable&trunk)
See bug 2016

Adopted in work© now :))
Comment 26 Vladimir Potapov 2013-05-16 19:35:44 MSD
(In reply to comment #22)
> (In reply to comment #21)
> > Created attachment 1363 [details]
> > create menu
> > 
> > Create menu is old-style now?
> 
> Yes, it was requested by many users and some of them already wrote how happy
> they were with more entries added to "Create menu" in this update. And
> nobody was unhappy. So it's better to have it this way, I guess.
I did like office files in this menu...
Comment 27 Andrey Bondrov 2013-05-16 20:07:58 MSD
Created attachment 1365 [details]
"Create" menu in KDE 4.9.5
Comment 28 Andrey Bondrov 2013-05-16 20:09:30 MSD
(In reply to comment #26)
> (In reply to comment #22)
> > (In reply to comment #21)
> > > Created attachment 1363 [details]
> > > create menu
> > > 
> > > Create menu is old-style now?
> > 
> > Yes, it was requested by many users and some of them already wrote how happy
> > they were with more entries added to "Create menu" in this update. And
> > nobody was unhappy. So it's better to have it this way, I guess.
> I did like office files in this menu...

Sorry, I don't understand what you mean. In KDE 4.9.5 we had only "Text file" and "Folder" entries. See the screenshot I added: http://bugs.rosalinux.ru/attachment.cgi?id=1365

Nothing related to office files.
Comment 29 Andrey Bondrov 2013-05-16 20:28:11 MSD
(In reply to comment #15)
> Created attachment 1359 [details]
> Lock
> 
> The lock screen: there is no localization, strange design

Should be fixed in kde-l10n-ru-4.10.3-2. Please update and test.
Comment 30 Postnikov Dmitry 2013-05-17 01:34:53 MSD
(In reply to comment #12)
> (In reply to comment #11)
> > The package route to extended testing
> 
> Adopted in work

******************************
Extended testing report
******************************
http://cdn.2safe.com/578823033045/Postnikov-all(updKDE4.10.3).odt
Comment 31 Andrey Bondrov 2013-05-17 01:52:35 MSD
(In reply to comment #30)
> (In reply to comment #12)
> > (In reply to comment #11)
> > > The package route to extended testing
> > 
> > Adopted in work
> 
> ******************************
> Extended testing report
> ******************************
> http://cdn.2safe.com/578823033045/Postnikov-all(updKDE4.10.3).odt

Thanx. #7 & #9 seem to be serious bugs.
Comment 32 Vladimir Potapov 2013-05-17 03:56:26 MSD
(In reply to comment #29)
> (In reply to comment #15)
> > Created attachment 1359 [details]
> > Lock
> > 
> > The lock screen: there is no localization, strange design
> 
> Should be fixed in kde-l10n-ru-4.10.3-2. Please update and test.
Fixed!
Comment 33 Vladimir Potapov 2013-05-17 05:45:47 MSD
Created attachment 1366 [details]
incorrect border
Comment 34 Vladimir Potapov 2013-05-17 11:34:03 MSD
> > > Adopted in work
> > 
> > ******************************
> > Extended testing report
> > ******************************
> > http://cdn.2safe.com/578823033045/Postnikov-all(updKDE4.10.3).odt
> 
> Thanx. #7 & #9 seem to be serious bugs.
I confirm this errors. But the ksnapshot bug present only my i586 system and doubleclick in selected area work correct (keyboard don't work)
Comment 35 Vladimir Potapov 2013-05-17 12:01:44 MSD
> > Thanx. #7 & #9 seem to be serious bugs.
But SW search for "kde" is no regression - similar in lts.
Comment 36 Andrey Bondrov 2013-05-17 12:09:17 MSD
(In reply to comment #34)
> > > > Adopted in work
> > > 
> > > ******************************
> > > Extended testing report
> > > ******************************
> > > http://cdn.2safe.com/578823033045/Postnikov-all(updKDE4.10.3).odt
> > 
> > Thanx. #7 & #9 seem to be serious bugs.
> I confirm this errors. But the ksnapshot bug present only my i586 system and
> doubleclick in selected area work correct (keyboard don't work)

Unfortunately, it's not a ksnapshot bug. ksnapshot from KDE 4.9.5 cannot capture selected region with menu in KDE 4.10.3 too.

Even more, this bug doesn't seem to be KDE 4.10.3 specific but just triggered in i586 build of some KDE core package. See: https://bugs.kde.org/show_bug.cgi?id=210916

If you need some technical detail, RegionGrabber::keyPressEvent( QKeyEvent* e ) is not triggered by pressed keys when we have a menu popped up. Something seems to block event instead of ignoring it.

It's really unlikely I'll fix it soon :-/
Comment 37 Vladimir Potapov 2013-05-17 12:47:33 MSD
> It's really unlikely I'll fix it soon :-/
Andrey, the bug only one platform and only one case. It's not critical regression.
I think that the current state of KDE is acceptable. Restore the request.
Comment 38 Andrey Bondrov 2013-05-17 13:08:32 MSD
(In reply to comment #37)
> > It's really unlikely I'll fix it soon :-/
> Andrey, the bug only one platform and only one case. It's not critical
> regression.
> I think that the current state of KDE is acceptable. Restore the request.

BTW, I guess I found a workaround. I'll build patched package soon.
Comment 39 Vladimir Potapov 2013-05-17 13:16:33 MSD
KDE(In reply to comment #38)
> (In reply to comment #37)
> > > It's really unlikely I'll fix it soon :-/
> > Andrey, the bug only one platform and only one case. It's not critical
> > regression.
> > I think that the current state of KDE is acceptable. Restore the request.
> 
> BTW, I guess I found a workaround. I'll build patched package soon.
I think that after the update, we still can find some small bugs. We'll fix them for a week and RP1 is fully working version.
Comment 40 Vladimir Potapov 2013-05-17 13:19:41 MSD
KDE 4.10.3
http://abf-downloads.rosalinux.ru/kde4_backports_personal/repository/rosa2012.1/
********************* Advisory ********************
New version of KDE 4.10.3
***************************************************
QA Verified
Comment 41 Denis Koryavov 2013-05-17 14:08:55 MSD
Folks, it is not very good to approve updates with bug like this http://bugs.rosalinux.ru/show_bug.cgi?id=2024. For the future: can you please notify UXteam about such errors before you will give "a green light" for an update?
Comment 42 Andrey Bondrov 2013-05-17 14:11:58 MSD
Please update and test ksnapshot 4.10.3-3. The issue with keyboard grabbing should be fixed there.
Comment 43 Alexander Burmashev 2013-05-17 14:13:46 MSD
Since this update is really big before publishing it i will need confirmation from both QA team and Andrey Bondrov.
Comment 44 Vladimir Potapov 2013-05-17 14:58:10 MSD
(In reply to comment #42)
> Please update and test ksnapshot 4.10.3-3. The issue with keyboard grabbing
> should be fixed there.
The error fixed!
Comment 45 Andrey Bondrov 2013-05-17 16:14:21 MSD
Created attachment 1376 [details]
Open device dialog with Arezzo theme
Comment 46 Andrey Bondrov 2013-05-17 16:15:14 MSD
(In reply to comment #33)
> Created attachment 1366 [details]
> incorrect border

Seems to be specific for Rosa theme. 

With Arezzo everything looks fine: http://bugs.rosalinux.ru/attachment.cgi?id=1376
Comment 47 Vladimir Potapov 2013-05-17 16:20:56 MSD
(In reply to comment #46)
> (In reply to comment #33)
> > Created attachment 1366 [details]
> > incorrect border
> 
> Seems to be specific for Rosa theme. 
> 
> With Arezzo everything looks fine:
> http://bugs.rosalinux.ru/attachment.cgi?id=1376

See first item! Please, make screenshot with Arezzo for first item.
Comment 48 Vladimir Potapov 2013-05-17 16:38:21 MSD
Created attachment 1377 [details]
The icons place near border
Comment 49 JDronova 2013-05-17 17:13:44 MSD
(In reply to comment #48)
> Created attachment 1377 [details]
> The icons place near border

We do have fixed Marathon bug 578 with similar issue.
Comment 50 Andrey Bondrov 2013-05-17 17:29:38 MSD
(In reply to comment #48)
> Created attachment 1377 [details]
> The icons place near border

Seems to be theme-specific. Please file a bug for UX Team.
Comment 51 Andrey Bondrov 2013-05-17 17:34:17 MSD
Created attachment 1378 [details]
Patched Device Notifier

(In reply to comment #47)
> (In reply to comment #46)
> > (In reply to comment #33)
> > > Created attachment 1366 [details]
> > > incorrect border
> > 
> > Seems to be specific for Rosa theme. 
> > 
> > With Arezzo everything looks fine:
> > http://bugs.rosalinux.ru/attachment.cgi?id=1376
> 
> See first item! Please, make screenshot with Arezzo for first item.

Well, it was OK but not perfect. So I patched Device Notifier to center action labels in more reliable way. See attached screenshot and compare it to my previous one.

I'll let you know when kdebase4-workspace-4.10.3-3 is published so you could update and test (better after reboot to make sure the applet is reloaded).
Comment 52 Denis Koryavov 2013-05-17 18:06:18 MSD
> The icons place near border

This bug is fixed here [1], please check and approve.

[1] http://bugs.rosalinux.ru/show_bug.cgi?id=2026
Comment 53 Andrey Bondrov 2013-05-17 18:51:05 MSD
(In reply to comment #51)
> > See first item! Please, make screenshot with Arezzo for first item.
> 
> Well, it was OK but not perfect. So I patched Device Notifier to center
> action labels in more reliable way. See attached screenshot and compare it
> to my previous one.
> 
> I'll let you know when kdebase4-workspace-4.10.3-3 is published so you could
> update and test (better after reboot to make sure the applet is reloaded).

kdebase4-workspace-4.10.3-3 is published. Please update and test Device Notifier behaviour.
Comment 54 Vladimir Potapov 2013-05-18 05:09:59 MSD
(In reply to comment #52)
> > The icons place near border
> 
> This bug is fixed here [1], please check and approve.
> 
> [1] http://bugs.rosalinux.ru/show_bug.cgi?id=2026
I don't see any changes...
Comment 55 Vladimir Potapov 2013-05-18 05:30:21 MSD
urpm-reposync: (KDE pero on) 

>>>ERROR: Package kajongg has unsatisfied dependencies: [kdegames4-core]
>>>ERROR: Package kmahjongglib has unsatisfied dependencies: [kdegames4-core]
>>>ERROR: [kpat, kreversi] conflicts with kdegames4-core
>>>ERROR: [kpat, kreversi] conflicts with kdegames4-core
>>> Пожалуйста, отправьте разработчикам дистрибутива эту информацию.
Comment 56 Vladimir Potapov 2013-05-18 05:43:36 MSD
> > 
> > I'll let you know when kdebase4-workspace-4.10.3-3 is published so you could
> > update and test (better after reboot to make sure the applet is reloaded).
> 
> kdebase4-workspace-4.10.3-3 is published. Please update and test Device
> Notifier behaviour.
Ok, label now correct.
But since there were a lot of changes, it is necessary to re-testing update. Ask freeze the repository and make a new request for verification (for 10.3.3). I close this request 
*************
Denied
Comment 57 Andrey Bondrov 2013-05-18 05:53:13 MSD
(In reply to comment #55)
> urpm-reposync: (KDE pero on) 
> 
> >>>ERROR: Package kajongg has unsatisfied dependencies: [kdegames4-core]
> >>>ERROR: Package kmahjongglib has unsatisfied dependencies: [kdegames4-core]
> >>>ERROR: [kpat, kreversi] conflicts with kdegames4-core
> >>>ERROR: [kpat, kreversi] conflicts with kdegames4-core
> >>> Пожалуйста, отправьте разработчикам дистрибутива эту информацию.

Seems to be urpm-reposync issue, it tries to install old kajongg and kmahjongglib packages from Main. I'll let urpm-reposync developers know about this.
Comment 58 Vladimir Potapov 2013-05-18 05:58:00 MSD
(In reply to comment #57)
> (In reply to comment #55)
> > urpm-reposync: (KDE pero on) 
> > 
> > >>>ERROR: Package kajongg has unsatisfied dependencies: [kdegames4-core]
> > >>>ERROR: Package kmahjongglib has unsatisfied dependencies: [kdegames4-core]
> > >>>ERROR: [kpat, kreversi] conflicts with kdegames4-core
> > >>>ERROR: [kpat, kreversi] conflicts with kdegames4-core
> > >>> Пожалуйста, отправьте разработчикам дистрибутива эту информацию.
> 
> Seems to be urpm-reposync issue, it tries to install old kajongg and
> kmahjongglib packages from Main. I'll let urpm-reposync developers know
> about this.

ok. But, please, freeze the repo and create new QA query (new "bug" in bugzilla!).
Comment 59 Andrey Bondrov 2013-05-18 14:10:07 MSD
BTW, please test printing and printer configuration. Personally I don't have a printer so I cannot test it.
Comment 60 Vladimir Potapov 2013-05-18 15:40:02 MSD
I test printer, scanner and photocamera with KDE. It's work.
Comment 61 Vladimir Potapov 2013-05-18 15:44:31 MSD
O! I Found a big bug.
1) Wake up! (for lock screen)
2) Change the keyboard layout
Cursor hide. Tab key don't work. Without mouse click I can't enter the password :-(
Comment 62 Vladimir Potapov 2013-05-27 07:16:39 MSD
I close this query, KDE in repo.