Bug 1989 - [UPDATE REQUEST] clamav 0.97.7-2 -> 0.97.8-1
: [UPDATE REQUEST] clamav 0.97.7-2 -> 0.97.8-1
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-03 16:35 MSD by Giovanni Mariani
Modified: 2013-05-13 11:26 MSD (History)
2 users (show)

See Also:
RPM Package: clamav-0.97.7-1.src.rpm
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Giovanni Mariani 2013-05-03 16:35:14 MSD
New release 0.97.8:
- Removed "Mandriva" from README.urpmi
- Fixed some new rpmlint warnings (missing-lsb-keyword) by massaging S2, S4 and S6
Comment 1 Giovanni Mariani 2013-05-03 16:36:39 MSD
Advisory: Update clamav from 0.97.7-2 to 0.97.8-1.

https://abf.rosalinux.ru/build_lists/1077052
https://abf.rosalinux.ru/build_lists/1077053
Comment 2 Vladimir Potapov 2013-05-07 16:10:19 MSD
Freshclam don't start after install (like marathon version)...
Comment 3 Giovanni Mariani 2013-05-08 15:38:30 MSD
(In reply to comment #2)
> Freshclam don't start after install (like marathon version)...

Very odd...

This on our specfile should ensure the starting of freshclam deamon:
**********************
%post
%_post_service freshclam
%create_ghostfile %{_var}/log/%{name}/freshclam.log %{name} %{name} 0644
# (gvm) Force the signature db update, otherwise we ends up
# *without* virus signatures until the next reboot
if [ -x %{_initrddir}/freshclam ]; then
    %{_initrddir}/freshclam restart
fi
**********************


I also tried to verify it actually works by removing the clamav package and then reinstalling it; this is the resulting system log snippet from my system:
************************
08/05/2013 12:22:43	Rivendell	urpme	called with: clamav
08/05/2013 12:23:02	Rivendell	urpme	transaction on / (remove=5, install=0, upgrade=0)
08/05/2013 12:23:14	Rivendell	systemd[1]	Stopping LSB: An AntiVirus Server...
08/05/2013 12:23:15	Rivendell	clamd[4472]	Stopping Clam AntiVirus Daemon: [  OK  ]
08/05/2013 12:23:16	Rivendell	systemd[1]	Stopped LSB: An AntiVirus Server.
08/05/2013 12:23:16	Rivendell	systemd[1]	Reloading.
08/05/2013 12:23:16	Rivendell	systemd[1]	Reloading.
08/05/2013 12:23:16	Rivendell	systemd[1]	Reloading.
08/05/2013 12:23:28	Rivendell	systemd[1]	Stopping LSB: Clam AntiVirus Database Update Daemon....
08/05/2013 12:23:28	Rivendell	systemd[1]	freshclam.service: main process exited, code=exited, status=2
08/05/2013 12:23:28	Rivendell	freshclam[4535]	Stopping Clam AntiVirus Update Daemon: [  OK  ]
08/05/2013 12:23:28	Rivendell	systemd[1]	Stopped LSB: Clam AntiVirus Database Update Daemon..
08/05/2013 12:23:28	Rivendell	systemd[1]	Unit freshclam.service entered failed state.
08/05/2013 12:23:28	Rivendell	systemd[1]	Reloading.
08/05/2013 12:23:29	Rivendell	systemd[1]	Reloading.
08/05/2013 12:23:29	Rivendell	systemd[1]	Reloading.
08/05/2013 12:26:09	Rivendell	urpmi	called with: clamd
08/05/2013 12:26:41	Rivendell	urpmi	transaction on / (remove=0, install=0, upgrade=3)
08/05/2013 12:26:46	Rivendell	systemd[1]	Reloading.
08/05/2013 12:26:46	Rivendell	systemd[1]	Reloading.
08/05/2013 12:26:46	Rivendell	systemd[1]	Starting LSB: Clam AntiVirus Database Update Daemon....
08/05/2013 12:26:46	Rivendell	freshclam[4753]	Starting Clam AntiVirus Update Daemon: [  OK  ]
08/05/2013 12:26:46	Rivendell	systemd[1]	Started LSB: Clam AntiVirus Database Update Daemon..
08/05/2013 12:26:47	Rivendell	systemd[1]	Reloading.
08/05/2013 12:26:47	Rivendell	systemd[1]	Reloading.
08/05/2013 12:26:48	Rivendell	systemd[1]	Starting LSB: An AntiVirus Server...
08/05/2013 12:27:02	Rivendell	clamd[4829]	Starting Clam AntiVirus Daemon: [  OK  ]
08/05/2013 12:27:02	Rivendell	systemd[1]	Started LSB: An AntiVirus Server.
************************
It shows that (at least here) freshclam has indeed started right after the clamav re-installation.
Perhaps freshclam somehow started but it failed to update the db signatures?
Comment 4 Vladimir Potapov 2013-05-08 17:24:23 MSD
I can't reproduce this bug, now all ok...
P.S. Rivendell? JRRT? I'm fan :-)
Comment 5 Vladimir Potapov 2013-05-08 17:26:13 MSD
clamav-0.97.8-1-rosa2012.1
*********************** Advisory *****************
New release 0.97.8:
- Removed "Mandriva" from README.urpmi
**************************************************
QA Verified
Comment 6 Giovanni Mariani 2013-05-08 22:11:34 MSD
(In reply to comment #4)
> I can't reproduce this bug, now all ok...
> P.S. Rivendell? JRRT? I'm fan :-)

Me too :-)