Bug 198 - Intel driver does not work with the 82945G/GZ Integrated Graphics Controller
: Intel driver does not work with the 82945G/GZ Integrated Graphics Controller
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: unspecified
: All Linux
: High major
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-06 16:06 MSD by Denis Koryavov
Modified: 2015-09-03 21:00 MSD (History)
5 users (show)

See Also:
RPM Package: x11-driver-video-intel-2.16.0-1-rosa.lts2012.0.i586
ISO-related:
Bad POT generating:
Upstream:


Attachments
Xorg.0.log (6.67 KB, text/plain)
2012-05-06 16:06 MSD, Denis Koryavov
Details
xorg.conf (5.57 KB, text/plain)
2012-05-06 16:06 MSD, Denis Koryavov
Details
configuration (1.98 KB, text/plain)
2012-05-06 16:08 MSD, Denis Koryavov
Details
The output of command "X -configure :1". (1.97 KB, text/plain)
2012-05-06 19:08 MSD, Denis Koryavov
Details
Xorg.1.log (16.77 KB, text/plain)
2012-05-06 19:11 MSD, Denis Koryavov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Denis Koryavov 2012-05-06 16:06:09 MSD
Created attachment 122 [details]
Xorg.0.log

Description of problem:

I tried to install RM2012 to my machine with the Intel graphics controller:

lspcidrake -v | grep Card
Card:Intel 810 and later: Intel Corporation|82945G/GZ Integrated Graphics Controller [DISPLAY_VGA] (vendor:8086 device:2772 subv:105b subd:0d4d) (rev: 02)

and found, that our Intel driver does not work with this video card.

Version-Release number of selected component (if applicable):


How reproducible:
Always

For more details, see the attached Xorg.0.log and xorg.conf.
Comment 1 Denis Koryavov 2012-05-06 16:06:59 MSD
Created attachment 123 [details]
xorg.conf
Comment 2 Denis Koryavov 2012-05-06 16:08:29 MSD
Created attachment 124 [details]
configuration
Comment 3 Postnikov Dmitry 2012-05-06 16:38:59 MSD
Try to change the kernel parameter:
-----------
[    51.043] Kernel command line: BOOT_IMAGE=linux root=UUID=4618c0d2-3ba9-4648-a590-54db2cd6a151 logo.nologo quiet resume=UUID=6dec202d-4e09-4778-b4cf-894654a9ef78 splash=silent vga=788 nokmsboot
-----------
Without "nokmsboot".
Comment 4 Denis Koryavov 2012-05-06 17:42:43 MSD
Hello Dmitry, 

It doesn't help to me. I still can't use Intel driver in my system.
Comment 5 Denis Koryavov 2012-05-06 17:44:01 MSD
BTW, nokmsboot is not in parameters list by default. I tried both variants.
Comment 6 Aleksandr Kazantcev 2012-05-06 17:59:12 MSD
Remove in kernel line ALL after resume=UIDxxxx (include vga, splash=silent and nokmsboot) and add only

 quiet splash
Comment 7 Denis Koryavov 2012-05-06 18:39:20 MSD
I can't understand how it can help me. Anyway, I tried this variant - it not helped to me.
Comment 8 Denis Koryavov 2012-05-06 19:08:54 MSD
Created attachment 125 [details]
The output of command "X -configure :1".

The output of command "X -configure :1".
Comment 9 Denis Koryavov 2012-05-06 19:11:31 MSD
Created attachment 126 [details]
Xorg.1.log
Comment 10 Postnikov Dmitry 2012-05-06 19:48:10 MSD
Try with kernel parameters:
-----------
BOOT_IMAGE=linux root=UUID=4618c0d2-3ba9-4648-a590-54db2cd6a151 logo.nologo quiet nosplash i915.modeset=1 vga=788
-----------
or

-----------
BOOT_IMAGE=linux root=UUID=4618c0d2-3ba9-4648-a590-54db2cd6a151 logo.nologo quiet nosplash i915.modeset=0 vga=788
-----------

Please, a sequence save option.
Comment 11 Denis Koryavov 2012-05-06 19:55:15 MSD
Hmm. It is a common problem for all distributions. See here: https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/805700

and here we can find a workaround for problem (see comment #12): "the grub option "pci=noacpi" allows to boot using intel driver"

I've tested this variant and can confirm - it works! But, as far as I can understood, the solution for problem did not found in no one distro.
Comment 12 Aleksandr Kazantcev 2012-05-06 19:56:34 MSD
It's need be add to ERRATA page.
Comment 13 Denis Koryavov 2012-05-09 14:44:31 MSD
OK, we found a workaround, so I lowered the severity of this bug.
Comment 14 Denis Koryavov 2012-08-20 17:26:32 MSD
Why this bug was closed as WONTFIX?
Comment 15 Aleksandr Kazantcev 2012-08-20 17:38:18 MSD
Becouse it's not a bug, but feature of Intel driver in some machines.

Kernel options not been impliment in automate mode, may be with new hardware detection system, but not now.
Comment 16 Denis Koryavov 2012-08-20 17:43:27 MSD
Hmm. So, if video card on my machine is not works it is not a bug? It is really nice to listen.
Comment 18 Pavel Shved 2012-08-20 17:52:40 MSD
We've already had this discussion AFAIK.

1. This is one of the bugs that can't be solved without asking user to detect if the driver doesn't work, and apply a workaround.
2. All we can do is to create "Problem Center" like Apple or Microsoft does, and ask the user to press a button "Fix my Intel Driver, please," if it doesn't work.
Comment 19 Denis Koryavov 2012-08-20 17:56:46 MSD
Pavel, take a look at the link on Ubuntu bugzilla that I gave. The status of this bug "Fix Committed". I'm understood correctly: Ubuntu folks can fix this bug, but we can not?
Comment 20 Denis Silakov 2015-09-03 21:00:18 MSD
According to our hardware database (http://hw.rosalinux.ru/index.php?search=82945G) our modern distributions doesn't have problems with this videocard.