Bug 1978 - Monodevelop crash when i make a new project
: Monodevelop crash when i make a new project
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Contributed Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-30 09:50 MSD by lopeztobal
Modified: 2015-01-16 14:30 MSK (History)
3 users (show)

See Also:
RPM Package: monodevelop-3.0.3.5-1.src.rpm
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lopeztobal 2013-04-30 09:50:05 MSD
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
When i want open an own project appears an error message window telling me:

El archivo '/home/tobal/ProgramasCSharp/Proyecto1/Proyecto1/Main.cs' no pudo ser abierto. Key '/desktop/gnome/interface/monospacefontname' not found in GConf



GConf.NoSuchKeyException: Key '/desktop/gnome/interface/monospace_font_name' not found in GConf
  at GConf.Client.Get (System.String key) [0x00000] in <filename unknown>:0 
  at MonoDevelop.Platform.GnomePlatform.get_DefaultMonospaceFont () [0x00000] in /home/build/rpmbuild/BUILD/monodevelop-3.0.3.5/src/addins/GnomePlatform/GnomePlatform.cs:138 
  at MonoDevelop.Ide.DesktopService.get_DefaultMonospaceFont () [0x00000] in /home/build/rpmbuild/BUILD/monodevelop-3.0.3.5/src/core/MonoDevelop.Ide/MonoDevelop.Ide/DesktopService.cs:74 
  at MonoDevelop.Ide.Fonts.FontService.FilterFontName (System.String name) [0x00010] in /home/build/rpmbuild/BUILD/monodevelop-3.0.3.5/src/core/MonoDevelop.Ide/MonoDevelop.Ide.Fonts/FontService.cs:75 
  at MonoDevelop.SourceEditor.DefaultSourceEditorOptions.get_FontName () [0x00000] in /home/build/rpmbuild/BUILD/monodevelop-3.0.3.5/src/addins/MonoDevelop.SourceEditor2/MonoDevelop.SourceEditor/SourceEditorOptions.cs:648 
  at Mono.TextEditor.TextEditorOptions.get_Font () [0x00022] in /home/build/rpmbuild/BUILD/monodevelop-3.0.3.5/src/core/Mono.Texteditor/Mono.TextEditor/TextEditorOptions.cs:426 
  at MonoDevelop.SourceEditor.StyledSourceEditorOptions.get_Font () [0x00000] in /home/build/rpmbuild/BUILD/monodevelop-3.0.3.5/src/addins/MonoDevelop.SourceEditor2/MonoDevelop.SourceEditor/StyledSourceEditorOptions.cs:182 
  at Mono.TextEditor.TextViewMargin.CreateLinePartLayout (ISyntaxMode mode, Mono.TextEditor.DocumentLine line, Int32 logicalRulerColumn, Int32 offset, Int32 length, Int32 selectionStart, Int32 selectionEnd) [0x000e8] in /home/build/rpmbuild/BUILD/monodevelop-3.0.3.5/src/core/Mono.Texteditor/Mono.TextEditor/Gui/TextViewMargin.cs:859 
  at Mono.TextEditor.TextViewMargin.CreateLinePartLayout (ISyntaxMode mode, Mono.TextEditor.DocumentLine line, Int32 offset, Int32 length, Int32 selectionStart, Int32 selectionEnd) [0x00000] in /home/build/rpmbuild/BUILD/monodevelop-3.0.3.5/src/core/Mono.Texteditor/Mono.TextEditor/Gui/TextViewMargin.cs:1202 
  at Mono.TextEditor.TextViewMargin.GetLayout (Mono.TextEditor.DocumentLine line) [0x00043] in /home/build/rpmbuild/BUILD/monodevelop-3.0.3.5/src/core/Mono.Texteditor/Mono.TextEditor/Gui/TextViewMargin.cs:1325 
  at Mono.TextEditor.TextEditor.OnTextSet (System.Object sender, System.EventArgs e) [0x00066] in /home/build/rpmbuild/BUILD/monodevelop-3.0.3.5/src/core/Mono.Texteditor/Mono.TextEditor/Gui/TextEditor.cs:2691 
  at (wrapper delegate-invoke) <Module>:invoke_void__this___object_EventArgs (object,System.EventArgs)
  at (wrapper delegate-invoke) <Module>:invoke_void__this___object_EventArgs (object,System.EventArgs)
  at (wrapper delegate-invoke) <Module>:invoke_void__this___object_EventArgs (object,System.EventArgs)
  at Mono.TextEditor.TextDocument.OnTextSet (System.EventArgs e) [0x0000d] in /home/build/rpmbuild/BUILD/monodevelop-3.0.3.5/src/core/Mono.Texteditor/Mono.TextEditor/Document/TextDocument.cs:403 
  at Mono.TextEditor.TextDocument.set_Text (System.String value) [0x00045] in /home/build/rpmbuild/BUILD/monodevelop-3.0.3.5/src/core/Mono.Texteditor/Mono.TextEditor/Document/TextDocument.cs:175 
  at MonoDevelop.SourceEditor.SourceEditorView.Load (System.String fileName, System.Text.Encoding loadEncoding) [0x000a1] in /home/build/rpmbuild/BUILD/monodevelop-3.0.3.5/src/addins/MonoDevelop.SourceEditor2/MonoDevelop.SourceEditor/SourceEditorView.cs:567 
  at MonoDevelop.SourceEditor.SourceEditorView.Load (System.String fileName) [0x00000] in /home/build/rpmbuild/BUILD/monodevelop-3.0.3.5/src/addins/MonoDevelop.SourceEditor2/MonoDevelop.SourceEditor/SourceEditorView.cs:496 
  at MonoDevelop.Ide.Gui.LoadFileWrapper.Invoke (System.String fileName) [0x000f8] in /home/build/rpmbuild/BUILD/monodevelop-3.0.3.5/src/core/MonoDevelop.Ide/MonoDevelop.Ide.Gui/Workbench.cs:1126 


Using kde.

Steps to Reproduce:
1.
2.
3.
Comment 1 Denis Silakov 2013-04-30 11:19:50 MSD
Yes, monodevelop is not in a good shape. It is in contrib repo, so fixing it is not the highest priority...
Comment 2 lopeztobal 2013-04-30 12:37:52 MSD
Uuuummm this is a bad image about the project. So, if a Rosa user wants to develope with C# is useless do it with ROSA because this package is not a priority? Is this the only answer about fix the bug? In the changelog not appear the packager, the package has been ported from Mageia and nothing else. Good.
I want learn C# but i only have 2 alternatives:

1. Use another linux distro
2. Use an ilegal copy of windows 7 or 8, because I can't install Monodevelop in my legal windows vista.

Bad News.
Anyway, thanks for the answer, I know Rosa bugzilla doesn't want fix the bugs.
Comment 3 Denis Silakov 2013-04-30 12:45:58 MSD
(In reply to comment #2)

> Anyway, thanks for the answer, I know Rosa bugzilla doesn't want fix the
> bugs.

This is conclusion is completely wrong:)

As for general C#/.NET question - you are right, these languages and frameworks are not encouraged in ROSA (and btw, in many other distributions). Do you know many good Linux applications written in C#? Though this is a question for dispute in mailing list or forum, not in bugzilla.

Also remember that Mono doesn't provide full implementation of .NET features, there is always a lag if compared to M$ implementations.
Comment 4 lopeztobal 2013-05-02 11:28:49 MSD
This program works good in the last Ubuntu, so the problem  must be fixed by the packager.
Oh, if Rosa doesn't want fix bugs from backports, then, why does Rosa let report bugs in Bugzilla Rosa?
Comment 5 Aleksandr Kazantcev 2013-05-02 11:33:29 MSD
Common reason - may be someone will want fix package... May you attach project, that broke monodevelop (or get a link)? This will be useful for fix and test.
Comment 6 FirstLevel 2014-10-08 14:48:59 MSD
Please check the problem for new release
http://mirror.rosalab.ru/rosa/rosa2014.1/iso/ROSA.Fresh.R4/
Comment 7 Denis Silakov 2014-10-14 17:21:51 MSD
The issue is valid.
Comment 8 Denis Silakov 2015-01-16 14:30:14 MSK
finally fixed with recent update of the mono stack and monodevelop itself