Bug 1960 - inkscape crashes on file open
: inkscape crashes on file open
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-24 07:19 MSD by MikhailZ
Modified: 2013-08-19 16:22 MSD (History)
4 users (show)

See Also:
RPM Package: inkscape-0.48.3.1-4-rosa2012.1.i586
ISO-related:
Bad POT generating:
Upstream:


Attachments
A screenshot (189.07 KB, image/png)
2013-04-25 08:25 MSD, Denis Koryavov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description MikhailZ 2013-04-24 07:19:15 MSD
Description of problem:

inkscape crashes (or hangup) on file open

How reproducible:
always. Opening files from filemanager works normal.

Steps to Reproduce:
1. Launch inkscape
2. Press "open file" icon 
   or choose from menu File-Open

mike@M3-desk ~ $ inkscape

Emergency save activated!
Emergency save completed. Inkscape will close now.
If you can reproduce this crash, please file a bug at www.inkscape.org
with a detailed description of the steps leading to the crash, so we can fix it.
Ошибка сегментирования (слепок снят)
mike@M3-desk ~ $ inkscape
mike@M3-desk ~ $ LC_ALL=C inkscape

Emergency save activated!
Emergency save completed. Inkscape will close now.
If you can reproduce this crash, please file a bug at www.inkscape.org
with a detailed description of the steps leading to the crash, so we can fix it.
Убито
Comment 1 Denis Koryavov 2013-04-24 07:58:56 MSD
I can't reproduce this bug. What icon set are you using?
Comment 2 Aleksandr Kazantcev 2013-04-24 08:47:59 MSD
Is you system is updated?
Comment 3 MikhailZ 2013-04-24 19:39:31 MSD
>I can't reproduce this bug. What icon set are you using?
Thank you for advice!
I reinstalled rosa-icons package and bug are now fixed.
Comment 4 MikhailZ 2013-04-24 20:28:57 MSD
>I reinstalled rosa-icons package and bug are now fixed.
No, It fails again :-(

M3-desk / # rpm -qa | grep icon | sort
drakconf-icons-12.19.2-4-rosa2012.1.noarch
elementary-icons-2.7.1-4-rosa2012.1.noarch
fusion-icon-0.1-0.20100215.5-rosa2012.1.noarch
gnome-icon-theme-3.6.0-1-rosa2012.1.noarch
gnome-icon-theme-symbolic-3.6.2-1-rosa2012.1.noarch
hicolor-icon-theme-0.12-8-rosa2012.1.noarch
libkemoticons4-4.9.5-1-rosa2012.1.i586
lxde-icon-theme-0.0.1-3-rosa2012.1.noarch
mandriva-kde-icons-1.0.4-14-rosa2012.1.noarch
mate-icon-theme-1.4.0-1-rosa2012.1.noarch
oxygen-icon-theme-4.9.4-1-rosa2012.1.noarch
rosa-icons-1.0.42-1-rosa2012.1.noarch


Для удовлетворения зависимостей будут установлены следующие пакеты:
(только проверка, без установки)
 Пакет                          Версия       Релиз         Dist  DEpoch Платформа 
(источник «main-updates»)
 gurpmi                         6.71         9             rosa  2012.1 noarch 
 knetworkmanager                0.9.0.7      2             rosa  2012.1 i586 
 knetworkmanager-common         0.9.0.7      2             rosa  2012.1 i586 
 knetworkmanager-openvpn        0.9.0.7      2             rosa  2012.1 i586 
 knetworkmanager-pptp           0.9.0.7      2             rosa  2012.1 i586 
 knetworkmanager-vpnc           0.9.0.7      2             rosa  2012.1 i586 
 libgsnmp0                      0.3.0        7             rosa  2012.1 i586 
 libknm_nm                      0.9.0.7      2             rosa  2012.1 i586 
 libknmclient4                  0.9.0.7      2             rosa  2012.1 i586 
 libknminternals4               0.9.0.7      2             rosa  2012.1 i586 
 libknmservice4                 0.9.0.7      2             rosa  2012.1 i586 
 libknmui4                      0.9.0.7      2             rosa  2012.1 i586 
 libnm-glib-vpn1                0.9.8.0      1             rosa  2012.1 i586 
 libnm-glib4                    0.9.8.0      1             rosa  2012.1 i586 
 libnm-gtk0                     0.9.8.0      1             rosa  2012.1 i586 
 libnm-util2                    0.9.8.0      1             rosa  2012.1 i586 
 libsolidcontrolfuture4         0.9.0.7      2             rosa  2012.1 i586 
 libsolidcontrolnm4             0.9.0.7      2             rosa  2012.1 i586 
 libsolidcontrolnmifaces4       0.9.0.7      2             rosa  2012.1 i586 
 mozilla-thunderbird-lightning  17.0.5       1             rosa  2012.1 i586 
 networkmanager                 0.9.8.0      1             rosa  2012.1 i586 
 networkmanager-applet          0.9.8.0      1             rosa  2012.1 i586 
 networkmanager-openconnect     0.9.8.0      1             rosa  2012.1 i586 
 networkmanager-openvpn         0.9.8.0      1             rosa  2012.1 i586 
 networkmanager-pptp            0.9.8.0      2             rosa  2012.1 i586 
 networkmanager-vpnc            0.9.8.0      1             rosa  2012.1 i586 
 ozerocdoff                     0.4          2             rosa  2012.1 i586 
 perl-URPM                      4.43         8             rosa  2012.1 i586 
 plasma-applet-networkmanageme> 0.9.0.7      2             rosa  2012.1 i586 
 rpmdrake                       5.26.12      15            rosa  2012.1 noarch 
 rpmlint                        1.4          28            rosa  2012.1 noarch 
 urpmi                          6.71         9             rosa  2012.1 noarch 
(источник «contrib-updates»)
 macchanger                     1.5.0        7             rosa  2012.1 i586 
(источник «restricted-release»)
 xscreensaver                   5.15         2plf          plf   2012.1 i586 
 xscreensaver-common            5.15         2plf          plf   2012.1 i586 
(источник «main-release»)
 busybox                        1.20.2       2             rosa  2012.1 i586 
 busybox-static                 1.20.2       2             rosa  2012.1 i586 
 nscd                           2.15         8             rosa  2012.1 i586 (рекомендуется)
 ppp-pppoe                      2.4.5        10            rosa  2012.1 i586 
Будет освобождено 3.1МБ дискового пространства.
Будет загружено 12МБ пакетов.
Comment 5 Denis Koryavov 2013-04-24 22:16:23 MSD
I can't reproduce this bug.
Comment 6 MikhailZ 2013-04-25 07:00:46 MSD
>I can't reproduce this bug.

Steps to Reproduce:
1. Launch Rosa Fresh Gnome in Live mode
2. urpmi.update -a
3. urpmi inkscape
4. start inkscape
5. press File-Open
6. You'l see that.
Comment 7 MikhailZ 2013-04-25 07:10:32 MSD
When updating rosa-icons packeage there are nothing changing.

But when I done 'rpm -e --nodeps rosa-icons' bug disappeared !!!

So, this icon related bug. The newest versions both inkscape and rosa-icons are affected !
Comment 8 Denis Koryavov 2013-04-25 08:25:39 MSD
Created attachment 1324 [details]
A screenshot

rpm -qa rosa-icons
rosa-icons-1.0.42-1-rosa2012.1.noarch

And inkscape works fine for me (see screenshot). 

So, I can't confirm this bug and it will be INCONFIRMED. Please, do not change this state untill somebody other will confirm this bug.
Comment 9 MikhailZ 2013-04-25 20:00:25 MSD
>So, I can't confirm this bug and it will be INCONFIRMED. Please, do not change this state untill somebody other will confirm this bug.
OK, I'll never touch this button. I'm sorry.

>Created attachment 1324 [details]
>A screenshot

I see you are using nonstandart GTK theme.
Can you test this http://mirror.rosalab.ru/unofficial/ROSA.Desktop.Fresh.2012.GNOME/ROSA.Desktop.Fresh.2012.GNOME.i586.iso ?

and do this steps to reproduce bug:
1. Launch Rosa Fresh Gnome in Live mode
2. urpmi.update -a
3. urpmi inkscape
whithout default theme changing?
Comment 10 MikhailZ 2013-04-25 21:20:41 MSD
I find icons which breaks my inkscape
there are 
/usr/share/icons/rosa/devices/48/gnome-dev-media-ms.svg
/usr/share/icons/rosa/devices/24/gnome-dev-media-ms.svg

This icons are using for usb pen & hdd. That is why you can't reproduce a bug. Just plug usb flash into your computer!

Then I made some modification. inkscape -f oldfile -l newfile 
and replace both bugged files. 
My inkscape are now working! It allow me to open and save file!

I'm not sure, how many broken icons contains rosa-icons
I'm not using such device as floppy, cd, dvd ,phone, etc.
So we can't solve that bug without checking any files from rosa-icons!

Have you any ideas?
Comment 11 Denis Koryavov 2013-04-25 21:34:57 MSD
The root of the problem in the rsvg that in the new version works very instable with rosa-icon theme (all our icons in SVG). So, some time ago we added a workaround [1] for this bug and I do not see problems on all my machines. 

Well, I will try to reproduce this bug again. 

[1] https://abf.rosalinux.ru/import/rosa-icons/commit/8611c67e9bdeb724ffe2db491b78639b0d479cc4
Comment 12 MikhailZ 2013-04-25 21:58:07 MSD
My plugged phone (MTP/flash) does not breaks inkscape.
I can try to check CD/DVD and floppy tomorrow.
I'll report results.
Comment 13 MikhailZ 2013-04-26 10:02:19 MSD
>I can try to check CD/DVD and floppy tomorrow.
I tried that devices. All is ok.

Only 2 icons are buged:
/usr/share/icons/rosa/devices/48/gnome-dev-media-ms.svg
/usr/share/icons/rosa/devices/24/gnome-dev-media-ms.svg
Comment 14 Vladimir Potapov 2013-04-30 18:16:19 MSD
I confirm the bug. Fresh 64 KDE.
Comment 15 Denis Koryavov 2013-05-06 12:00:14 MSD
OK, good. How to reproduce it?
Comment 16 Vladimir Potapov 2013-05-06 12:22:05 MSD
(In reply to comment #15)
> OK, good. How to reproduce it?


Steps to Reproduce:
1. Launch inkscape
2. Press "open file" icon 
   or choose from menu File-Open

The bug appear on x64 and i586 version on rosa fresh kde
Comment 17 Denis Koryavov 2013-05-06 12:58:49 MSD
As I said in #8, I can't reproduce this bug, neither on KDE nor on GNOME.
Comment 18 Vladimir Potapov 2013-05-06 13:03:00 MSD
On my test system, KDE and GNOME installed at the same time (using a task-gnome). Perhaps the reason for this?
Comment 19 Denis Koryavov 2013-05-06 17:30:26 MSD
I doubt it. I think the root of the problem somewhere in your 'File/Open' dialog configuration. Some settings for 'File/Open' dialog in your system are different with the settings for this dialog in the my systems, so I can't reproduce this bug.
Comment 20 Vladimir Potapov 2013-05-06 17:55:29 MSD
I work with default settings.
Comment 21 MikhailZ 2013-05-08 07:48:39 MSD
>so I can't reproduce this bug.
Do you plug in USB device (HDD,flash)?
Bug only appears when using icon for USB device.
Comment 22 Vladimir Potapov 2013-05-08 09:27:33 MSD
(In reply to comment #21)
> >so I can't reproduce this bug.
> Do you plug in USB device (HDD,flash)?
> Bug only appears when using icon for USB device.
O! I confirm this!
Comment 23 Denis Koryavov 2013-05-08 10:36:53 MSD
Yes, I tried to plug in usb flash, DVD. I will try to plug in usb hdd.
Comment 24 MikhailZ 2013-05-08 11:44:34 MSD
I dont know why your installation is not affected...

Are you using default theme? 
Can you test this on the another machines ?
This http://mirror.rosalab.ru/rosa2012.1/iso/ROSA.Desktop.Fresh/ROSA.Desktop.Fresh.2012.i586.iso and this http://mirror.rosalab.ru/unofficial/ROSA.Desktop.Fresh.2012.GNOME/ROSA.Desktop.Fresh.2012.GNOME.i586.iso are affected.
Can you test it in Virtualbox?
Comment 25 Denis Koryavov 2013-05-08 12:42:20 MSD
I tried to fix this bug "in the blind". Try this package. It helps? 

http://cdn.2safe.com/491171033558/rosa-icons-1.0.42-2-rosa2012.1.noarch.rpm
Comment 26 MikhailZ 2013-05-08 14:27:35 MSD
>It helps? 
No. But in this packages was changed many of links to icons...
When I delete 2 files
/usr/share/icons/rosa/devices/24/gnome-dev-removable.svg
/usr/share/icons/rosa/devices/48/gnome-dev-removable.svg
it starts work.

Please patch also these files.
Comment 27 Denis Koryavov 2013-05-08 14:46:07 MSD
Are you sure that 48x48 icons should be converted too? I don't see where they used in the file/open dialog.
Comment 28 Denis Koryavov 2013-05-08 15:01:39 MSD
Try this package [1]. I converted all icons in the folder "/usr/share/icons/rosa/devices/24/" there. 

[1] http://cdn.2safe.com/560725033046/rosa-icons-1.0.42-3-rosa2012.1.noarch.rpm
Comment 29 MikhailZ 2013-05-08 16:36:56 MSD
>Are you sure that 48x48 icons should be converted too? I don't see where they used in the file/open dialog.
Maybe. But in case I delete 24/gnome-dev-removable.svg icon, 48/gnome-dev-removable.svg break inkscape too.

>Try this package [1]
Yes. It fixes a bug! Thank you.
Comment 30 Denis Silakov 2013-08-19 16:22:06 MSD
We already have rosa-icons-1.0.44, hopefully the issue has been gone.

But feel free to reopen the bug if you still can reproduce it.