Bug 1951 - [UPDATE REQUEST] fglrx-9.012-2
: [UPDATE REQUEST] fglrx-9.012-2
Status: RESOLVED INVALID
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal critical
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-22 16:50 MSD by Aleksandr Kazantcev
Modified: 2013-05-02 11:47 MSD (History)
3 users (show)

See Also:
RPM Package: fglrx-9.012-2.src.rpm
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified-


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aleksandr Kazantcev 2013-04-22 16:50:26 MSD
Fix build with kernel 3.8.x
Comment 1 Aleksandr Kazantcev 2013-04-22 16:51:41 MSD
https://abf.rosalinux.ru/build_lists/1054568
https://abf.rosalinux.ru/build_lists/1054567

Advisory: This update fix build on Kernel 3.7 and 3.8 series
Comment 2 Vladimir Potapov 2013-04-23 21:19:58 MSD
I can't create containers :-(
Comment 3 Denis Silakov 2013-04-23 22:26:09 MSD
Containers created.
Comment 4 Vladimir Potapov 2013-04-24 13:20:22 MSD
*************************
Creating symlink /var/lib/dkms/fglrx/9.012-2/source ->
                 /usr/src/fglrx-9.012-2

DKMS: add Completed.

Error! Your kernel source for kernel 3.8.5-nrj-desktop-1rosa cannot be found at
/lib/modules/3.8.5-nrj-desktop-1rosa/build or /lib/modules/3.8.5-nrj-desktop-1rosa/source.
You can use the --kernelsourcedir option to tell DKMS where it's located.
      2/3: x11-driver-video-fglrx
                                 #############################################################################################################################################
      3/3: fglrx-control-center  #############################################################################################################################################

------------------------------
Deleting module version: 9.012-1
completely from the DKMS tree.
------------------------------
Done.
*********************
Please add kernel-desktop-driverl-latest to requirements for dkms-fglrx
Comment 5 Alexander Burmashev 2013-04-24 13:27:42 MSD
Imho not to dkms-fglrx, but to dkms itself. ALl dkms modules, not only fglrx require kernel-devel
Comment 6 Alexander Burmashev 2013-04-24 13:53:15 MSD
We discussed this issue in IRC and came to such conclusion:
1) Strict require on devel package can't be used.
Because it can't require a devel for particular kernel, and presence of any devel is not enough.

2) We can't make kernel require devel ( since devel is not really required  for kernel )


3) Out of the box all installations have devel-latest packages. It's absence indicated something went wrong.

4) All proprietary drivers are ment to be installed through XFdrake only! And XFdrake will install devel package itself