Bug 1940 - Failed to install Grub2
: Failed to install Grub2
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: x86_64 Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-19 15:28 MSD by Giorgio
Modified: 2015-01-21 15:51 MSK (History)
8 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Giorgio 2013-04-19 15:28:42 MSD
Description of problem: installation of GRUB 2 unsuccessful


Version-Release number of selected component (if applicable):


How reproducible: ever


Steps to Reproduce:
1. in dual boot system install from DVD, usb or external DVD reader

2. when installing boot loader a message appears:
"Failed to install Grub2: inappropriate ioctl for device. Try again?"

3. trying again nothing change

4. lack of boot loader avoid boot in Rosa
Comment 1 Aleksandr Kazantcev 2013-04-19 15:39:38 MSD
Did you install grub2 record to MBR? It may not work installed in partition.
Comment 2 Alexander Burmashev 2013-04-19 15:42:05 MSD
To provide a better output, you should boot system in live mode, start draklive-install from konsole and when installer fails to install bootloader, copy output from konsole and paste it here.
Comment 3 Denis Silakov 2013-04-19 15:50:30 MSD
This looks very similar to bug #1239.
Comment 4 Giorgio 2013-04-19 17:18:52 MSD
(In reply to comment #1)
> Did you install grub2 record to MBR? It may not work installed in partition.
I don't remember any choice about MBR, I installed in "default" mode.


(In reply to comment #3)
> This looks very similar to bug #1239.
May be, not sure because I can't read anything in the photo.


(In reply to comment #2)
> To provide a better output, you should boot system in live mode, start
> draklive-install from konsole and when installer fails to install
> bootloader, copy output from konsole and paste it here.
As soon as I'll have back the computer I'll try.
Comment 5 Vladimir Potapov 2013-08-28 09:06:49 MSD
I confirm the bug with friend's AMD computer and Fresh R1 586
Comment 6 Vladimir Potapov 2013-08-28 09:07:58 MSD
(In reply to comment #1)
> Did you install grub2 record to MBR? It may not work installed in partition.
Can't select "mbr" in interface
Comment 7 Vladimir Potapov 2013-08-28 09:09:03 MSD
(In reply to comment #2)
> To provide a better output, you should boot system in live mode, start
> draklive-install from konsole and when installer fails to install
> bootloader, copy output from konsole and paste it here.
In live mode draklive-install fail before grub2 setup
Comment 8 Aleksandr Kazantcev 2013-08-28 09:10:48 MSD
Install in MBR = install in sdX (like sda, sdb, etc). If you has gpt system install in automate mode not possible.
Comment 9 Aleksandr Kazantcev 2013-08-28 09:11:29 MSD
What fail? Before grub install there is similar coping file in HDD.
Comment 10 Vladimir Potapov 2013-08-28 12:47:30 MSD
(In reply to comment #8)
> Install in MBR = install in sdX (like sda, sdb, etc). If you has gpt system
> install in automate mode not possible.
only sda in case.
Comment 11 JDronova 2013-08-28 14:35:11 MSD
I had same issue while installing GNOME edition recently. I have two hard disks, /sda and /sdb. On /sdb I have WindowsXP and ROSA KDE so I was installing the GNOME ed to /sda but I thought it would be better to have GRUB installed on /sdb. So installing GNOME ed to some partitions on /sda I indicated /dev/sdb for the bootloader to be installed. So I got the same error, it could not install GRUB2 there.
Comment 12 Alexander Burmashev 2013-08-28 14:37:28 MSD
maybe the problem is with incorrect exit from windows, when NTFS parition was not correctly "closed" ?
Comment 13 JDronova 2013-08-28 14:56:09 MSD
Cannot say exactly but at that moment I haven't touched Windows for some months already, wine works fine in ROSA. But it seems to be closely related to the Windows installation on destination drive, since everybody affected by the bug have Windows on destination drives. Cannot say also if NTFS partition has to do something with it since I have ROSA KDE on that drive, too, and some file-store on reiserfs also. It makes 3 partitions in total on /dev/sdb.
Comment 14 Vladimir Potapov 2013-08-28 14:57:21 MSD
(In reply to comment #12)
> maybe the problem is with incorrect exit from windows, when NTFS parition
> was not correctly "closed" ?
No. I correct exit from windows. Marathon's grub setup without errors.
Comment 15 Alexander Burmashev 2013-08-28 15:01:28 MSD
Marathon has grub1, legacy grub. What may be ok for legacy grub is not ok for grub2.
Comment 16 JDronova 2013-08-28 15:13:35 MSD
Btw, after this error the ROSA KDE installation on /dev/sdb was broken. I reinstalled GNOME with GRUB on /dev/sda and after that it could nicely boot into Windows but could not boot into KDE. The problem resulted to be that UUID of the KDE partition specified in GRUB2 config was correct, so GRUB was working fine but after that the img of KDE system was searching for wrong UUID. I ran dracut from chroot on that partition and after that it was able to boot but with lots of errors from systemctl, which I could not defeat and fix. Hope this info helps. somehow.
Comment 17 Eugene Budanov 2013-09-29 17:20:47 MSD
Same problem at this config while installing ROSA Fresh R1:

Mainboard: ASUS P8H61Pro with EFI and two harddisks with 500 Gb and 1 Tb capacity.

ROSA was installed at first 500 Gb HDD with preinstalled Windows 7 Home Premium.

Disks configuration:

[root@localhost ~]# fdisk -l

Disk /dev/sda: 500.1 GB, 500107862016 bytes, 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x06b94949

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048      206847      102400    7  HPFS/NTFS/exFAT
/dev/sda2          206848   204799999   102296576    7  HPFS/NTFS/exFAT
/dev/sda3       204800000   831641599   313420800    7  HPFS/NTFS/exFAT
/dev/sda4       831643596   976768064    72562234+   5  Extended
Partition 4 does not start on physical sector boundary.
/dev/sda5       831643648   856826774    12591563+  83  Linux
/dev/sda6       856829952   865003859     4086954   82  Linux swap / Solaris
/dev/sda7       865007616   976768064    55880224+  83  Linux

Disk /dev/sdc: 1000.2 GB, 1000204886016 bytes, 1953525168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xc3145809

   Device Boot      Start         End      Blocks   Id  System
/dev/sdc1        88148656  1953520064   932685704+   7  HPFS/NTFS/exFAT
/dev/sdc2   *          63    78156224    39078081    7  HPFS/NTFS/exFAT

Drive /dev/sdb this is installation flashdrive with ROSA.

After succesful installing of ROSa Grub2 not installed with ioctl error. Manual install of Grub2 using ROSA Wiki not help for me. Any ideas?
Comment 18 Alexander Burmashev 2013-09-29 17:31:43 MSD
If you boot in EFI mode, try this guide
http://wiki.rosalab.ru/ru/index.php/%D0%A3%D1%81%D1%82%D0%B0%D0%BD%D0%BE%D0%B2%D0%BA%D0%B0_ROSA_%D0%BD%D0%B0_EFI/UEFI
Comment 19 Denis Silakov 2013-10-01 14:53:58 MSD
*** Bug 1239 has been marked as a duplicate of this bug. ***
Comment 20 Denis Silakov 2013-10-01 14:54:52 MSD
*** Bug 1709 has been marked as a duplicate of this bug. ***
Comment 21 Denis Silakov 2013-10-01 14:56:24 MSD
*** Bug 2621 has been marked as a duplicate of this bug. ***
Comment 22 FirstLevel 2014-10-08 15:02:04 MSD
Please check the problem for new release
http://mirror.rosalab.ru/rosa/rosa2014.1/iso/ROSA.Fresh.R4/
Comment 23 Denis Silakov 2015-01-21 15:51:36 MSK
We believe that this issue is fixed since ROSA Desktop Fresh R4. At least the same problem on Asus Zenbook mentioned in bug #1239 has disappeared with modern ROSA releases.

If you still experience some problems with ROSA installation, feel free to reopen this bug or create a new one.