Bug 1934 - [NEWPACKAGE] qt5
: [NEWPACKAGE] qt5
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-17 10:54 MSD by Denis Koryavov
Modified: 2013-04-26 12:28 MSD (History)
3 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Denis Koryavov 2013-04-17 10:54:30 MSD
Description of problem:

Q5 package was build for ROSA Desktop Fresh 2012.
Comment 1 Denis Koryavov 2013-04-17 10:56:37 MSD
Advisory:

Q5 packages for ROSA Desktop Fresh 2012.

BuildLists:

Directfb (new version, necessary for QT5):
https://abf.rosalinux.ru/build_lists/1055285
https://abf.rosalinux.ru/build_lists/1055286


Q5:
https://abf.rosalinux.ru/build_lists/1055312
https://abf.rosalinux.ru/build_lists/1055313
Comment 2 Denis Koryavov 2013-04-19 13:57:43 MSD
UP
Comment 3 Denis Koryavov 2013-04-22 11:48:15 MSD
UP
Comment 4 Vladimir Potapov 2013-04-23 15:04:13 MSD
/usr/lib/qt5/bin/designer
Failed to load platform plugin "xcb". Available platforms are:
Comment 5 Denis Koryavov 2013-04-23 15:51:19 MSD
As far as I can see, you trying to run qt5 for x86_64 on the i586 system.
Comment 6 Vladimir Potapov 2013-04-23 16:18:48 MSD
(In reply to comment #5)
> As far as I can see, you trying to run qt5 for x86_64 on the i586 system.
No. Now I check x64 system, present same error.
Comment 7 Dmitry 2013-04-23 18:44:15 MSD
You have to install xcb platform plugin for Qt5 Gui. Install libqt5gui5-x11 package.
Comment 8 Vladimir Potapov 2013-04-23 18:48:12 MSD
(In reply to comment #7)
> You have to install xcb platform plugin for Qt5 Gui. Install libqt5gui5-x11
> package.
Hm. All you need for run must be install by requirements.
Comment 9 Dmitry 2013-04-23 18:48:35 MSD
And I dunno should this package be required or be suggested, because there are several platform plugins: xcb, linuxfb, directfb, minimal...
Comment 10 Vladimir Potapov 2013-04-23 18:54:11 MSD
(In reply to comment #9)
> And I dunno should this package be required or be suggested, because there
> are several platform plugins: xcb, linuxfb, directfb, minimal...

The mechanism for selection of requiremens exist -- you can use it.
Or you can choose one platform by default.
Comment 11 Denis Koryavov 2013-04-23 22:00:05 MSD
Try these:

Advisory:

Q5 packages for ROSA Desktop Fresh 2012.

BuildLists:

Directfb (new version, necessary for QT5):
https://abf.rosalinux.ru/build_lists/1055285
https://abf.rosalinux.ru/build_lists/1055286

Q5:
https://abf.rosalinux.ru/build_lists/1074693
https://abf.rosalinux.ru/build_lists/1074694

Polkit-qt5 (separate QT5 package):
https://abf.rosalinux.ru/build_lists/1073990
https://abf.rosalinux.ru/build_lists/1073991
Comment 12 Dmitry 2013-04-23 22:56:58 MSD
-1

Why have you decided to make your Qt5 instead of using Qt5 from openmandriva/qt5 (https://abf.rosalinux.ru/openmandriva/qt5)? It seems like there are several fixes for Qt5 in openmandriva/qt5.
Comment 13 Denis Koryavov 2013-04-23 23:29:28 MSD
Are you know problems in "our" (really it based on the latest from today OpenMandriva version) QT5 that is fixed in OpenMandriva?
Comment 14 Vladimir Potapov 2013-04-24 17:34:40 MSD
for i586

Failed to load platform plugin "xcb". Available platforms are: 

Аварийный останов (слепок снят)
Comment 15 Vladimir Potapov 2013-04-24 17:39:21 MSD
urpmi qt5-designer
/usr/lib/qt5/bin/designer
Failed to load platform plugin "xcb". Available platforms are: 

Аварийный останов (слепок снят)
Comment 16 Denis Koryavov 2013-04-25 16:57:39 MSD
Sorry. My fault. Now everything should be OK. Try these:

Advisory:

Q5 packages for ROSA Desktop Fresh 2012.

BuildLists:

Directfb (new version, necessary for QT5):
https://abf.rosalinux.ru/build_lists/1055285
https://abf.rosalinux.ru/build_lists/1055286

Q5:
https://abf.rosalinux.ru/build_lists/1075248
https://abf.rosalinux.ru/build_lists/1075249

Polkit-qt5 (separate QT5 package):
https://abf.rosalinux.ru/build_lists/1073990
https://abf.rosalinux.ru/build_lists/1073991
Comment 17 Vladimir Potapov 2013-04-25 17:41:57 MSD
libdirectfb1.6_0-1.6.2-3-rosa2012.1
qt5-designer-5.0.1-4-rosa2012.1
libpolkit-qt5-gui-1_1-0.103.1-2-rosa2012.1
********************** Advisory **************************
Q5 packages for ROSA Desktop Fresh 2012.
**********************************************************
QA Verified
Comment 18 Dmitry 2013-04-25 18:21:18 MSD
Have you tried to start Qt Linguist, some Qt examples ?
Comment 19 Alexander Burmashev 2013-04-25 19:14:22 MSD
Seems that Polkit-qt5 from the latest request is built not on the latest version of qt5 nad directfb ? Can you check it ?
Comment 20 Denis Koryavov 2013-04-25 19:25:00 MSD
Yes, but changes in the latest build are cosmetic (fixed buildrequires for several packages).
Comment 21 Alexander Burmashev 2013-04-25 19:33:06 MSD
The problem is that i physically can't publish it, because it is built on not published containers. Ok, since we cleared it out - i will rebuild it and republish, ok ?
Comment 22 Denis Koryavov 2013-04-25 19:47:12 MSD
Well, I already ran new builds. :) 

https://abf.rosalinux.ru/build_lists/1075397
https://abf.rosalinux.ru/build_lists/1075398