Bug 1887 - [drm:i915_hangcheck_hung] *ERROR* Hangcheck timer elapsed... GPU hung
: [drm:i915_hangcheck_hung] *ERROR* Hangcheck timer elapsed... GPU hung
Status: RESOLVED WORKSFORME
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-05 21:40 MSD by Denis Koryavov
Modified: 2014-03-30 23:58 MSD (History)
2 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream: known


Attachments
lspcidrake (2.75 KB, text/plain)
2013-04-05 21:40 MSD, Denis Koryavov
Details
dmesg (98.39 KB, text/plain)
2013-04-05 21:41 MSD, Denis Koryavov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Denis Koryavov 2013-04-05 21:40:46 MSD
Created attachment 1288 [details]
lspcidrake

Description of problem:

After some time working on the system I see this error in the logs:

Apr  2 13:27:16 laptop kernel: [12815.025127] [drm:i915_hangcheck_hung] *ERROR* Hangcheck timer elapsed... GPU hung
Apr  2 13:27:16 laptop kernel: [12815.025131] [drm] capturing error event; look for more information in /debug/dri/0/i915_error_state
Apr  2 13:27:16 laptop kernel: [12815.049680] traps: gnome-shell[32382] trap int3 ip:7fa4256aa9ff sp:7fff003e8e80 error:0
Apr  2 13:27:16 laptop [24123]: Process 32382 (gnome-shell) dumped core.
Apr  2 13:27:18 laptop kernel: [12817.123691] traps: gnome-shell[24124] trap int3 ip:7f5fee0179ff sp:7fff918f72b0 error:0
Apr  2 13:27:23 laptop [24173]: Process 24124 (gnome-shell) dumped core.


I tried many kernels (3.6.10, 3.8.2-laptop, 3.8.5-desktop) - nothing helps - the problems is still here.


Simular bugs on the Fedora and Ubuntu:

https://bugzilla.redhat.com/show_bug.cgi?id=879823
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1162007


Steps to Reproduce:
1.
2.
3.
Comment 1 Denis Koryavov 2013-04-05 21:41:31 MSD
Created attachment 1289 [details]
dmesg
Comment 2 Denis Koryavov 2013-04-05 21:44:09 MSD
The system very often "freezes" after that message in the log. And I can get back it to a "live" only by killing Xorg.
Comment 3 Denis Silakov 2013-04-08 20:54:49 MSD
This discussion indicates that downgrade of x11-driver-video-intel should help for now:

http://forums.gentoo.org/viewtopic-t-949868-start-0.html

(you can try x11-driver-video-intel-2.20.15 from main/release).

Let's hope this bug will be fixed at upstream soon, it is really widespread.
Comment 4 Denis Koryavov 2013-04-08 21:08:13 MSD
I have this driver installed, but this doesn't helps me. I've added 'i915.i915_enable_rc6=0 i915.i915_enable_fbc=0' options to the my GRUB boot parameters, let's check, will it help or not.
Comment 5 Aleksandr Kazantcev 2013-04-08 21:36:09 MSD
try latest driver

https://abf.rosalinux.ru/build_lists/1052212
https://abf.rosalinux.ru/build_lists/1052213
Comment 6 Denis Silakov 2014-03-30 23:58:53 MSD
No response for a long time and no similar reports, so let's close as 'worksforme'. Currently we have x11-driver-video-intel-2.21.15, though there is no clear indication if this version works ok on problematic cards or not.

Feel free to reopen the bug if you are able to reproduce the issue.