Bug 1882 - MandrivaUpdate SEGV's during regular update
: MandrivaUpdate SEGV's during regular update
Status: RESOLVED WORKSFORME
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: x86_64 Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-05 11:34 MSD by mayavimmer
Modified: 2013-06-03 12:42 MSD (History)
2 users (show)

See Also:
RPM Package: rpmdrake
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mayavimmer 2013-04-05 11:34:13 MSD
Description of problem:

MandrivaUpdate SEGV's during regular update. Also Drakbug failed to invoke the navigator due to including the entire stack trace in the URL, thus making it too long -- but this will be the subject of another bug report. Here is Drakbug's attempted automatic stack trace in an IT locale:

-----
Il programma "MandrivaUpdate" si è interrotto(SEGV) per questo errore:

  SEGV
  Glibc's trace:
  4: /usr/lib/perl5/5.14.2/x86_64-linux-thread-multi/CORE/libperl.so(Perl_sighandler+0x1e5) [0x7ff26ba27235]
  5: /lib64/libc.so.6(+0x35b20) [0x7ff26b607b20]
  6: /usr/lib64/librpmio-5.4.so(rpmioPutPool+0x31) [0x7ff2669eed51]
  7: /usr/lib64/librpm-5.4.so(+0x4fbea) [0x7ff266f8fbea]
  8: /usr/lib64/librpmio-5.4.so(rpmioFreePoolItem+0x10c) [0x7ff2669eeecc]
  9: /usr/lib64/librpm-5.4.so(rpmtsEmpty+0x6b) [0x7ff266f92a1b]
  10: /usr/lib/perl5/vendor_perl/5.14.2/x86_64-linux-thread-multi/auto/URPM/URPM.so(XS_URPM__Transaction_run+0x40e) [0x7ff26740cb0e]
  11: /usr/lib/perl5/5.14.2/x86_64-linux-thread-multi/CORE/libperl.so(Perl_pp_entersub+0x57c) [0x7ff26ba401bc]
  12: /usr/lib/perl5/5.14.2/x86_64-linux-thread-multi/CORE/libperl.so(Perl_runops_standard+0x16) [0x7ff26ba377a6]
  13: /usr/lib/perl5/5.14.2/x86_64-linux-thread-multi/CORE/libperl.so(Perl_call_sv+0x45b) [0x7ff26b9d34eb]
  14: /usr/lib/perl5/vendor_perl/5.14.2/x86_64-linux-thread-multi/auto/Glib/Glib.so(+0x27d21) [0x7ff260a80d21]
  15: /lib64/libgobject-2.0.so.0(g_closure_invoke+0x190) [0x7ff26081b140]
  16: /lib64/libgobject-2.0.so.0(+0x21550) [0x7ff26082c550]
  17: /lib64/libgobject-2.0.so.0(g_signal_emit_valist+0xdaf) [0x7ff2608344af]
  18: /lib64/libgobject-2.0.so.0(g_signal_emit+0x82) [0x7ff260834642]
  19: /usr/lib64/libgtk-x11-2.0.so.0(+0x8d4d5) [0x7ff25b2094d5]
  
  Perl's trace:
  standalone::bug_handler() called from /usr/lib/libDrakX/standalone.pm:225
  standalone::__ANON__() called from /usr/lib/perl5/vendor_perl/5.14.2/urpm/install.pm:293
  (eval)() called from /usr/lib/perl5/vendor_perl/5.14.2/urpm/install.pm:293
  urpm::install::install() called from /usr/lib/perl5/vendor_perl/5.14.2/urpm/main_loop.pm:288
  ::urpm::main_loop::run() called from /usr/lib/perl5/vendor_perl/5.14.2/Rpmdrake/pkg.pm:876
  Rpmdrake::pkg::perform_installation() called from /usr/lib/perl5/vendor_perl/5.14.2/Rpmdrake/gui.pm:953
  Rpmdrake::gui::do_action__real() called from /usr/lib/perl5/vendor_perl/5.14.2/Rpmdrake/gui.pm:968
  (eval)() called from /usr/lib/perl5/vendor_perl/5.14.2/Rpmdrake/gui.pm:968
  Rpmdrake::gui::do_action() called from /usr/sbin/MandrivaUpdate:192
  main::__ANON__() called from /usr/lib/libDrakX/mygtk2.pm:1426
  (eval)() called from /usr/lib/libDrakX/mygtk2.pm:1426
  mygtk2::main() called from /usr/lib/libDrakX/ugtk2.pm:767
  ugtk2::main() called from /usr/sbin/MandrivaUpdate:274
  main::run_treeview_dialog() called from /usr/sbin/MandrivaUpdate:285

Usato il tema: elementary

Per inviare una segnalazione di bug, clicca sul pulsante Segnalazione.
Si aprirà un browser web su Bugzilla dove troverai un modulo da compilare. Le informazioni mostrate qui sopra verranno inviate a quel server.
Sarebbe utile aggiungere alla tua segnalazione l'output del seguente comando: 'lspcidrake -v'.
-----

Here is my description with the suggested lspcidrake -v:

-----
The crash happened while performing a regular update. My system has plenty of resources available: CPU almost idle, df = 700MB.

$ lspcidrake -v
r8169           : Realtek Semiconductor Co., Ltd.|RTL8111/8168B PCI Express Gigabit Ethernet controller [NETWORK_ETHERNET] (vendor:10ec device:8168 subv:1458 subd:e000) (rev: 06)
i2c_i801        : Intel Corporation|7 Series/C210 Series Chipset Family SMBus Controller [SERIAL_SMBUS] (vendor:8086 device:1e22 subv:1458 subd:5001) (rev: 04)
ahci            : Intel Corporation|7 Series/C210 Series Chipset Family 6-port SATA Controller [AHCI mode] [STORAGE_SATA] (vendor:8086 device:1e02 subv:1458 subd:b005) (rev: 04)
lpc_ich         : Intel Corporation|B75 Express Chipset LPC Controller [BRIDGE_ISA] (vendor:8086 device:1e49 subv:1458 subd:5001) (rev: 04)
unknown         : Intel Corporation|82801 PCI Bridge [BRIDGE_PCI] (vendor:8086 device:244e) (rev: a4)
ehci_hcd        : Intel Corporation|7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 [SERIAL_USB] (vendor:8086 device:1e26 subv:1458 subd:5006) (rev: 04)
shpchp          : Intel Corporation|7 Series/C210 Series Chipset Family PCI Express Root Port 5 [BRIDGE_PCI] (vendor:8086 device:1e18) (rev: c4)
shpchp          : Intel Corporation|7 Series/C210 Series Chipset Family PCI Express Root Port 1 [BRIDGE_PCI] (vendor:8086 device:1e10) (rev: c4)
snd_hda_intel   : Intel Corporation|7 Series/C210 Series Chipset Family High Definition Audio Controller [MULTIMEDIA_AUDIO_DEV] (vendor:8086 device:1e20 subv:1458 subd:a002) (rev: 04)
ehci_hcd        : Intel Corporation|7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 [SERIAL_USB] (vendor:8086 device:1e2d subv:1458 subd:5006) (rev: 04)
mei             : Intel Corporation|7 Series/C210 Series Chipset Family MEI Controller #1 [COMMUNICATION_OTHER] (vendor:8086 device:1e3a subv:1458 subd:1c3a) (rev: 04)
xhci_hcd        : Intel Corporation|7 Series/C210 Series Chipset Family USB xHCI Host Controller [SERIAL_USB] (vendor:8086 device:1e31 subv:1458 subd:5007) (rev: 04)
i915            : Intel Corporation|Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller [DISPLAY_VGA] (vendor:8086 device:0152 subv:1458 subd:d000) (rev: 09)
unknown         : Intel Corporation|Xeon E3-1200 v2/3rd Gen Core processor DRAM Controller [BRIDGE_HOST] (vendor:8086 device:0150 subv:1458 subd:5000) (rev: 09)
hub             : Linux 3.6.10-nrj-desktop-1rosa ehci_hcd|EHCI Host Controller [Hub|Unused|Full speed (or root) hub] (vendor:1d6b device:0002)
hub             : Intel Corp.|Integrated Rate Matching Hub [Hub|Unused|Full speed (or root) hub] (vendor:8087 device:0024)
hub             : Linux 3.6.10-nrj-desktop-1rosa ehci_hcd|EHCI Host Controller [Hub|Unused|Full speed (or root) hub] (vendor:1d6b device:0002)
hub             : Intel Corp.|Integrated Rate Matching Hub [Hub|Unused|Full speed (or root) hub] (vendor:8087 device:0024)
usbhid          : Textech International Ltd.|USB Optical Mouse [Human Interface Device|Boot Interface Subclass|Mouse] (vendor:15ca device:00c3)
hub             : Linux 3.6.10-nrj-desktop-1rosa xhci_hcd|xHCI Host Controller [Hub|Unused|Full speed (or root) hub] (vendor:1d6b device:0003)
hub             : Linux 3.6.10-nrj-desktop-1rosa xhci_hcd|xHCI Host Controller [Hub|Unused|Full speed (or root) hub] (vendor:1d6b device:0002)
hid_generic     : USB Optical Mouse
-----

Note that notwithstanding the crash, MandrivaUpdate seems to have carried out its task, which was probably to install these two packages:

mozilla-thunderbird-17.0.5-69.1-mib2012.1.x86_64
mozilla-thunderbird-it-17.0.5-69.1-mib2012.1.noarch

It crashed before updating to the following package, which it subsequently do without error:

mozilla-thunderbird-en_GB-17.0.5-69.1-mib2012.1.noarch


Version-Release number of selected component (if applicable):

rpmdrake-5.26.12-14-rosa2012.1.noarch

How reproducible:

Only happened once. I cannot reproduce the exact state of the system because the RPM db was modified by the update.

Steps to Reproduce:
1. Launch MandrivaUpdate
2. See Drakbug's bug reporting window instead of the completed MandrivaUpdate window.
3. Drakbug also fails, but that's probably an independent bug I reported separately.
Comment 1 Aleksandr Kazantcev 2013-04-05 11:49:08 MSD
We push big update for usermod and set MandrivaUpdate download all package befor install for default (see new options in rpmdrake menu).

In that fact you need free space in HDD for properly update.

Also you may simple run 

 urpmi --auto-update

P.S. If you use non-standart repo (mib2012.1) problem may appear for it using - try get help on MIB forum - in standart ROSA repo all work OK.

-
Comment 2 Denis Silakov 2013-06-03 12:42:40 MSD
The problem should not rise anymore. We have also changed urpmi default behavior to download all packages before installation, so users with default configuration should not experience any problems if we perform similar big updates in future.