Bug 1865 - Printing from Firefox and Chromium to Brother DCP7057W is ending abnormally
: Printing from Firefox and Chromium to Brother DCP7057W is ending abnormally
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-03 12:36 MSD by FirstLevel
Modified: 2015-06-17 19:20 MSD (History)
5 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments
Diagnostic information (2.08 KB, text/plain)
2013-04-03 12:36 MSD, FirstLevel
Details
error_cups.txt (13.00 KB, text/plain)
2013-04-03 12:37 MSD, FirstLevel
Details
Trouble report to Brother (12.37 KB, text/plain)
2013-06-05 07:24 MSD, Rolf Pedersen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2013-04-03 12:36:42 MSD
Created attachment 1285 [details]
Diagnostic information

Description of problem:
I have installed ROSA 2012.1 Fresh and plugged printer Brother DCP7057W. It works well from most of programs. But If I print from browsers (Firefox and Chromium) the print task is ending abnormally
"Простаивает - /usr/lib/cups/filter/pdftops failed"
I have attached some diagnostic information and errors for cups service.
Same problem is described https://bugs.mageia.org/show_bug.cgi?id=6819

This articles are described that problem is depends on libpoppler.
http://forums.opensuse.org/english/get-technical-help-here/applications/481656-usr-lib-cups-filter-pdftops-failed-webbrowser.html
https://bugs.archlinux.org/task/30021


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 FirstLevel 2013-04-03 12:37:05 MSD
Created attachment 1286 [details]
error_cups.txt
Comment 2 Rolf Pedersen 2013-04-03 20:54:08 MSD
I'm here to report the same problem.  Running up-to-date ROSA Desktop.Fresh release 2012.1 (Desktop) for x86_64, Brother MFC665CW, cups-1.5.4-2.1-rosa2012.1.x86_64

https://bugzilla.novell.com/show_bug.cgi?id=795582#c23 shows the opensuse resolution in poppler-tools.  FWIW, I downloaded the update, http://download.opensuse.org/update/12.2/x86_64/poppler-tools-0.20.0-2.2.1_2.9.1.x86_64.drpm and looked inside with mc.  Here is a screenie of some clues, perhaps:
https://dl.dropbox.com/u/1286780/images/poppler-tools-drm.jpeg

I've seen poppler causing problems with CUPS printing before.
Thanks.
Comment 3 Sergey Zhemoitel 2013-04-03 21:07:24 MSD
I build poppler 0.22.2 version now in ABF-rosa for 2012.1. If it is possible building I will try to collect test.
Comment 4 Sergey Zhemoitel 2013-04-04 14:11:22 MSD
i build in http://abf.rosalinux.ru/downloads/djam_personal/container/1049816/ poppler 0.22.2 and testing it

Yes, fix it problem, and fix problem printing in kmail (http://bugs.rosalinux.ru/show_bug.cgi?id=1866).

Пересобранный пакет с выключенными патчами и gobject-inetspection дает превосходный результат и при этом закрывается как проблема печати из браузеров так и печать из kmail (http://bugs.rosalinux.ru/show_bug.cgi?id=1866)
Comment 5 Denis Silakov 2013-04-05 13:12:59 MSD
Poppler update should be done very carefully - there are a lot of packages that should be rebuilt and tested after it, because soname of libpooppler library was changed in the new release.
Comment 6 Sergey Zhemoitel 2013-04-05 21:24:14 MSD
Ok. Yes, i understand it.
Comment 7 Sergey Zhemoitel 2013-04-05 21:30:20 MSD
but, with the version 0.22 the error persists now, and it does not print out all the programs using the filter pdftops!
Comment 8 Rolf Pedersen 2013-04-09 19:41:24 MSD
I added the repo as 
# urpmi.addmedia tmp http://abf.rosalinux.ru/downloads/djam_personal/container/1049816/x86_64/main/release/

Then, updating poppler brought in
poppler-data-0.4.4-3-rosa2012.1.noarch   
poppler-0.22.2-1-rosa2012.1.x86_64       
lib64poppler35-0.22.2-1-rosa2012.1.x86_64

There are still problems but it's hard to specify under what conditions.  Initially, the most obvious problem was printing from various https website account payment "Print Receipt" pop-up windows, which would frequently fail.  Another symptom that I have not seen before is partial printing:
The end of the print job fades out.  If I take a screenshot of the page at issue, the picture prints completely.  It might be the data size of the job determines whether it prints fully or not.  Of course, there might be some new issue with the Brother drivers being exposed and I've re-installed the drivers.  There might be some better reliability on these browser-sourced print jobs by some small amount since these changes but one such "Print Receipt" pop-up job just printed about 40% of the top of the receipt; the rest was blank.
My workaround is "Print to file" in the Seamonkey print dialog, print to a .ps file, do ps2pdf on that file, open the pdf in okular, then print from okular.  That seems to work pretty reliably.

Thanks.
Comment 9 Sergey Zhemoitel 2013-04-09 19:56:47 MSD
print to file -> ps2pdf -> okular printing

iit is no good idea
Comment 10 Rolf Pedersen 2013-04-09 20:07:50 MSD
(In reply to comment #9)
> print to file -> ps2pdf -> okular printing
> 
> iit is no good idea

No, I don't like this but I don't have much choice, at this time.
Comment 11 Denis Silakov 2013-04-21 10:06:26 MSD
I've pushed a request for poppler update - bug #1942.

As an experiment, you can install packages from containers mentioned in that bug.
Comment 12 Ben Bullard 2013-04-26 21:51:36 MSD
I had this issue with a HP photosmart 6520 printer in Firefox and Thunderbird.
Installing poppler and libpoppler35 packages from:

http://abf.rosalinux.ru/downloads/djam_personal/container/1049816/

corrected my problem.
Comment 13 Rolf Pedersen 2013-06-05 07:24:28 MSD
Created attachment 1495 [details]
Trouble report to Brother

I've been working with this.  For one test case, the fade-out printing in my perl script envelope program, at least, I can get expected results in an installation of Mandriva Linux release 2011.0 (Official) for x86_64 on another machine.  I think I have eliminated the printer and Brother Linux drivers as the source of this problem.  On the machine with the problem, I get good print results with Brother drivers on XP in Virtualbox, so I'd say the machine is not the problem.

The attached text file contains the content of a trouble report to Brother. Mostly, it's the perl script.  There are a few other comments about my observations but I'd say the best clue I have to date is the success I had on the MDV 2011 box.

I did try installing/downgrading on my Rosa installation to all the poppler-related packages on that machine.  That didn't help, afaict:

file-5.11-0.1-mdv2011.0.x86_64                Tue 04 Jun 2013 07:31:53 PM PDT
poppler-data-0.4.4-2-mdv2011.0.noarch         Tue 04 Jun 2013 07:30:25 PM PDT
lib64poppler-qt4-3-0.16.7-1-mdv2011.0.x86_64  Tue 04 Jun 2013 07:27:34 PM PDT
poppler-0.16.7-1-mdv2011.0.x86_64             Tue 04 Jun 2013 07:23:00 PM PDT
lib64poppler-glib6-0.16.7-1-mdv2011.0.x86_64  Tue 04 Jun 2013 07:23:00 PM PDT
lib64poppler13-0.16.7-1-mdv2011.0.x86_64      Tue 04 Jun 2013 07:17:06 PM PDT
lib64openjpeg2-1.3-8.2-mdv2011.0.x86_64       Tue 04 Jun 2013 07:17:05 PM PDT

Thanks.
Comment 14 FirstLevel 2014-10-08 15:57:10 MSD
Please check the problem for our new release
http://mirror.rosalab.ru/rosa/rosa2014.1/iso/ROSA.Fresh.R4/
Comment 15 Sergey Zhemoitel 2015-01-12 18:30:40 MSK
up
Comment 16 Rolf Pedersen 2015-01-12 18:51:45 MSK
$ cat /etc/release
ROSA Desktop Fresh R5 release 2014.1 for x86_64

I've changed to a Brother MFC-685CW but my guess is that model is not relevant.

Printing in ROSA has not been fatally problematic for some time.  I say "fatally" as my aggravations come from driver/interaction with applications, imo.  Printing is functional, essentially.
Thanks.
Comment 17 Denis Silakov 2015-05-28 11:21:47 MSD
poppler has been updated severl times since the time this bug was created and the poppler issues mentioned here should be fixed for a long time.

In addition to that problems, we had an issue with cups-filters in R4/R5 that could prevent some applications from printing. Fix for cups filter is currently tested by our QA (see bug #5627). It would be nice if somebody can say if that fixes help with the current bug.
Comment 18 Sergey Zhemoitel 2015-05-28 12:06:43 MSD
попробую прогнать на своих железках
Comment 19 Denis Silakov 2015-06-17 19:20:09 MSD
At least some of the printers mentioned in this bug should finally work fine now, with modern poppler and cups-filters. If some of them still fail - please open new bugs, since this one can become a mess of different issues.