Bug 1840 - Lazarus could not start
: Lazarus could not start
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-28 09:58 MSK by FirstLevel
Modified: 2013-05-21 12:22 MSD (History)
4 users (show)

See Also:
RPM Package: lazarus-0.9.30.1.32070-5-rosa.lts2012.0.i586
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments
hanging lazarus (62.88 KB, image/png)
2013-03-28 09:58 MSK, FirstLevel
Details
~.lazarus (10.44 KB, application/gzip)
2013-03-28 09:58 MSK, FirstLevel
Details
/etc/lazarus (584 bytes, application/gzip)
2013-03-28 09:58 MSK, FirstLevel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2013-03-28 09:58:01 MSK
Created attachment 1277 [details]
hanging lazarus

Description of problem:
I have installed ROSA 2012 LTS ant try to start lazarus. But it is hanging on start (screenshot is attached).
I have such output when it is hanging:
[leonid@Comp Nosovy ~]$ ps -e | grep lazarus
31546 ?        00:00:01 startlazarus
31547 ?        00:00:02 lazarus

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 FirstLevel 2013-03-28 09:58:33 MSK
Created attachment 1278 [details]
~.lazarus
Comment 2 FirstLevel 2013-03-28 09:58:48 MSK
Created attachment 1279 [details]
/etc/lazarus
Comment 3 Denis Silakov 2013-03-29 14:45:19 MSK
Seems to be a known problem with old Lazarus. Backport of newer Lazarus from Desktop Fresh should help.
Comment 4 Denis Silakov 2013-04-08 21:00:07 MSD
Uh, when trying to backport fpc from Desktop Fresh, we are hitting a very rare segfault in urpmi - https://abf.rosalinux.ru/import/fpc/build_lists.

A significant update of urpmi in Marathon is ongoing, so let's wait for the updated urpmi to be available.
Comment 5 Denis Silakov 2013-05-20 12:26:55 MSD
Advisory:

Updated fpc to 2.6.0 and Lazarus to 1.0.1 to fix issues with Lazarus hanging at startup.

Build lists:
(fpc)
https://abf.rosalinux.ru/build_lists/1098332
https://abf.rosalinux.ru/build_lists/1098331

(lazarus)
https://abf.rosalinux.ru/build_lists/1098334
https://abf.rosalinux.ru/build_lists/1098333
Comment 6 Vladimir Potapov 2013-05-21 12:11:55 MSD
fpc-2.6.0-2-rosa.lts2012.0
lazarus-1.0.1.20120905-7-rosa.lts2012.0
*************************** Advisory ****************************
Fpc updated to 2.6.0 and Lazarus updated to 1.0.1 to fix issues with Lazarus hanging at startup.
*****************************************************************
QA Verified