Bug 1839 - Error occured while executing createrepo command
: Error occured while executing createrepo command
Status: RESOLVED WONTFIX
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Contributed Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-28 09:41 MSK by FirstLevel
Modified: 2013-03-28 13:00 MSK (History)
3 users (show)

See Also:
RPM Package: createrepo-0.9.9-3-rosa2012.1.noarch
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2013-03-28 09:41:07 MSK
Description of problem:
I have installed ROSA 2012.1 Fresh.
In some catalog I have several rpm packages. But if I execute
createrepo .
in such catalog I have an error
# createrepo .
Traceback (most recent call last):
  File "/usr/share/createrepo/genpkgmetadata.py", line 275, in <module>
    main(sys.argv[1:])
  File "/usr/share/createrepo/genpkgmetadata.py", line 239, in main
    callback=MDCallBack())
  File "/usr/lib/python2.7/site-packages/createrepo/__init__.py", line 138, in __init__
    self.ts = rpmUtils.transaction.initReadOnlyTransaction()
  File "/usr/lib/python2.7/site-packages/rpmUtils/transaction.py", line 180, in initReadOnlyTransaction
    read_ts.pushVSFlags((rpm._RPMVSF_NOSIGNATURES|rpm._RPMVSF_NODIGESTS))
AttributeError: 'module' object has no attribute '_RPMVSF_NOSIGNATURES'




Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 Aleksandr Kazantcev 2013-03-28 10:01:13 MSK
Use genhdlist2 instead
Comment 2 FirstLevel 2013-03-28 10:03:07 MSK
(In reply to comment #1)
> Use genhdlist2 instead

Is is final solution?
Comment 3 Aleksandr Kazantcev 2013-03-28 10:05:45 MSK
For now yes - this is contributed package and we not maintain it + createrepo not used in ROSA anymore i think - it's create repodata for Fedora Yum, not ROSA urpmi.
Comment 4 FirstLevel 2013-03-28 10:15:15 MSK
(In reply to comment #3)
> For now yes - this is contributed package and we not maintain it +
> createrepo not used in ROSA anymore i think - it's create repodata for
> Fedora Yum, not ROSA urpmi.

But user wants to create exactly YUM repo.
Comment 5 Alexander Burmashev 2013-03-28 12:03:40 MSK
That is the problem, because we do not officially support yum and createrepo.
Comment 6 FirstLevel 2013-03-28 12:45:52 MSK
(In reply to comment #5)
> That is the problem, because we do not officially support yum and createrepo.

Hmmm. But if I create bug I may to choose Component - "Contributed Packages". What does it mean?
Comment 7 Alexander Burmashev 2013-03-28 12:53:37 MSK
It means that you can fill a bug against a contributed package.
Comment 8 FirstLevel 2013-03-28 12:57:15 MSK
(In reply to comment #7)
> It means that you can fill a bug against a contributed package.

Ok. The status is "Resolved"- "Wonfix". Am I right?
Comment 9 Alexander Burmashev 2013-03-28 12:58:29 MSK
Yes, at least for now.
Maybe in some future this bug will be resolved, but unfortunately not now.