Bug 1790 - Postfix overmounts root dev??
: Postfix overmounts root dev??
Status: RESOLVED WORKSFORME
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-18 15:33 MSK by FirstLevel
Modified: 2016-08-17 00:40 MSD (History)
3 users (show)

See Also:
RPM Package: postfix-2.9.4-2-rosa2012.1.x86_64
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2013-03-18 15:33:45 MSK
Description of problem:
After installing Postfix and Courier I see a scary looking Postfix authdaemon dir mounted on my root device! "Df" command gives:

Filesystem      Size  Used Avail Use% Mounted on
rootfs           21G  4.8G   15G  26% /
/dev/sda17       21G  4.8G   15G  26% /
/dev/sda17       21G  4.8G   15G  26% /var/spool/postfix/var/lib/authdaemon

Everything seems to work for now, but the above looks dangerous.

More info in my forum entry at:

http://forum.rosalab.ru/viewtopic.php?f=33&t=1851&p=14458#p14458

Is this normal? Is it dangerous? If not, how can I fix it?
Since the installation is on a remote machine, can I fix this in a non disruptive way?

[root@localhost ~]# cat /etc/fstab |grep authdaemon
[root@localhost ~]# mount |grep authdaemon
/dev/sda17 on /var/spool/postfix/var/lib/authdaemon type ext4 (rw,relatime,data=ordered)

I suspect courier-authdaemon is messing with postfix and trying to hard link incorrectly in the start() section of /etc/rc.d/init.d/courier-authdaemon.

[root@localhost home]# grep -C2 mount /etc/rc.d/init.d/courier-authdaemon
        fi
        gprintf "re-mouting %s in postfix chroot\n" "$authdaemonvar"
        mount $authdaemonvar $PFDIR$authdaemonvar -o bind
    fi
}
--
    if [ -d $PFDIR ]; then
        gprintf "unmouting %s from %s%s\n" "$authdaemonvar" "$PFDIR" "$authdaemonvar"
        umount $PFDIR$authdaemonvar
    fi
}

[root@localhost home]# rpm -qa |grep courier
courier-authlib-devel-0.65.0-1-rosa2012.1.x86_64
courier-authlib-0.65.0-1-rosa2012.1.x86_64
courier-base-4.11.0-1-rosa2012.1.x86_64
courier-authdaemon-0.65.0-1-rosa2012.1.x86_64
courier-imap-4.11.0-1-rosa2012.1.x86_64

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 FirstLevel 2014-06-03 15:46:21 MSD
checking the relevance
Comment 2 FirstLevel 2014-06-03 22:26:12 MSD
Case is actual
Comment 3 Denis Silakov 2016-08-17 00:40:21 MSD
It looks like this issue went away long ago in rosa2014.1.